diff options
author | Javier Viguera <javier.viguera@digi.com> | 2013-05-21 16:17:06 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2013-05-22 10:43:31 -0300 |
commit | b93c40348cdcb0022f4315edc1b9cb7474253b1e (patch) | |
tree | 6296213fb3d3c7ed6c7ebf4bb1f7736173e2392d | |
parent | 87baff82973eb26086d22532ff5f41a643ef98b5 (diff) | |
download | meta-fsl-arm-b93c40348cdcb0022f4315edc1b9cb7474253b1e.tar.gz |
gst-fsl-plugin: fix segfault due to not found library
The gst-fsl-plugin package tries to 'dlopen' a library using the
symbolic link that points to the library file. But that symbolic link is
only installed with the development package (PN-dev), not with the
normal package.
This commit adds a patch that uses the soname of the library in dlopen
call.
Signed-off-by: Javier Viguera <javier.viguera@digi.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-multimedia/gst-plugins/gst-fsl-plugin/Use-librarys-SONAME-in-dlopen.patch | 29 | ||||
-rw-r--r-- | recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.3.bb | 5 |
2 files changed, 32 insertions, 2 deletions
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin/Use-librarys-SONAME-in-dlopen.patch b/recipes-multimedia/gst-plugins/gst-fsl-plugin/Use-librarys-SONAME-in-dlopen.patch new file mode 100644 index 0000000..6349844 --- /dev/null +++ b/recipes-multimedia/gst-plugins/gst-fsl-plugin/Use-librarys-SONAME-in-dlopen.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From: Javier Viguera <javier.viguera@digi.com> | ||
2 | Date: Tue, 21 May 2013 16:52:52 +0200 | ||
3 | Subject: [PATCH] Use library's SONAME in dlopen | ||
4 | |||
5 | The 'libmfwba.so' symbolic link is only installed with the development | ||
6 | package, and without that symlink some gstreamer pipelines (mostly using | ||
7 | mfw_isink) fail with: | ||
8 | |||
9 | Can not open dll, libmfwba.so: cannot open shared object file: No such file or directory. | ||
10 | Caught SIGSEGV accessing address (nil) | ||
11 | |||
12 | Signed-off-by: Javier Viguera <javier.viguera@digi.com> | ||
13 | --- | ||
14 | libs/vss/vss_common.c | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/libs/vss/vss_common.c b/libs/vss/vss_common.c | ||
18 | index 757c2fc..2044051 100755 | ||
19 | --- a/libs/vss/vss_common.c | ||
20 | +++ b/libs/vss/vss_common.c | ||
21 | @@ -86,7 +86,7 @@ static void * g_dlhandle = NULL; | ||
22 | void open_allocator_dll() | ||
23 | { | ||
24 | char * errstr; | ||
25 | - g_dlhandle = dlopen("libmfwba.so", RTLD_LAZY); | ||
26 | + g_dlhandle = dlopen("libmfwba.so.0", RTLD_LAZY); | ||
27 | |||
28 | if (!g_dlhandle) { | ||
29 | printf("Can not open dll, %s.\n", dlerror()); | ||
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.3.bb b/recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.3.bb index dea6ed3..cbfee09 100644 --- a/recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.3.bb +++ b/recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.3.bb | |||
@@ -5,10 +5,11 @@ require gst-fsl-plugin.inc | |||
5 | DEPENDS += "fsl-mm-codeclib fsl-mm-flv-codeclib fsl-mm-mp3enc-codeclib" | 5 | DEPENDS += "fsl-mm-codeclib fsl-mm-flv-codeclib fsl-mm-mp3enc-codeclib" |
6 | RDEPENDS_${PN} = "fsl-mm-codeclib fsl-mm-flv-codeclib fsl-mm-mp3enc-codeclib" | 6 | RDEPENDS_${PN} = "fsl-mm-codeclib fsl-mm-flv-codeclib fsl-mm-mp3enc-codeclib" |
7 | 7 | ||
8 | PR = "${INC_PR}.3" | 8 | PR = "${INC_PR}.4" |
9 | 9 | ||
10 | SRC_URI += "file://fix_segment_fault_in_v4lsink_for_yocto.patch \ | 10 | SRC_URI += "file://fix_segment_fault_in_v4lsink_for_yocto.patch \ |
11 | file://fix-missing-sys-types-h.patch" | 11 | file://fix-missing-sys-types-h.patch \ |
12 | file://Use-librarys-SONAME-in-dlopen.patch" | ||
12 | 13 | ||
13 | SRC_URI[md5sum] = "036a8e86031b0670f41b10796e268f9e" | 14 | SRC_URI[md5sum] = "036a8e86031b0670f41b10796e268f9e" |
14 | SRC_URI[sha256sum] = "ee024e6fe94ce309b10dc89ab247d1bbcf8ae9cc8006178c96101ce2d4d164a0" | 15 | SRC_URI[sha256sum] = "ee024e6fe94ce309b10dc89ab247d1bbcf8ae9cc8006178c96101ce2d4d164a0" |