diff options
-rw-r--r-- | recipes-bsp/qe-ucode/qe-ucode_git.bb | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/qe-ucode/qe-ucode_git.bb b/recipes-bsp/qe-ucode/qe-ucode_git.bb new file mode 100644 index 0000000..28af4b6 --- /dev/null +++ b/recipes-bsp/qe-ucode/qe-ucode_git.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | DESCRIPTION = "qe microcode binary" | ||
2 | SECTION = "qe-ucode" | ||
3 | LICENSE = "Freescale-EULA" | ||
4 | LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c" | ||
5 | |||
6 | inherit deploy | ||
7 | |||
8 | SRC_URI = "git://git.freescale.com/ppc/sdk/qe-ucode.git;nobranch=1" | ||
9 | SRCREV= "49efc94b553de5c2a9bd28093592eff0068e161c" | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | python () { | ||
14 | if not d.getVar("QE_UCODE", True): | ||
15 | PN = d.getVar("PN", True) | ||
16 | FILE = os.path.basename(d.getVar("FILE", True)) | ||
17 | bb.debug(1, "To build %s, see %s for instructions on \ | ||
18 | setting up your qe-ucode" % (PN, FILE)) | ||
19 | raise bb.parse.SkipPackage("because QE_UCODE is not set") | ||
20 | } | ||
21 | |||
22 | do_install () { | ||
23 | install -d ${D}/boot | ||
24 | install -m 644 ${QE_UCODE} ${D}/boot | ||
25 | } | ||
26 | |||
27 | do_deploy () { | ||
28 | install -d ${DEPLOYDIR}/boot | ||
29 | install -m 644 ${QE_UCODE} ${DEPLOYDIR}/boot | ||
30 | } | ||
31 | addtask deploy before do_build after do_install | ||
32 | |||
33 | PACKAGES += "${PN}-image" | ||
34 | FILES_${PN}-image += "/boot/*" | ||
35 | ALLOW_EMPTY_${PN} = "1" | ||
36 | COMPATIBLE_MACHINE = "(ls102xa)" | ||