diff options
-rw-r--r-- | openembedded-layer/recipes-kernel/asf/asf_git.bb | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-kernel/asf/asf_git.bb b/openembedded-layer/recipes-kernel/asf/asf_git.bb new file mode 100644 index 0000000..676c547 --- /dev/null +++ b/openembedded-layer/recipes-kernel/asf/asf_git.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | DESCRIPTION = "Non-DPAA software Application Specific Fast-path" | ||
2 | SECTION = "asf" | ||
3 | LICENSE = "GPLv2 & GPLv2+ & BSD" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287" | ||
5 | |||
6 | SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=sdk-v1.7.x" | ||
7 | SRCREV = "16eb472d6b2b34c8b605a86c469611bc8ddec1c9" | ||
8 | |||
9 | inherit module | ||
10 | |||
11 | S = "${WORKDIR}/git/asfmodule" | ||
12 | |||
13 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}" | ||
14 | export KERNEL_PATH = "${STAGING_KERNEL_DIR}" | ||
15 | |||
16 | INHIBIT_PACKAGE_STRIP = "1" | ||
17 | |||
18 | do_install(){ | ||
19 | mkdir -p ${D}/${libexecdir} | ||
20 | mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/asf | ||
21 | cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf | ||
22 | cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf | ||
23 | cp -rf ${S}/scripts ${D}/${libexecdir}/ | ||
24 | } | ||
25 | |||
26 | FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf" | ||
27 | RDEPENDS_${PN} += "ipsec-tools" | ||