diff options
3 files changed, 0 insertions, 94 deletions
diff --git a/recipes-bsp/mqxboot/mqxboot_1.0.bb b/recipes-bsp/mqxboot/mqxboot_1.0.bb deleted file mode 100644 index 7f11a98..0000000 --- a/recipes-bsp/mqxboot/mqxboot_1.0.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | # Copyright (C) 2013 Timesys Corporation | ||
2 | SUMMARY = "MQX Image loader - starts an MQX image on the M4" | ||
3 | LICENSE = "GPL-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c49712341497d0b5f2e40c30dff2af9d" | ||
5 | |||
6 | DEPENDS = "virtual/kernel-module-mcc" | ||
7 | |||
8 | SRC_URI = "http://repository.timesys.com/buildsources/m/mqxboot/mqxboot-${PV}/mqxboot-${PV}.tar.bz2" | ||
9 | |||
10 | SRC_URI[md5sum] = "3de3c8b5f8cd6664870587d29c04c421" | ||
11 | SRC_URI[sha256sum] = "c2f66ae962fe2529578d5c007e3f91a36085b714a0ea276f47bc3aea90e69699" | ||
12 | |||
13 | S = "${WORKDIR}/mqxboot-${PV}" | ||
14 | |||
15 | CFLAGS += "-I${STAGING_KERNEL_DIR}/include" | ||
16 | |||
17 | RDEPENDS_${PN} = "virtual/kernel-module-mcc" | ||
18 | |||
19 | COMPATIBLE_MACHINE = "(vf60)" | ||
20 | |||
21 | do_install() { | ||
22 | oe_runmake 'DESTDIR=${D}' install | ||
23 | } | ||
diff --git a/recipes-kernel/kernel-modules/kernel-module-mcc/mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch b/recipes-kernel/kernel-modules/kernel-module-mcc/mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch deleted file mode 100644 index 570edaa..0000000 --- a/recipes-kernel/kernel-modules/kernel-module-mcc/mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch +++ /dev/null | |||
@@ -1,51 +0,0 @@ | |||
1 | From 17e04c68557c4c9cb1a0112717019329a0cc3f96 Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Tue, 6 Jan 2015 13:39:50 -0200 | ||
4 | Subject: [PATCH] mcc_config.h: Only include mvf_sema4.h if building in kernel | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | When mcc_config.h is used to make application we shouldn't include | ||
8 | mvf_sema4.h as it is an internal symbol of kernel and shouldn't be | ||
9 | directly referenced by user space applications using the MCC | ||
10 | interface. | ||
11 | |||
12 | This patch puts a guard using __KERNEL__ define, avoiding the include | ||
13 | and the definition of MCC_SHMEM_SEMAPHORE_NUMBER as | ||
14 | MVF_SHMEM_SEMAPHORE_NUMBER would be undefined. | ||
15 | |||
16 | Upstream-Status: Pending | ||
17 | |||
18 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
19 | --- | ||
20 | mcc_config.h | 8 +++++--- | ||
21 | 1 file changed, 5 insertions(+), 3 deletions(-) | ||
22 | |||
23 | diff --git a/mcc_config.h b/mcc_config.h | ||
24 | index 6a12c6d..3887aad 100644 | ||
25 | --- a/mcc_config.h | ||
26 | +++ b/mcc_config.h | ||
27 | @@ -18,8 +18,13 @@ | ||
28 | #ifndef __MCC_CONFIG__ | ||
29 | #define __MCC_CONFIG__ | ||
30 | |||
31 | +#ifdef __KERNEL__ | ||
32 | #include <linux/mvf_sema4.h> | ||
33 | |||
34 | +/* semaphore number */ | ||
35 | +#define MCC_SHMEM_SEMAPHORE_NUMBER (MVF_SHMEM_SEMAPHORE_NUMBER) | ||
36 | +#endif | ||
37 | + | ||
38 | /* used OS */ | ||
39 | #define MCC_OS_USED (MCC_LINUX) | ||
40 | |||
41 | @@ -47,7 +52,4 @@ | ||
42 | /* other cores, besides this participating in mcc */ | ||
43 | #define MCC_OTHER_CORES {1} | ||
44 | |||
45 | -/* semaphore number */ | ||
46 | -#define MCC_SHMEM_SEMAPHORE_NUMBER (MVF_SHMEM_SEMAPHORE_NUMBER) | ||
47 | - | ||
48 | #endif /* __MCC_CONFIG__ */ | ||
49 | -- | ||
50 | 2.1.4 | ||
51 | |||
diff --git a/recipes-kernel/kernel-modules/kernel-module-mcc_1.06.bb b/recipes-kernel/kernel-modules/kernel-module-mcc_1.06.bb deleted file mode 100644 index db3eb02..0000000 --- a/recipes-kernel/kernel-modules/kernel-module-mcc_1.06.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | # Copyright (C) 2013 Timesys Corporation | ||
2 | SUMMARY = "Multicore communication kernel module" | ||
3 | LICENSE = "GPL-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c8959abcbbe4d6676c58eab9354019e6" | ||
5 | |||
6 | PROVIDES = "virtual/kernel-module-mcc" | ||
7 | RPROVIDES_${PN} = "virtual/kernel-module-mcc" | ||
8 | RPROVIDES_${PN}-dev = "virtual/kernel-module-mcc-dev" | ||
9 | |||
10 | inherit module | ||
11 | |||
12 | SRC_URI = "http://repository.timesys.com/buildsources/m/mcc-kmod/mcc-kmod-${PV}/mcc-kmod-${PV}.tar.bz2 \ | ||
13 | file://mcc_config.h-Only-include-mvf_sema4.h-if-building-in.patch" | ||
14 | |||
15 | SRC_URI[md5sum] = "d0507968592af5d8781e8bdbbb249e7d" | ||
16 | SRC_URI[sha256sum] = "43f834ddf9845da843c7790a307a0dbc8b04a40deed06aed7c3c99ad3a273f6c" | ||
17 | |||
18 | S = "${WORKDIR}/mcc-kmod-${PV}" | ||
19 | |||
20 | COMPATIBLE_MACHINE = "(vf60)" | ||