diff options
Diffstat (limited to 'qt5-layer')
-rw-r--r-- | qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch | 23 | ||||
-rw-r--r-- | qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | 5 |
2 files changed, 28 insertions, 0 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch b/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch new file mode 100644 index 0000000..b0be292 --- /dev/null +++ b/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | Workaround EGL initialization failure due visual mismatch | ||
2 | |||
3 | Error: | ||
4 | |||
5 | Warning: EGL suggested using X Visual ID 33 (RGB888) for EGL config 28 (RGB444), but this is incompatable | ||
6 | Unable to find an X11 visual which matches EGL config 28 | ||
7 | Could not initialize EGL | ||
8 | Aborted | ||
9 | |||
10 | Upstream-Status: Inappropriate [workaround] | ||
11 | |||
12 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
13 | |||
14 | diff -Naur qtbase-opensource-src-5.1.1_original/src/platformsupport/eglconvenience/qxlibeglintegration.cpp qtbase-opensource-src-5.1.1/src/platformsupport/eglconvenience/qxlibeglintegration.cpp | ||
15 | --- qtbase-opensource-src-5.1.1_original/src/platformsupport/eglconvenience/qxlibeglintegration.cpp 2013-12-25 19:08:42.163895341 -0800 | ||
16 | +++ qtbase-opensource-src-5.1.1/src/platformsupport/eglconvenience/qxlibeglintegration.cpp 2013-12-25 19:09:37.207893799 -0800 | ||
17 | @@ -180,5 +180,5 @@ | ||
18 | } | ||
19 | |||
20 | qWarning("Unable to find an X11 visual which matches EGL config %d", configId); | ||
21 | - return (VisualID)0; | ||
22 | + return (VisualID)33; | ||
23 | } | ||
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend index 310d7f7..c1df764 100644 --- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend +++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | |||
@@ -1,5 +1,9 @@ | |||
1 | # Copyright (C) 2013 Eric Bénard - Eukréa Electromatique | 1 | # Copyright (C) 2013 Eric Bénard - Eukréa Electromatique |
2 | 2 | ||
3 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
4 | |||
5 | SRC_URI += "file://Force_egl_visual_ID_33.patch" | ||
6 | |||
3 | HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" | 7 | HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" |
4 | 8 | ||
5 | PACKAGECONFIG_GL_mx5 = "gles2" | 9 | PACKAGECONFIG_GL_mx5 = "gles2" |
@@ -7,6 +11,7 @@ PACKAGECONFIG_append_mx5 = " tslib icu examples" | |||
7 | 11 | ||
8 | PACKAGECONFIG_GL_mx6 = "gles2" | 12 | PACKAGECONFIG_GL_mx6 = "gles2" |
9 | PACKAGECONFIG_append_mx6 = " tslib icu examples" | 13 | PACKAGECONFIG_append_mx6 = " tslib icu examples" |
14 | QT_CONFIG_FLAGS_append_mx6 = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', '', d)}" | ||
10 | 15 | ||
11 | do_configure_prepend_mx5() { | 16 | do_configure_prepend_mx5() { |
12 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf | 17 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf |