diff options
Diffstat (limited to 'recipes-connectivity/openssl/openssl-qoriq/engines-install-in-libdir-ssl.patch')
-rw-r--r-- | recipes-connectivity/openssl/openssl-qoriq/engines-install-in-libdir-ssl.patch | 42 |
1 files changed, 25 insertions, 17 deletions
diff --git a/recipes-connectivity/openssl/openssl-qoriq/engines-install-in-libdir-ssl.patch b/recipes-connectivity/openssl/openssl-qoriq/engines-install-in-libdir-ssl.patch index d8a6f1a..a574648 100644 --- a/recipes-connectivity/openssl/openssl-qoriq/engines-install-in-libdir-ssl.patch +++ b/recipes-connectivity/openssl/openssl-qoriq/engines-install-in-libdir-ssl.patch | |||
@@ -1,11 +1,11 @@ | |||
1 | Upstream-Status: Inappropriate [configuration] | 1 | Upstream-Status: Inappropriate [configuration] |
2 | 2 | ||
3 | 3 | ||
4 | Index: openssl-1.0.0/engines/Makefile | 4 | Index: openssl-1.0.2/engines/Makefile |
5 | =================================================================== | 5 | =================================================================== |
6 | --- openssl-1.0.0.orig/engines/Makefile | 6 | --- openssl-1.0.2.orig/engines/Makefile |
7 | +++ openssl-1.0.0/engines/Makefile | 7 | +++ openssl-1.0.2/engines/Makefile |
8 | @@ -107,7 +107,7 @@ | 8 | @@ -107,13 +107,13 @@ install: |
9 | @[ -n "$(INSTALLTOP)" ] # should be set by top Makefile... | 9 | @[ -n "$(INSTALLTOP)" ] # should be set by top Makefile... |
10 | @if [ -n "$(SHARED_LIBS)" ]; then \ | 10 | @if [ -n "$(SHARED_LIBS)" ]; then \ |
11 | set -e; \ | 11 | set -e; \ |
@@ -14,16 +14,19 @@ Index: openssl-1.0.0/engines/Makefile | |||
14 | for l in $(LIBNAMES); do \ | 14 | for l in $(LIBNAMES); do \ |
15 | ( echo installing $$l; \ | 15 | ( echo installing $$l; \ |
16 | pfx=lib; \ | 16 | pfx=lib; \ |
17 | @@ -119,13 +119,13 @@ | 17 | if expr "$(PLATFORM)" : "Cygwin" >/dev/null; then \ |
18 | sfx=".so"; \ | ||
19 | - cp cyg$$l.dll $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx.new; \ | ||
20 | + cp cyg$$l.dll $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/ssl/engines/$$pfx$$l$$sfx.new; \ | ||
21 | else \ | ||
22 | case "$(CFLAGS)" in \ | ||
23 | *DSO_BEOS*) sfx=".so";; \ | ||
24 | @@ -122,10 +122,10 @@ install: | ||
18 | *DSO_WIN32*) sfx="eay32.dll"; pfx=;; \ | 25 | *DSO_WIN32*) sfx="eay32.dll"; pfx=;; \ |
19 | *) sfx=".bad";; \ | 26 | *) sfx=".bad";; \ |
20 | esac; \ | 27 | esac; \ |
21 | - cp $$pfx$$l$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx.new; \ | 28 | - cp $$pfx$$l$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx.new; \ |
22 | + cp $$pfx$$l$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/ssl/engines/$$pfx$$l$$sfx.new; \ | 29 | + cp $$pfx$$l$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/ssl/engines/$$pfx$$l$$sfx.new; \ |
23 | else \ | ||
24 | sfx=".so"; \ | ||
25 | - cp cyg$$l.dll $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx.new; \ | ||
26 | + cp cyg$$l.dll $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/ssl/engines/$$pfx$$l$$sfx.new; \ | ||
27 | fi; \ | 30 | fi; \ |
28 | - chmod 555 $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx.new; \ | 31 | - chmod 555 $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx.new; \ |
29 | - mv -f $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx.new $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx ); \ | 32 | - mv -f $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx.new $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx ); \ |
@@ -32,20 +35,25 @@ Index: openssl-1.0.0/engines/Makefile | |||
32 | done; \ | 35 | done; \ |
33 | fi | 36 | fi |
34 | @target=install; $(RECURSIVE_MAKE) | 37 | @target=install; $(RECURSIVE_MAKE) |
35 | Index: openssl-1.0.0/engines/ccgost/Makefile | 38 | Index: openssl-1.0.2/engines/ccgost/Makefile |
36 | =================================================================== | 39 | =================================================================== |
37 | --- openssl-1.0.0.orig/engines/ccgost/Makefile | 40 | --- openssl-1.0.2.orig/engines/ccgost/Makefile |
38 | +++ openssl-1.0.0/engines/ccgost/Makefile | 41 | +++ openssl-1.0.2/engines/ccgost/Makefile |
39 | @@ -53,13 +53,13 @@ | 42 | @@ -47,7 +47,7 @@ install: |
43 | pfx=lib; \ | ||
44 | if expr "$(PLATFORM)" : "Cygwin" >/dev/null; then \ | ||
45 | sfx=".so"; \ | ||
46 | - cp cyg$(LIBNAME).dll $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$${pfx}$(LIBNAME)$$sfx.new; \ | ||
47 | + cp cyg$(LIBNAME).dll $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/ssl/engines/$${pfx}$(LIBNAME)$$sfx.new; \ | ||
48 | else \ | ||
49 | case "$(CFLAGS)" in \ | ||
50 | *DSO_BEOS*) sfx=".so";; \ | ||
51 | @@ -56,10 +56,10 @@ install: | ||
40 | *DSO_WIN32*) sfx="eay32.dll"; pfx=;; \ | 52 | *DSO_WIN32*) sfx="eay32.dll"; pfx=;; \ |
41 | *) sfx=".bad";; \ | 53 | *) sfx=".bad";; \ |
42 | esac; \ | 54 | esac; \ |
43 | - cp $${pfx}$(LIBNAME)$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$${pfx}$(LIBNAME)$$sfx.new; \ | 55 | - cp $${pfx}$(LIBNAME)$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$${pfx}$(LIBNAME)$$sfx.new; \ |
44 | + cp $${pfx}$(LIBNAME)$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/ssl/engines/$${pfx}$(LIBNAME)$$sfx.new; \ | 56 | + cp $${pfx}$(LIBNAME)$$sfx $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/ssl/engines/$${pfx}$(LIBNAME)$$sfx.new; \ |
45 | else \ | ||
46 | sfx=".so"; \ | ||
47 | - cp cyg$(LIBNAME).dll $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$${pfx}$(LIBNAME)$$sfx.new; \ | ||
48 | + cp cyg$(LIBNAME).dll $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/ssl/engines/$${pfx}$(LIBNAME)$$sfx.new; \ | ||
49 | fi; \ | 57 | fi; \ |
50 | - chmod 555 $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$${pfx}$(LIBNAME)$$sfx.new; \ | 58 | - chmod 555 $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$${pfx}$(LIBNAME)$$sfx.new; \ |
51 | - mv -f $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$${pfx}$(LIBNAME)$$sfx.new $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$${pfx}$(LIBNAME)$$sfx; \ | 59 | - mv -f $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$${pfx}$(LIBNAME)$$sfx.new $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$${pfx}$(LIBNAME)$$sfx; \ |