summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLim Siew Hoon <siew.hoon.lim@intel.com>2024-09-30 08:01:01 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2024-09-30 10:11:47 +0800
commit86a337d450684ef49f3cefeb1e00d606f0697d36 (patch)
tree2117de2213113af9607d0255714db5a9963cf205
parentfd8ccbdf1e381ba0bc5daefdf27ae17261a1eb0d (diff)
downloadmeta-intel-86a337d450684ef49f3cefeb1e00d606f0697d36.tar.gz
intel-media-driver: upgrade 24.1.5 -> 24.3.2
Drop patches already merged: - 0001-Disable-vp9-padding-on-mtl.patch - 8aa866dc650e6b0e0b7425bafc7b1039232c377a.patch Rebased patches: - 0001-Force-ARGB-surface-to-tile4-for-ACM.patch code fixed for videowall issue: - 0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch Release notes: https://github.com/intel/media-driver/releases/tag/intel-media-24.3.2 Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-multimedia/libva/files/0001-Disable-vp9-padding-on-mtl.patch35
-rw-r--r--recipes-multimedia/libva/files/0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch85
-rw-r--r--recipes-multimedia/libva/files/0001-Force-ARGB-surface-to-tile4-for-ACM.patch (renamed from recipes-multimedia/libva/files/0002-Force-ARGB-surface-to-tile4-for-ACM.patch)12
-rw-r--r--recipes-multimedia/libva/files/8aa866dc650e6b0e0b7425bafc7b1039232c377a.patch154
-rw-r--r--recipes-multimedia/libva/intel-media-driver_24.3.2.bb (renamed from recipes-multimedia/libva/intel-media-driver_24.1.5.bb)7
5 files changed, 94 insertions, 199 deletions
diff --git a/recipes-multimedia/libva/files/0001-Disable-vp9-padding-on-mtl.patch b/recipes-multimedia/libva/files/0001-Disable-vp9-padding-on-mtl.patch
deleted file mode 100644
index 90dff8d1..00000000
--- a/recipes-multimedia/libva/files/0001-Disable-vp9-padding-on-mtl.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 1b303f417113ad1aa6b63fc024fbe4aa0c943f57 Mon Sep 17 00:00:00 2001
2From: Lim Siew Hoon <siew.hoon.lim@intel.com>
3Date: Tue, 5 Sep 2023 16:13:42 +0800
4Subject: [PATCH 01/12] Disable vp9 padding on mtl.
5
6Upstream-Status: Submitted [https://github.com/intel/media-driver/pull/1720]
7
8Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
9---
10 media_softlet/linux/Xe_M_plus/ddi/media_sku_wa_mtl.cpp | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/media_softlet/linux/Xe_M_plus/ddi/media_sku_wa_mtl.cpp b/media_softlet/linux/Xe_M_plus/ddi/media_sku_wa_mtl.cpp
14index 844545a87..72265289c 100644
15--- a/media_softlet/linux/Xe_M_plus/ddi/media_sku_wa_mtl.cpp
16+++ b/media_softlet/linux/Xe_M_plus/ddi/media_sku_wa_mtl.cpp
17@@ -284,7 +284,7 @@ static bool InitMtlMediaWaExt(struct GfxDeviceInfo *devInfo,
18
19 MEDIA_WR_WA(waTable, WaDisableSetObjectCapture, 1);
20
21- MEDIA_WR_WA(waTable, Wa_Vp9UnalignedHeight, 1);
22+ MEDIA_WR_WA(waTable, Wa_Vp9UnalignedHeight, 0);
23
24 MEDIA_WR_WA(waTable, Wa_15013355402, 1);
25
26@@ -337,4 +337,4 @@ static struct LinuxDeviceInit arlDeviceInit =
27 };
28
29 static bool arlDeviceRegister = DeviceInfoFactory<LinuxDeviceInit>::
30- RegisterDevice((uint32_t)IGFX_ARROWLAKE, &arlDeviceInit);
31\ No newline at end of file
32+ RegisterDevice((uint32_t)IGFX_ARROWLAKE, &arlDeviceInit);
33--
342.40.1
35
diff --git a/recipes-multimedia/libva/files/0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch b/recipes-multimedia/libva/files/0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch
new file mode 100644
index 00000000..fbeab6e2
--- /dev/null
+++ b/recipes-multimedia/libva/files/0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch
@@ -0,0 +1,85 @@
1From 38e6883e54e65a73aa7795dc2ff9f072448cb3dc Mon Sep 17 00:00:00 2001
2From: Lim Siew Hoon <siew.hoon.lim@intel.com>
3Date: Fri, 2 Aug 2024 13:25:13 +0800
4Subject: [PATCH] Fix failed 4k videowalll test case and color corruption of
5 video composition in Gen12 platform
6
7Fix failed 4k video wall test case from 16CH video only show
81CH output and corruption observed on certain number of video
9composition when doing sample_multi_transcode in legacy path.
10
11platform: TGL/ADL/RPL
12
13Upstream-Status: Submitted [https://github.com/intel/media-driver/pull/1839]
14
15Signed-off-by: xupianch <xu.pian.chan@intel.com>
16Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
17---
18 .../common/vp/hal/vphal_render_composite.cpp | 9 ++++++++-
19 .../linux/common/vp/ddi/media_libva_vp.c | 18 +++++-------------
20 2 files changed, 13 insertions(+), 14 deletions(-)
21
22diff --git a/media_driver/agnostic/common/vp/hal/vphal_render_composite.cpp b/media_driver/agnostic/common/vp/hal/vphal_render_composite.cpp
23index 169030209..cc7c241c1 100644
24--- a/media_driver/agnostic/common/vp/hal/vphal_render_composite.cpp
25+++ b/media_driver/agnostic/common/vp/hal/vphal_render_composite.cpp
26@@ -6784,6 +6784,13 @@ bool CompositeState::BuildFilter(
27
28 for (i = 0; (i < (int)pCompParams->uSourceCount) && (iMaxFilterSize > 0); i++)
29 {
30+ if (i > 0)
31+ {
32+ if (!RECT1_CONTAINS_RECT2(pCompParams->pSource[0]->rcDst, pCompParams->pSource[i]->rcDst))
33+ {
34+ pFilter->forceToTargetColorSpace = true;
35+ }
36+ }
37 pSrc = pCompParams->pSource[i];
38
39 //--------------------------------
40@@ -8154,4 +8161,4 @@ bool CompositeState::IsSamplerIDForY(
41 return true;
42 }
43 return false;
44- }
45\ No newline at end of file
46+ }
47diff --git a/media_driver/linux/common/vp/ddi/media_libva_vp.c b/media_driver/linux/common/vp/ddi/media_libva_vp.c
48index 48a452315..4f0fc2c48 100644
49--- a/media_driver/linux/common/vp/ddi/media_libva_vp.c
50+++ b/media_driver/linux/common/vp/ddi/media_libva_vp.c
51@@ -1148,7 +1148,7 @@ DdiVp_SetProcPipelineParams(
52
53 // Background Colorfill
54 // According to libva definition, if alpha in output background color is zero, then colorfill is not needed
55- if ((pPipelineParam->output_background_color >> 24) != 0 || pVpHalTgtSurf->ColorSpace == CSpace_sRGB)
56+ if ((pPipelineParam->output_background_color >> 24) != 0)
57 {
58 if (pVpHalRenderParams->pColorFillParams == nullptr)
59 {
60@@ -1157,18 +1157,10 @@ DdiVp_SetProcPipelineParams(
61
62 DDI_CHK_NULL(pVpHalRenderParams->pColorFillParams, "Null pColorFillParams.", VA_STATUS_ERROR_UNKNOWN);
63
64- if (pVpHalTgtSurf->ColorSpace == CSpace_sRGB && (pPipelineParam->output_background_color >> 24) == 0)
65- {
66- // set color space for sRGB output
67- pVpHalRenderParams->pColorFillParams->CSpace = CSpace_sRGB;
68- }
69- else
70- {
71- // set background colorfill option
72- pVpHalRenderParams->pColorFillParams->Color = pPipelineParam->output_background_color;
73- pVpHalRenderParams->pColorFillParams->bYCbCr = false;
74- pVpHalRenderParams->pColorFillParams->CSpace = CSpace_sRGB;
75- }
76+ // set background colorfill option
77+ pVpHalRenderParams->pColorFillParams->Color = pPipelineParam->output_background_color;
78+ pVpHalRenderParams->pColorFillParams->bYCbCr = false;
79+ pVpHalRenderParams->pColorFillParams->CSpace = CSpace_sRGB;
80 }else
81 {
82 MOS_FreeMemAndSetNull(pVpHalRenderParams->pColorFillParams);
83--
842.43.2
85
diff --git a/recipes-multimedia/libva/files/0002-Force-ARGB-surface-to-tile4-for-ACM.patch b/recipes-multimedia/libva/files/0001-Force-ARGB-surface-to-tile4-for-ACM.patch
index df3d9805..0642f129 100644
--- a/recipes-multimedia/libva/files/0002-Force-ARGB-surface-to-tile4-for-ACM.patch
+++ b/recipes-multimedia/libva/files/0001-Force-ARGB-surface-to-tile4-for-ACM.patch
@@ -1,7 +1,7 @@
1From 1580f01ec5ad5afdad58c39dded999494275be10 Mon Sep 17 00:00:00 2001 1From f318522175fb2ecc6d364b995a7b1926fd158a88 Mon Sep 17 00:00:00 2001
2From: Lim Siew Hoon <siew.hoon.lim@intel.com> 2From: Lim Siew Hoon <siew.hoon.lim@intel.com>
3Date: Wed, 11 Oct 2023 15:36:21 +0800 3Date: Wed, 11 Oct 2023 15:36:21 +0800
4Subject: [PATCH 02/12] Force ARGB surface to tile4 for ACM 4Subject: [PATCH] Force ARGB surface to tile4 for ACM
5 5
6Upstream-Status: Submitted [https://github.com/intel/media-driver/pull/1728] 6Upstream-Status: Submitted [https://github.com/intel/media-driver/pull/1728]
7 7
@@ -12,10 +12,10 @@ Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
12 1 file changed, 10 insertions(+) 12 1 file changed, 10 insertions(+)
13 13
14diff --git a/media_driver/linux/common/ddi/media_libva_util.cpp b/media_driver/linux/common/ddi/media_libva_util.cpp 14diff --git a/media_driver/linux/common/ddi/media_libva_util.cpp b/media_driver/linux/common/ddi/media_libva_util.cpp
15index 63c173419..73be76366 100755 15index a4e12edfa..11634f66e 100755
16--- a/media_driver/linux/common/ddi/media_libva_util.cpp 16--- a/media_driver/linux/common/ddi/media_libva_util.cpp
17+++ b/media_driver/linux/common/ddi/media_libva_util.cpp 17+++ b/media_driver/linux/common/ddi/media_libva_util.cpp
18@@ -504,6 +504,7 @@ VAStatus DdiMediaUtil_AllocateSurface( 18@@ -521,6 +521,7 @@ VAStatus DdiMediaUtil_AllocateSurface(
19 gmmCustomParams.Flags.Gpu.UnifiedAuxSurface = 0; 19 gmmCustomParams.Flags.Gpu.UnifiedAuxSurface = 0;
20 } 20 }
21 } 21 }
@@ -23,7 +23,7 @@ index 63c173419..73be76366 100755
23 break; 23 break;
24 case TILING_X: 24 case TILING_X:
25 gmmCustomParams.Flags.Info.TiledX = true; 25 gmmCustomParams.Flags.Info.TiledX = true;
26@@ -685,6 +686,15 @@ VAStatus DdiMediaUtil_AllocateSurface( 26@@ -702,6 +703,15 @@ VAStatus DdiMediaUtil_AllocateSurface(
27 } 27 }
28 } 28 }
29 } 29 }
@@ -40,5 +40,5 @@ index 63c173419..73be76366 100755
40 case TILING_X: 40 case TILING_X:
41 gmmParams.Flags.Info.TiledX = true; 41 gmmParams.Flags.Info.TiledX = true;
42-- 42--
432.40.1 432.43.2
44 44
diff --git a/recipes-multimedia/libva/files/8aa866dc650e6b0e0b7425bafc7b1039232c377a.patch b/recipes-multimedia/libva/files/8aa866dc650e6b0e0b7425bafc7b1039232c377a.patch
deleted file mode 100644
index 17b2d635..00000000
--- a/recipes-multimedia/libva/files/8aa866dc650e6b0e0b7425bafc7b1039232c377a.patch
+++ /dev/null
@@ -1,154 +0,0 @@
1From 8aa866dc650e6b0e0b7425bafc7b1039232c377a Mon Sep 17 00:00:00 2001
2From: "Xu, Zhengguo" <zhengguo.xu@intel.com>
3Date: Tue, 16 Apr 2024 09:53:41 +0800
4Subject: [PATCH] [Decode] Correct condition check when dump avc mv buffer
5
6Fixes: #1791
7Signed-off-by: Xu, Zhengguo <zhengguo.xu@intel.com>
8
9Upstream-Status: Backport [https://github.com/intel/media-driver/commit/8aa866dc650e6b0e0b7425bafc7b1039232c377a]
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 .../common/codec/hal/codechal_decode_avc.cpp | 33 ++++++++-----------
13 .../decode_avc_picture_xe_m_base_packet.cpp | 28 +++++++---------
14 .../avc/packet/decode_avc_picture_packet.cpp | 30 +++++++----------
15 3 files changed, 37 insertions(+), 54 deletions(-)
16
17diff --git a/media_driver/agnostic/common/codec/hal/codechal_decode_avc.cpp b/media_driver/agnostic/common/codec/hal/codechal_decode_avc.cpp
18index 3adf6994ce..4bac426802 100644
19--- a/media_driver/agnostic/common/codec/hal/codechal_decode_avc.cpp
20+++ b/media_driver/agnostic/common/codec/hal/codechal_decode_avc.cpp
21@@ -1619,28 +1619,23 @@ MOS_STATUS CodechalDecodeAvc::InitPicMhwParams(
22 uint8_t picID = picMhwParams->AvcDirectmodeParams.bPicIdRemappingInUse ? i : refList[idx]->ucFrameId;
23 uint8_t mvIdx = refList[idx]->ucDMVIdx[0];
24
25- if (&picMhwParams->AvcDirectmodeParams.presAvcDmvBuffers[i] != nullptr)
26- {
27- // dump Reference mvdata
28- std::string mvBufDumpName = "_DEC_Ref_MV_" + std::to_string(i);
29- CODECHAL_DECODE_CHK_STATUS_RETURN(m_debugInterface->DumpBuffer(
30- &picMhwParams->AvcDirectmodeParams.presAvcDmvBuffers[mvIdx],
31- CodechalDbgAttr::attrMvData,
32- mvBufDumpName.c_str(),
33- m_avcDmvBufferSize));
34- }
35+ // dump Reference mvdata
36+ std::string mvBufDumpName = "_DEC_Ref_MV_" + std::to_string(i);
37+ CODECHAL_DECODE_CHK_STATUS_RETURN(m_debugInterface->DumpBuffer(
38+ &picMhwParams->AvcDirectmodeParams.presAvcDmvBuffers[mvIdx],
39+ CodechalDbgAttr::attrMvData,
40+ mvBufDumpName.c_str(),
41+ m_avcDmvBufferSize));
42 }
43 }
44
45- if (&picMhwParams->AvcDirectmodeParams.presAvcDmvBuffers[picMhwParams->AvcDirectmodeParams.ucAvcDmvIdx])
46- {
47- // dump Current mvdata
48- CODECHAL_DECODE_CHK_STATUS_RETURN(m_debugInterface->DumpBuffer(
49- &picMhwParams->AvcDirectmodeParams.presAvcDmvBuffers[picMhwParams->AvcDirectmodeParams.ucAvcDmvIdx],
50- CodechalDbgAttr::attrMvData,
51- "DEC_Cur_MV_",
52- m_avcDmvBufferSize));
53- });
54+ // dump Current mvdata
55+ CODECHAL_DECODE_CHK_STATUS_RETURN(m_debugInterface->DumpBuffer(
56+ &picMhwParams->AvcDirectmodeParams.presAvcDmvBuffers[picMhwParams->AvcDirectmodeParams.ucAvcDmvIdx],
57+ CodechalDbgAttr::attrMvData,
58+ "DEC_Cur_MV_",
59+ m_avcDmvBufferSize));
60+ );
61
62 return eStatus;
63 }
64diff --git a/media_driver/media_softlet/agnostic/Xe_M/Xe_M_base/codec/hal/dec/avc/packet/decode_avc_picture_xe_m_base_packet.cpp b/media_driver/media_softlet/agnostic/Xe_M/Xe_M_base/codec/hal/dec/avc/packet/decode_avc_picture_xe_m_base_packet.cpp
65index bd0611f6fa..035a7e6149 100644
66--- a/media_driver/media_softlet/agnostic/Xe_M/Xe_M_base/codec/hal/dec/avc/packet/decode_avc_picture_xe_m_base_packet.cpp
67+++ b/media_driver/media_softlet/agnostic/Xe_M/Xe_M_base/codec/hal/dec/avc/packet/decode_avc_picture_xe_m_base_packet.cpp
68@@ -589,26 +589,20 @@ namespace decode{
69 {
70 if (m_avcBasicFeature->m_refFrames.m_avcPicIdx[n].bValid)
71 {
72- if (&avcDirectmodeParams.presAvcDmvBuffers[n+1] != nullptr)
73- {
74- std::string mvBufDumpName = "_DEC_Ref_MV_" + std::to_string(n);
75- DECODE_CHK_STATUS(debugInterface->DumpBuffer(
76- &avcDirectmodeParams.presAvcDmvBuffers[n+1],
77- CodechalDbgAttr::attrMvData,
78- mvBufDumpName.c_str(),
79- mvBufferSize));
80- }
81+ std::string mvBufDumpName = "_DEC_Ref_MV_" + std::to_string(n);
82+ DECODE_CHK_STATUS(debugInterface->DumpBuffer(
83+ &avcDirectmodeParams.presAvcDmvBuffers[n+1],
84+ CodechalDbgAttr::attrMvData,
85+ mvBufDumpName.c_str(),
86+ mvBufferSize));
87 }
88 }
89
90- if (&avcDirectmodeParams.presAvcDmvBuffers[0] != nullptr)
91- {
92- DECODE_CHK_STATUS(debugInterface->DumpBuffer(
93- &avcDirectmodeParams.presAvcDmvBuffers[0],
94- CodechalDbgAttr::attrMvData,
95- "DEC_Cur_MV_",
96- mvBufferSize));
97- }
98+ DECODE_CHK_STATUS(debugInterface->DumpBuffer(
99+ &avcDirectmodeParams.presAvcDmvBuffers[0],
100+ CodechalDbgAttr::attrMvData,
101+ "DEC_Cur_MV_",
102+ mvBufferSize));
103 return MOS_STATUS_SUCCESS;
104 }
105
106diff --git a/media_softlet/agnostic/common/codec/hal/dec/avc/packet/decode_avc_picture_packet.cpp b/media_softlet/agnostic/common/codec/hal/dec/avc/packet/decode_avc_picture_packet.cpp
107index 88ed0bb832..8cdc05e585 100644
108--- a/media_softlet/agnostic/common/codec/hal/dec/avc/packet/decode_avc_picture_packet.cpp
109+++ b/media_softlet/agnostic/common/codec/hal/dec/avc/packet/decode_avc_picture_packet.cpp
110@@ -646,26 +646,20 @@ MOS_STATUS AvcDecodePicPkt::DumpResources(uint32_t mvBufferSize) const
111 CodechalDbgAttr::attrDecodeReferenceSurfaces,
112 refSurfName.c_str()));
113
114- if (&mvParam.presAvcDmvBuffers[n+1] != nullptr)
115- {
116- std::string mvBufDumpName = "_DEC_Ref_MV_" + std::to_string(n);
117- DECODE_CHK_STATUS(debugInterface->DumpBuffer(
118- &mvParam.presAvcDmvBuffers[n+1],
119- CodechalDbgAttr::attrMvData,
120- mvBufDumpName.c_str(),
121- mvBufferSize));
122- }
123+ std::string mvBufDumpName = "_DEC_Ref_MV_" + std::to_string(n);
124+ DECODE_CHK_STATUS(debugInterface->DumpBuffer(
125+ &mvParam.presAvcDmvBuffers[n+1],
126+ CodechalDbgAttr::attrMvData,
127+ mvBufDumpName.c_str(),
128+ mvBufferSize));
129 }
130 }
131
132- if (&mvParam.presAvcDmvBuffers[0] != nullptr)
133- {
134- DECODE_CHK_STATUS(debugInterface->DumpBuffer(
135- &mvParam.presAvcDmvBuffers[0],
136- CodechalDbgAttr::attrMvData,
137- "DEC_Cur_MV_",
138- mvBufferSize));
139- }
140+ DECODE_CHK_STATUS(debugInterface->DumpBuffer(
141+ &mvParam.presAvcDmvBuffers[0],
142+ CodechalDbgAttr::attrMvData,
143+ "DEC_Cur_MV_",
144+ mvBufferSize));
145
146 return MOS_STATUS_SUCCESS;
147 }
148@@ -699,4 +693,4 @@ MOS_STATUS AvcDecodePicPkt::SetSurfaceMmcState() const
149 return MOS_STATUS_SUCCESS;
150 }
151
152-} // namespace decode
153\ No newline at end of file
154+} // namespace decode
diff --git a/recipes-multimedia/libva/intel-media-driver_24.1.5.bb b/recipes-multimedia/libva/intel-media-driver_24.3.2.bb
index 79f9887d..eaadcd59 100644
--- a/recipes-multimedia/libva/intel-media-driver_24.1.5.bb
+++ b/recipes-multimedia/libva/intel-media-driver_24.3.2.bb
@@ -19,12 +19,11 @@ REQUIRED_DISTRO_FEATURES = "opengl"
19DEPENDS += "libva gmmlib" 19DEPENDS += "libva gmmlib"
20 20
21SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;nobranch=1 \ 21SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;nobranch=1 \
22 file://0001-Disable-vp9-padding-on-mtl.patch \ 22 file://0001-Force-ARGB-surface-to-tile4-for-ACM.patch \
23 file://0002-Force-ARGB-surface-to-tile4-for-ACM.patch \ 23 file://0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch \
24 file://8aa866dc650e6b0e0b7425bafc7b1039232c377a.patch \
25 " 24 "
26 25
27SRCREV = "8068c2e119ba16c017e5a5f443fac5a55edbee65" 26SRCREV = "f40b45dd7355f5f739c75bfd793fa2f1ead30f02"
28S = "${WORKDIR}/git" 27S = "${WORKDIR}/git"
29 28
30COMPATIBLE_HOST:x86-x32 = "null" 29COMPATIBLE_HOST:x86-x32 = "null"