summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2023-05-30 09:03:01 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-05-30 15:10:17 +0800
commitc8fc88b7ed082706af30aac7d4cf4e7201f62542 (patch)
tree1f1ad78fea4e1cb4bd079ec9d85e2a018d5c2425 /dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch
parent1340aeb6c799c41eae7703bf3d7fded2d54a952d (diff)
downloadmeta-intel-c8fc88b7ed082706af30aac7d4cf4e7201f62542.tar.gz
intel-compute-runtime: fix build with gcc13
Dont turn warnings to errors. Helps when compiling with gcc13. | /build/poky/build/tmp/work/corei7-64-poky-linux/intel-compute-runtime/23.09.25812.14-r0/recipe-sysroot/usr/include/c++/13.1.1/bits/stl_algobase.h:398:11: error: '*(unsigned char (*)[7])((char*)&<unnamed> + offsetof(NEO::ArgDescValue, NEO::ArgDescValue::elements.StackVec<NEO::ArgDescValue::Element, 1, unsigned char>::onStackMemRawBytes[0]))' may be used uninitialized [-Werror=maybe-uninitialized] | 398 | { *__to = *__from; } | | Also, include cstdint header to get rid of other gcc13 specific errors. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch
new file mode 100644
index 00000000..20d9b847
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch
@@ -0,0 +1,16 @@
1Upstream-Status: Inappropriate
2Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
3
4diff --git a/CMakeLists.txt b/CMakeLists.txt
5index d52e089778..bc0cf35014 100644
6--- a/CMakeLists.txt
7+++ b/CMakeLists.txt
8@@ -727,7 +727,7 @@ if(NOT MSVC)
9 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-noexcept-type") # Added for gtest
10 endif()
11 endif()
12- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Werror=vla")
13+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror=vla")
14
15 if(USE_SANITIZE_UB)
16 check_cxx_compiler_flag(-fsanitize=undefined COMPILER_SUPPORTS_UNDEFINED_BEHAVIOR_SANITIZER)