diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2022-03-07 13:59:22 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2022-03-07 14:16:04 +0800 |
commit | 2bde8e7514da2f3a35e7d62b19e302745ece7869 (patch) | |
tree | 6d7dd632457e0be915623b9189f7f9f36ef967ee /dynamic-layers/clang-layer/recipes-opencl/compute-runtime | |
parent | 366861210445d2680f19df3c7e3274fecb6c6a5b (diff) | |
download | meta-intel-2bde8e7514da2f3a35e7d62b19e302745ece7869.tar.gz |
intel-compute-runtime: fix patch fuzz
Fix warnings:
| Applying patch allow-to-find-cpp-generation-tool.patch
| patching file shared/source/built_ins/kernels/CMakeLists.txt
| Hunk #1 succeeded at 94 with fuzz 2 (offset -6 lines).
| Hunk #2 succeeded at 147 with fuzz 2 (offset 3 lines).
|
| The context lines in the patches can be updated with devtool:
|
| devtool modify intel-compute-runtime
| devtool finish --force-patch-refresh intel-compute-runtime <layer_path>
|
| Don't forget to review changes done by devtool!
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch | 20 |
1 files changed, 9 insertions, 11 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch index 456dc5cd..4646856d 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 47ae5d13ad021076f5a79f245e33bcb228b0a0da Mon Sep 17 00:00:00 2001 | 1 | From 40e9344d37d62158e6c9f72919f0595ef5fde61a Mon Sep 17 00:00:00 2001 |
2 | From: Dongwon Kim <dongwon.kim@intel.com> | 2 | From: Dongwon Kim <dongwon.kim@intel.com> |
3 | Date: Sat, 21 Aug 2021 16:09:39 -0700 | 3 | Date: Sat, 21 Aug 2021 16:09:39 -0700 |
4 | Subject: [PATCH] Build not able to locate cpp_generation_tool. | 4 | Subject: [PATCH] Build not able to locate cpp_generation_tool. |
@@ -7,15 +7,16 @@ Upstream-Status: Inappropriate [oe specific] | |||
7 | 7 | ||
8 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | 8 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> |
9 | Signed-off-by: Dongwon Kim <dongwon.kim@intel.com> | 9 | Signed-off-by: Dongwon Kim <dongwon.kim@intel.com> |
10 | |||
10 | --- | 11 | --- |
11 | shared/source/built_ins/kernels/CMakeLists.txt | 8 ++++---- | 12 | shared/source/built_ins/kernels/CMakeLists.txt | 8 ++++---- |
12 | 1 file changed, 4 insertions(+), 4 deletions(-) | 13 | 1 file changed, 4 insertions(+), 4 deletions(-) |
13 | 14 | ||
14 | diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt | 15 | diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt |
15 | index 929b981fe..57cd3d4b3 100644 | 16 | index 769e2a100..eef25747e 100644 |
16 | --- a/shared/source/built_ins/kernels/CMakeLists.txt | 17 | --- a/shared/source/built_ins/kernels/CMakeLists.txt |
17 | +++ b/shared/source/built_ins/kernels/CMakeLists.txt | 18 | +++ b/shared/source/built_ins/kernels/CMakeLists.txt |
18 | @@ -100,9 +100,9 @@ if(NOT NEO_DISABLE_BUILTINS_COMPILATION) | 19 | @@ -94,9 +94,9 @@ function(compile_builtin core_type platform_type builtin bits builtin_options mo |
19 | ) | 20 | ) |
20 | add_custom_command( | 21 | add_custom_command( |
21 | OUTPUT ${OUTPUT_FILE_CPP} | 22 | OUTPUT ${OUTPUT_FILE_CPP} |
@@ -25,9 +26,9 @@ index 929b981fe..57cd3d4b3 100644 | |||
25 | - DEPENDS ${OUTPUT_FILES_BINARIES} $<TARGET_FILE:cpp_generate_tool> | 26 | - DEPENDS ${OUTPUT_FILES_BINARIES} $<TARGET_FILE:cpp_generate_tool> |
26 | + DEPENDS ${OUTPUT_FILES_BINARIES} cpp_generate_tool | 27 | + DEPENDS ${OUTPUT_FILES_BINARIES} cpp_generate_tool |
27 | ) | 28 | ) |
28 | endforeach() | 29 | list(APPEND BUILTINS_COMMANDS "${OUTPUT_FILE_CPP}") |
29 | set(BUILTINS_COMMANDS ${BUILTINS_COMMANDS} PARENT_SCOPE) | 30 | else() |
30 | @@ -144,9 +144,9 @@ if(NOT NEO_DISABLE_BUILTINS_COMPILATION) | 31 | @@ -147,9 +147,9 @@ function(generate_cpp_spirv builtin) |
31 | ) | 32 | ) |
32 | add_custom_command( | 33 | add_custom_command( |
33 | OUTPUT ${OUTPUT_FILE_CPP} | 34 | OUTPUT ${OUTPUT_FILE_CPP} |
@@ -37,8 +38,5 @@ index 929b981fe..57cd3d4b3 100644 | |||
37 | - DEPENDS ${GENERATED_SPV_INPUT} $<TARGET_FILE:cpp_generate_tool> | 38 | - DEPENDS ${GENERATED_SPV_INPUT} $<TARGET_FILE:cpp_generate_tool> |
38 | + DEPENDS ${GENERATED_SPV_INPUT} cpp_generate_tool | 39 | + DEPENDS ${GENERATED_SPV_INPUT} cpp_generate_tool |
39 | ) | 40 | ) |
40 | endfunction() | 41 | set(OUTPUT_LIST_CPP_FILES ${OUTPUT_LIST_CPP_FILES} ${OUTPUT_FILE_CPP} PARENT_SCOPE) |
41 | 42 | else() | |
42 | -- | ||
43 | 2.32.0 | ||
44 | |||