diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2022-03-22 15:02:22 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2022-09-29 21:54:00 +0800 |
commit | 19561ccc5ff270ae9ab846a0f1132c3d8e100bc4 (patch) | |
tree | 37d23ce11603c47927e4b17d394b7d87638638be /dynamic-layers/clang-layer/recipes-opencl/igc | |
parent | a26ea404d91b11825bdcfb57283e59717ca019fc (diff) | |
download | meta-intel-19561ccc5ff270ae9ab846a0f1132c3d8e100bc4.tar.gz |
intel-graphics-compiler: fix compile issues
Backport patches to fix compile problems like:
| /build/build/tmp/work/corei7-64-poky-linux/intel-graphics-compiler/1.0.10395-r0/git/visa/LocalScheduler/SWSB_G4IR.cpp:1459:49: error: expected primary-expression before 'int'
| 1459 | int maxTokenDelay = std::numeric_limits<int>::min(); //The delay may cause if reuse
| | ^~~
| /build/build/tmp/work/corei7-64-poky-linux/intel-graphics-compiler/1.0.10395-r0/git/visa/LocalScheduler/SWSB_G4IR.cpp:1460:37: error: 'numeric_limits' is not a member of 'std'
| 1460 | int minTokenDistance = std::numeric_limits<int>::max(); //The distance from the reused node
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
(cherry picked from commit 311b43239440070f750a0ec44537a26c5f22e131)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc')
3 files changed, 55 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/4369c970d4e02258b3c53e854faaa34197124a33.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/4369c970d4e02258b3c53e854faaa34197124a33.patch new file mode 100644 index 00000000..68131584 --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/4369c970d4e02258b3c53e854faaa34197124a33.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 79a95322fc5ae21c3380f6455b28b931c98b2d13 Mon Sep 17 00:00:00 2001 | ||
2 | From: Marcin Naczk <marcin.naczk@intel.com> | ||
3 | Date: Tue, 22 Feb 2022 13:09:54 +0000 | ||
4 | Subject: [PATCH] Upgrade github Action build IGC | ||
5 | |||
6 | - Fix build IGC on Ubuntu 22.04 by adding missing include | ||
7 | |||
8 | Upstream-Status: Backport | ||
9 | Part of: https://github.com/intel/intel-graphics-compiler/commit/4369c970d4e02258b3c53e854faaa34197124a33 | ||
10 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
11 | |||
12 | --- | ||
13 | visa/iga/IGALibrary/IR/SWSBSetter.hpp | 1 + | ||
14 | 1 file changed, 1 insertion(+) | ||
15 | |||
16 | diff --git a/visa/iga/IGALibrary/IR/SWSBSetter.hpp b/visa/iga/IGALibrary/IR/SWSBSetter.hpp | ||
17 | index 5a7ad75c0..02d52add2 100644 | ||
18 | --- a/visa/iga/IGALibrary/IR/SWSBSetter.hpp | ||
19 | +++ b/visa/iga/IGALibrary/IR/SWSBSetter.hpp | ||
20 | @@ -32,6 +32,7 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. | ||
21 | #include "Operand.hpp" | ||
22 | #include "../ErrorHandler.hpp" | ||
23 | #include "RegDeps.hpp" | ||
24 | +#include <limits> | ||
25 | |||
26 | namespace iga | ||
27 | { | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-header.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-header.patch new file mode 100644 index 00000000..6efd51bc --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-header.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 59d5ba1517c48a9e629994917a6e90207df26b08 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruno Pagani <bruno.n.pagani@gmail.com> | ||
3 | Date: Mon, 21 Feb 2022 12:32:25 +0000 | ||
4 | Subject: [PATCH] Fix missing include | ||
5 | |||
6 | Same as 6c805b2 | ||
7 | |||
8 | Upstream-Status: Backport | ||
9 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
10 | |||
11 | --- | ||
12 | visa/LocalScheduler/SWSB_G4IR.cpp | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | diff --git a/visa/LocalScheduler/SWSB_G4IR.cpp b/visa/LocalScheduler/SWSB_G4IR.cpp | ||
16 | index 0ef7961a0..bb631117d 100644 | ||
17 | --- a/visa/LocalScheduler/SWSB_G4IR.cpp | ||
18 | +++ b/visa/LocalScheduler/SWSB_G4IR.cpp | ||
19 | @@ -26,6 +26,7 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. | ||
20 | |||
21 | #include <fstream> | ||
22 | #include <functional> | ||
23 | +#include <limits> | ||
24 | #include <sstream> | ||
25 | #include "SWSB_G4IR.h" | ||
26 | #include "../G4_Opcode.h" | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb index 19d74b0e..5474f8a7 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb | |||
@@ -11,6 +11,8 @@ SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \ | |||
11 | file://0001-skip-execution-of-ElfPackager.patch \ | 11 | file://0001-skip-execution-of-ElfPackager.patch \ |
12 | file://a58dd6de4c29595a0f93cff167b487d777e4559e.patch \ | 12 | file://a58dd6de4c29595a0f93cff167b487d777e4559e.patch \ |
13 | file://0001-IGA-Add-missing-header.patch \ | 13 | file://0001-IGA-Add-missing-header.patch \ |
14 | file://4369c970d4e02258b3c53e854faaa34197124a33.patch \ | ||
15 | file://fix-header.patch \ | ||
14 | " | 16 | " |
15 | 17 | ||
16 | SRCREV = "577887bf74c51a6084058836720fe58f8c35ca58" | 18 | SRCREV = "577887bf74c51a6084058836720fe58f8c35ca58" |