diff options
-rw-r--r-- | recipes-bsp/metee/files/0001-Include-poll.h-instead-of-sys-poll.h.patch | 29 | ||||
-rw-r--r-- | recipes-bsp/metee/metee_3.1.6.bb | 4 |
2 files changed, 32 insertions, 1 deletions
diff --git a/recipes-bsp/metee/files/0001-Include-poll.h-instead-of-sys-poll.h.patch b/recipes-bsp/metee/files/0001-Include-poll.h-instead-of-sys-poll.h.patch new file mode 100644 index 00000000..cc898e75 --- /dev/null +++ b/recipes-bsp/metee/files/0001-Include-poll.h-instead-of-sys-poll.h.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From a98ff2597628d7225c1871719db2411a1e4b7c0a Mon Sep 17 00:00:00 2001 | ||
2 | From: cheeyanglee <chee.yang.lee@intel.com> | ||
3 | Date: Wed, 1 Nov 2023 09:59:32 +0800 | ||
4 | Subject: [PATCH] metee_linux.c: Include poll.h instead of sys/poll.h | ||
5 | |||
6 | fix compilation error with musl C library: | ||
7 | |||
8 | error: #warning redirecting incorrect #include <sys/poll.h> to <poll.h> | ||
9 | |||
10 | Upstream-Status: Submitted [ https://github.com/intel/metee/pull/6 ] | ||
11 | |||
12 | Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> | ||
13 | --- | ||
14 | src/linux/metee_linux.c | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/src/linux/metee_linux.c b/src/linux/metee_linux.c | ||
18 | index 463fe6c..8507ea4 100644 | ||
19 | --- a/src/linux/metee_linux.c | ||
20 | +++ b/src/linux/metee_linux.c | ||
21 | @@ -12,7 +12,7 @@ | ||
22 | #include <stdlib.h> | ||
23 | #include <string.h> | ||
24 | #include <sys/ioctl.h> | ||
25 | -#include <sys/poll.h> | ||
26 | +#include <poll.h> | ||
27 | #include <unistd.h> | ||
28 | |||
29 | #include "metee.h" | ||
diff --git a/recipes-bsp/metee/metee_3.1.6.bb b/recipes-bsp/metee/metee_3.1.6.bb index 1ac55bd6..9a4e267c 100644 --- a/recipes-bsp/metee/metee_3.1.6.bb +++ b/recipes-bsp/metee/metee_3.1.6.bb | |||
@@ -10,7 +10,9 @@ COMPATIBLE_HOST = '(i.86|x86_64).*-linux' | |||
10 | 10 | ||
11 | inherit cmake | 11 | inherit cmake |
12 | 12 | ||
13 | SRC_URI = "git://github.com/intel/metee.git;branch=master;protocol=https" | 13 | SRC_URI = "git://github.com/intel/metee.git;branch=master;protocol=https \ |
14 | file://0001-Include-poll.h-instead-of-sys-poll.h.patch \ | ||
15 | " | ||
14 | SRCREV = "0173c7b6eef327f398c16e51e5ab770390b91472" | 16 | SRCREV = "0173c7b6eef327f398c16e51e5ab770390b91472" |
15 | 17 | ||
16 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |