diff options
-rw-r--r-- | recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order-for-BMG.patch | 45 | ||||
-rw-r--r-- | recipes-multimedia/libva/files/0003-Force-ARGB-surface-to-tile4-for-ACM.patch (renamed from recipes-multimedia/libva/files/0001-Force-ARGB-surface-to-tile4-for-ACM.patch) | 6 | ||||
-rw-r--r-- | recipes-multimedia/libva/files/0004-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch (renamed from recipes-multimedia/libva/files/0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch) | 8 | ||||
-rw-r--r-- | recipes-multimedia/libva/intel-media-driver_25.1.4.bb (renamed from recipes-multimedia/libva/intel-media-driver_24.4.4.bb) | 7 |
4 files changed, 10 insertions, 56 deletions
diff --git a/recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order-for-BMG.patch b/recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order-for-BMG.patch deleted file mode 100644 index 0b3277b0..00000000 --- a/recipes-multimedia/libva/files/0001-Change-RGB-mask-and-order-for-BMG.patch +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | From 8e7b263729bec520cf830cbf85216c2d6466421d Mon Sep 17 00:00:00 2001 | ||
2 | From: "Hoe, Sheng Yang" <sheng.yang.hoe@intel.com> | ||
3 | Date: Fri, 22 Nov 2024 10:11:14 +0000 | ||
4 | Subject: [PATCH] Change RGB mask and order for BMG | ||
5 | |||
6 | Upstream-Status: Submitted [https://github.com/intel/media-driver/pull/1884] | ||
7 | |||
8 | Signed-off-by: Hoe, Sheng Yang <sheng.yang.hoe@intel.com> | ||
9 | --- | ||
10 | .../ddi/capstable_data_image_format_definition.h | 11 ++++++----- | ||
11 | 1 file changed, 6 insertions(+), 5 deletions(-) | ||
12 | |||
13 | diff --git a/media_softlet/linux/common/ddi/capstable_data_image_format_definition.h b/media_softlet/linux/common/ddi/capstable_data_image_format_definition.h | ||
14 | index af28653a5..ec99164ce 100644 | ||
15 | --- a/media_softlet/linux/common/ddi/capstable_data_image_format_definition.h | ||
16 | +++ b/media_softlet/linux/common/ddi/capstable_data_image_format_definition.h | ||
17 | @@ -29,13 +29,14 @@ | ||
18 | |||
19 | #include "va/va.h" | ||
20 | |||
21 | -static VAImageFormat formatBGRA = {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x0000ff00, 0x00ff0000, 0xff000000, 0x000000ff }; /* [31:0] B:G:R:A 8:8:8:8 little endian */ | ||
22 | +// "VA_LSB_FIRST" is to identify how following bit masks mapped to address instead of char order in VA_FOURCC_RGBA naming. | ||
23 | +static VAImageFormat formatBGRA = {VA_FOURCC_BGRA, VA_LSB_FIRST, 32, 32, 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000}; /* [31:0] A:R:G:B 8:8:8:8 little endian */ | ||
24 | static VAImageFormat formatARGB = {VA_FOURCC_ARGB, VA_LSB_FIRST, 32, 32, 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000 }; /* [31:0] A:R:G:B 8:8:8:8 little endian */ | ||
25 | -static VAImageFormat formatRGBA = {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0xff000000, 0x00ff0000, 0x0000ff00, 0x000000ff }; /* [31:0] R:G:B:A 8:8:8:8 little endian */ | ||
26 | +static VAImageFormat formatRGBA = {VA_FOURCC_RGBA, VA_LSB_FIRST, 32, 32, 0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000}; /* [31:0] A:B:G:R 8:8:8:8 little endian */ | ||
27 | static VAImageFormat formatABGR = {VA_FOURCC_ABGR, VA_LSB_FIRST, 32, 32, 0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000 }; /* [31:0] A:B:G:R 8:8:8:8 little endian */ | ||
28 | -static VAImageFormat formatBGRX = {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x0000ff00, 0x00ff0000, 0xff000000, 0 }; /* [31:0] B:G:R:x 8:8:8:8 little endian */ | ||
29 | +static VAImageFormat formatBGRX = {VA_FOURCC_BGRX, VA_LSB_FIRST, 32, 24, 0x00ff0000, 0x0000ff00, 0x000000ff, 0}; /* [31:0] X:R:G:B 8:8:8:8 little endian */ | ||
30 | static VAImageFormat formatXRGB = {VA_FOURCC_XRGB, VA_LSB_FIRST, 32, 24, 0x00ff0000, 0x0000ff00, 0x000000ff, 0 }; /* [31:0] x:R:G:B 8:8:8:8 little endian */ | ||
31 | -static VAImageFormat formatRGBX = {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0xff000000, 0x00ff0000, 0x0000ff00, 0 }; /* [31:0] R:G:B:x 8:8:8:8 little endian */ | ||
32 | +static VAImageFormat formatRGBX = {VA_FOURCC_RGBX, VA_LSB_FIRST, 32, 24, 0x000000ff, 0x0000ff00, 0x00ff0000, 0}; /* [31:0] X:B:G:R 8:8:8:8 little endian */ | ||
33 | static VAImageFormat formatXBGR = {VA_FOURCC_XBGR, VA_LSB_FIRST, 32, 24, 0x000000ff, 0x0000ff00, 0x00ff0000, 0 }; /* [31:0] x:B:G:R 8:8:8:8 little endian */ | ||
34 | static VAImageFormat formatA2R10G10B10 = {VA_FOURCC_A2R10G10B10, VA_LSB_FIRST, 32, 30, 0x3ff00000, 0x000ffc00, 0x000003ff, 0x30000000 }; /* [31:0] A:R:G:B 2:10:10:10 little endian */ | ||
35 | static VAImageFormat formatA2B10G10R10 = {VA_FOURCC_A2B10G10R10, VA_LSB_FIRST, 32, 30, 0x000003ff, 0x000ffc00, 0x3ff00000, 0x30000000 }; /* [31:0] A:B:G:R 2:10:10:10 little endian */ | ||
36 | @@ -70,4 +71,4 @@ static VAImageFormat formatY416 = {VA_FOURCC_Y416, VA_LSB_FIRST, | ||
37 | static VAImageFormat formatRGBP = {VA_FOURCC_RGBP, VA_LSB_FIRST, 24, 24,0,0,0,0}; | ||
38 | static VAImageFormat formatBGRP = {VA_FOURCC_BGRP, VA_LSB_FIRST, 24, 24,0,0,0,0}; | ||
39 | |||
40 | -#endif //__CAPSTABLE_DATA_IMAGE_FORMAT_DEFINITION_H__ | ||
41 | \ No newline at end of file | ||
42 | +#endif //__CAPSTABLE_DATA_IMAGE_FORMAT_DEFINITION_H__ | ||
43 | -- | ||
44 | 2.34.1 | ||
45 | |||
diff --git a/recipes-multimedia/libva/files/0001-Force-ARGB-surface-to-tile4-for-ACM.patch b/recipes-multimedia/libva/files/0003-Force-ARGB-surface-to-tile4-for-ACM.patch index 0642f129..ffb5b747 100644 --- a/recipes-multimedia/libva/files/0001-Force-ARGB-surface-to-tile4-for-ACM.patch +++ b/recipes-multimedia/libva/files/0003-Force-ARGB-surface-to-tile4-for-ACM.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From f318522175fb2ecc6d364b995a7b1926fd158a88 Mon Sep 17 00:00:00 2001 | 1 | From 6132115dd2f1db55a6a5371618247dfaa334a035 Mon Sep 17 00:00:00 2001 |
2 | From: Lim Siew Hoon <siew.hoon.lim@intel.com> | 2 | From: Lim Siew Hoon <siew.hoon.lim@intel.com> |
3 | Date: Wed, 11 Oct 2023 15:36:21 +0800 | 3 | Date: Wed, 11 Oct 2023 15:36:21 +0800 |
4 | Subject: [PATCH] Force ARGB surface to tile4 for ACM | 4 | Subject: [PATCH 3/7] Force ARGB surface to tile4 for ACM |
5 | 5 | ||
6 | Upstream-Status: Submitted [https://github.com/intel/media-driver/pull/1728] | 6 | Upstream-Status: Submitted [https://github.com/intel/media-driver/pull/1728] |
7 | 7 | ||
@@ -40,5 +40,5 @@ index a4e12edfa..11634f66e 100755 | |||
40 | case TILING_X: | 40 | case TILING_X: |
41 | gmmParams.Flags.Info.TiledX = true; | 41 | gmmParams.Flags.Info.TiledX = true; |
42 | -- | 42 | -- |
43 | 2.43.2 | 43 | 2.43.0 |
44 | 44 | ||
diff --git a/recipes-multimedia/libva/files/0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch b/recipes-multimedia/libva/files/0004-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch index fbeab6e2..49e3ff13 100644 --- a/recipes-multimedia/libva/files/0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch +++ b/recipes-multimedia/libva/files/0004-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch | |||
@@ -1,8 +1,8 @@ | |||
1 | From 38e6883e54e65a73aa7795dc2ff9f072448cb3dc Mon Sep 17 00:00:00 2001 | 1 | From a32b95e58fd3e34847e799b909e08dbe5c9dc692 Mon Sep 17 00:00:00 2001 |
2 | From: Lim Siew Hoon <siew.hoon.lim@intel.com> | 2 | From: Lim Siew Hoon <siew.hoon.lim@intel.com> |
3 | Date: Fri, 2 Aug 2024 13:25:13 +0800 | 3 | Date: Fri, 2 Aug 2024 13:25:13 +0800 |
4 | Subject: [PATCH] Fix failed 4k videowalll test case and color corruption of | 4 | Subject: [PATCH 4/7] Fix failed 4k videowalll test case and color corruption |
5 | video composition in Gen12 platform | 5 | of video composition in Gen12 platform |
6 | 6 | ||
7 | Fix failed 4k video wall test case from 16CH video only show | 7 | Fix failed 4k video wall test case from 16CH video only show |
8 | 1CH output and corruption observed on certain number of video | 8 | 1CH output and corruption observed on certain number of video |
@@ -81,5 +81,5 @@ index 48a452315..4f0fc2c48 100644 | |||
81 | { | 81 | { |
82 | MOS_FreeMemAndSetNull(pVpHalRenderParams->pColorFillParams); | 82 | MOS_FreeMemAndSetNull(pVpHalRenderParams->pColorFillParams); |
83 | -- | 83 | -- |
84 | 2.43.2 | 84 | 2.43.0 |
85 | 85 | ||
diff --git a/recipes-multimedia/libva/intel-media-driver_24.4.4.bb b/recipes-multimedia/libva/intel-media-driver_25.1.4.bb index f2f8b83c..b972e230 100644 --- a/recipes-multimedia/libva/intel-media-driver_24.4.4.bb +++ b/recipes-multimedia/libva/intel-media-driver_25.1.4.bb | |||
@@ -19,12 +19,11 @@ REQUIRED_DISTRO_FEATURES = "opengl" | |||
19 | DEPENDS += "libva gmmlib" | 19 | DEPENDS += "libva gmmlib" |
20 | 20 | ||
21 | SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;nobranch=1 \ | 21 | SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;nobranch=1 \ |
22 | file://0001-Force-ARGB-surface-to-tile4-for-ACM.patch \ | 22 | file://0003-Force-ARGB-surface-to-tile4-for-ACM.patch \ |
23 | file://0001-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch \ | 23 | file://0004-Fix-failed-4k-videowalll-test-case-and-color-corrupt.patch \ |
24 | file://0001-Change-RGB-mask-and-order-for-BMG.patch \ | ||
25 | " | 24 | " |
26 | 25 | ||
27 | SRCREV = "d3c30f6dddb43bd7b1b0a4d38a0d0ba47dda5726" | 26 | SRCREV = "14e2e7bcf1014186dbf1c099089c7c05cd880ae8" |
28 | S = "${WORKDIR}/git" | 27 | S = "${WORKDIR}/git" |
29 | 28 | ||
30 | COMPATIBLE_HOST:x86-x32 = "null" | 29 | COMPATIBLE_HOST:x86-x32 = "null" |