diff options
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch | 5 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-external-SPIRV-Tools-change-path-to-tools-and-header.patch | 7 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-fix-tblgen.patch | 7 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/files/0003-Improve-Reproducibility-for-src-package.patch | 7 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.16900.23.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.16510.2.bb) | 4 |
5 files changed, 12 insertions, 18 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch index 377081fd..1e1ea855 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 3d71670f8ad5b54d434c2f5f71713bb1d5433ae4 Mon Sep 17 00:00:00 2001 | 1 | From 1b98a931c3bf8daccc48cd618335ff35e3d382da Mon Sep 17 00:00:00 2001 |
2 | From: Anuj Mittal <anuj.mittal@intel.com> | 2 | From: Anuj Mittal <anuj.mittal@intel.com> |
3 | Date: Tue, 12 Oct 2021 23:46:42 +0800 | 3 | Date: Tue, 12 Oct 2021 23:46:42 +0800 |
4 | Subject: [PATCH] BiF/CMakeLists.txt: remove opt from DEPENDS | 4 | Subject: [PATCH] BiF/CMakeLists.txt: remove opt from DEPENDS |
@@ -30,6 +30,3 @@ index d20d7f887..882e09fea 100644 | |||
30 | BYPRODUCTS ${BIF_OPT_BC_PATH} | 30 | BYPRODUCTS ${BIF_OPT_BC_PATH} |
31 | SOURCES ${CMCL_SRC_PATH}) | 31 | SOURCES ${CMCL_SRC_PATH}) |
32 | set(${RES_FILE} ${BIF_OPT_BC_NAME} PARENT_SCOPE) | 32 | set(${RES_FILE} ${BIF_OPT_BC_NAME} PARENT_SCOPE) |
33 | -- | ||
34 | 2.43.2 | ||
35 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-external-SPIRV-Tools-change-path-to-tools-and-header.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-external-SPIRV-Tools-change-path-to-tools-and-header.patch index dca75e22..7dc0bc20 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-external-SPIRV-Tools-change-path-to-tools-and-header.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-external-SPIRV-Tools-change-path-to-tools-and-header.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From e69a3181482e5f442756a61c7b683914072884f1 Mon Sep 17 00:00:00 2001 | 1 | From 251e2854dd206ebf66e5908d3277e4585fe2a63b Mon Sep 17 00:00:00 2001 |
2 | From: Anuj Mittal <anuj.mittal@intel.com> | 2 | From: Anuj Mittal <anuj.mittal@intel.com> |
3 | Date: Mon, 9 Jan 2023 11:43:05 +0800 | 3 | Date: Mon, 9 Jan 2023 11:43:05 +0800 |
4 | Subject: [PATCH] external/SPIRV-Tools: change path to tools and headers | 4 | Subject: [PATCH] external/SPIRV-Tools: change path to tools and headers |
@@ -9,16 +9,15 @@ file path substitutions take place. | |||
9 | Upstream-Status: Inappropriate | 9 | Upstream-Status: Inappropriate |
10 | 10 | ||
11 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | 11 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> |
12 | |||
13 | --- | 12 | --- |
14 | external/SPIRV-Tools/CMakeLists.txt | 4 ++-- | 13 | external/SPIRV-Tools/CMakeLists.txt | 4 ++-- |
15 | 1 file changed, 2 insertions(+), 2 deletions(-) | 14 | 1 file changed, 2 insertions(+), 2 deletions(-) |
16 | 15 | ||
17 | diff --git a/external/SPIRV-Tools/CMakeLists.txt b/external/SPIRV-Tools/CMakeLists.txt | 16 | diff --git a/external/SPIRV-Tools/CMakeLists.txt b/external/SPIRV-Tools/CMakeLists.txt |
18 | index 9afa5746c..7ca24d5dc 100644 | 17 | index 31108b96b..007c24bf0 100644 |
19 | --- a/external/SPIRV-Tools/CMakeLists.txt | 18 | --- a/external/SPIRV-Tools/CMakeLists.txt |
20 | +++ b/external/SPIRV-Tools/CMakeLists.txt | 19 | +++ b/external/SPIRV-Tools/CMakeLists.txt |
21 | @@ -43,8 +43,8 @@ else() #By default use build from sources | 20 | @@ -45,8 +45,8 @@ else() #By default use build from sources |
22 | message(STATUS "[SPIRV-Tools] : Building from source") | 21 | message(STATUS "[SPIRV-Tools] : Building from source") |
23 | message(STATUS "[SPIRV-Tools] : Current source dir: ${CMAKE_CURRENT_SOURCE_DIR}") | 22 | message(STATUS "[SPIRV-Tools] : Current source dir: ${CMAKE_CURRENT_SOURCE_DIR}") |
24 | 23 | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-fix-tblgen.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-fix-tblgen.patch index 39443931..3d9ae02f 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-fix-tblgen.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-fix-tblgen.patch | |||
@@ -1,19 +1,18 @@ | |||
1 | From 5648568e597acd0fed82aac3e6aef0f95a1b78d1 Mon Sep 17 00:00:00 2001 | 1 | From 1641dc87b2ed6b6b87b2cef824e4d66da65b0b30 Mon Sep 17 00:00:00 2001 |
2 | From: Anuj Mittal <anuj.mittal@intel.com> | 2 | From: Anuj Mittal <anuj.mittal@intel.com> |
3 | Date: Thu, 19 May 2022 22:50:09 +0800 | 3 | Date: Thu, 19 May 2022 22:50:09 +0800 |
4 | Subject: [PATCH] fix tblgen | 4 | Subject: [PATCH] fix tblgen |
5 | 5 | ||
6 | Upstream-Status: Inappropriate [OE specific] | 6 | Upstream-Status: Inappropriate [OE specific] |
7 | |||
8 | --- | 7 | --- |
9 | IGC/cmake/igc_llvm.cmake | 2 +- | 8 | IGC/cmake/igc_llvm.cmake | 2 +- |
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | 9 | 1 file changed, 1 insertion(+), 1 deletion(-) |
11 | 10 | ||
12 | diff --git a/IGC/cmake/igc_llvm.cmake b/IGC/cmake/igc_llvm.cmake | 11 | diff --git a/IGC/cmake/igc_llvm.cmake b/IGC/cmake/igc_llvm.cmake |
13 | index 10322533c..9020cb3c8 100644 | 12 | index b708cc904..fe4668890 100644 |
14 | --- a/IGC/cmake/igc_llvm.cmake | 13 | --- a/IGC/cmake/igc_llvm.cmake |
15 | +++ b/IGC/cmake/igc_llvm.cmake | 14 | +++ b/IGC/cmake/igc_llvm.cmake |
16 | @@ -52,7 +52,7 @@ else() | 15 | @@ -53,7 +53,7 @@ else() |
17 | set(LLVM_OPT_EXE "opt" CACHE STRING "") | 16 | set(LLVM_OPT_EXE "opt" CACHE STRING "") |
18 | 17 | ||
19 | set(LLVM_TABLEGEN_EXE "llvm-tblgen") | 18 | set(LLVM_TABLEGEN_EXE "llvm-tblgen") |
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0003-Improve-Reproducibility-for-src-package.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0003-Improve-Reproducibility-for-src-package.patch index 650130a8..9f2bc455 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0003-Improve-Reproducibility-for-src-package.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0003-Improve-Reproducibility-for-src-package.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 0559332abd04b6c8bc70171d201f43d2e4735336 Mon Sep 17 00:00:00 2001 | 1 | From ca136c04d4ac60e3febc8ea2b9c4d4736365a424 Mon Sep 17 00:00:00 2001 |
2 | From: Lee Chee Yang <chee.yang.lee@intel.com> | 2 | From: Lee Chee Yang <chee.yang.lee@intel.com> |
3 | Date: Wed, 2 Sep 2020 08:28:35 +0800 | 3 | Date: Wed, 2 Sep 2020 08:28:35 +0800 |
4 | Subject: [PATCH] Improve Reproducibility for src package | 4 | Subject: [PATCH] Improve Reproducibility for src package |
@@ -9,16 +9,15 @@ this only works on bison 3.7 onward, hence check for bison version | |||
9 | before adding the flags. | 9 | before adding the flags. |
10 | Upstream-Status: Inappropriate [applying --file-prefix-map in such way does not work for upstream] | 10 | Upstream-Status: Inappropriate [applying --file-prefix-map in such way does not work for upstream] |
11 | Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> | 11 | Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> |
12 | |||
13 | --- | 12 | --- |
14 | visa/CMakeLists.txt | 7 +++++-- | 13 | visa/CMakeLists.txt | 7 +++++-- |
15 | 1 file changed, 5 insertions(+), 2 deletions(-) | 14 | 1 file changed, 5 insertions(+), 2 deletions(-) |
16 | 15 | ||
17 | diff --git a/visa/CMakeLists.txt b/visa/CMakeLists.txt | 16 | diff --git a/visa/CMakeLists.txt b/visa/CMakeLists.txt |
18 | index 6be467587..930c386a6 100644 | 17 | index 1b01b3389..8d608163d 100644 |
19 | --- a/visa/CMakeLists.txt | 18 | --- a/visa/CMakeLists.txt |
20 | +++ b/visa/CMakeLists.txt | 19 | +++ b/visa/CMakeLists.txt |
21 | @@ -123,8 +123,11 @@ endif() | 20 | @@ -133,8 +133,11 @@ endif() |
22 | set(bison_output_file ${CMAKE_CURRENT_BINARY_DIR}/CISA.tab.cpp) | 21 | set(bison_output_file ${CMAKE_CURRENT_BINARY_DIR}/CISA.tab.cpp) |
23 | set(flex_output_file ${CMAKE_CURRENT_BINARY_DIR}/lex.CISA.cpp) | 22 | set(flex_output_file ${CMAKE_CURRENT_BINARY_DIR}/lex.CISA.cpp) |
24 | 23 | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.16510.2.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.16900.23.bb index 24eb97bd..16dcd360 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.16510.2.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.16900.23.bb | |||
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc | |||
8 | file://LICENSE.md;md5=488d74376edf2765f6e78d271543dde3 \ | 8 | file://LICENSE.md;md5=488d74376edf2765f6e78d271543dde3 \ |
9 | file://NOTICES.txt;md5=b81a52411c84df3419f20bad4d755880" | 9 | file://NOTICES.txt;md5=b81a52411c84df3419f20bad4d755880" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;name=igc;branch=releases/igc-1.0.16510 \ | 11 | SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;name=igc;branch=releases/igc-1.0.16900 \ |
12 | git://github.com/intel/vc-intrinsics.git;protocol=https;destsuffix=git/vc-intrinsics;name=vc;nobranch=1 \ | 12 | git://github.com/intel/vc-intrinsics.git;protocol=https;destsuffix=git/vc-intrinsics;name=vc;nobranch=1 \ |
13 | git://github.com/KhronosGroup/SPIRV-Tools.git;protocol=https;destsuffix=git/SPIRV-Tools;name=spirv-tools;branch=main \ | 13 | git://github.com/KhronosGroup/SPIRV-Tools.git;protocol=https;destsuffix=git/SPIRV-Tools;name=spirv-tools;branch=main \ |
14 | git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=git/SPIRV-Headers;name=spirv-headers;branch=main \ | 14 | git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=git/SPIRV-Headers;name=spirv-headers;branch=main \ |
@@ -19,7 +19,7 @@ SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;nam | |||
19 | 19 | ||
20 | SRC_URI:append:class-native = " file://0001-fix-tblgen.patch" | 20 | SRC_URI:append:class-native = " file://0001-fix-tblgen.patch" |
21 | 21 | ||
22 | SRCREV_igc = "c2495d45f37fadd963ad22eb0cc1a8235a306775" | 22 | SRCREV_igc = "626c9e4a18b174f2f0f2d5328166f38da4538500" |
23 | SRCREV_vc = "f9c34404d0ea9abad83875a10bd48d88cea90ebd" | 23 | SRCREV_vc = "f9c34404d0ea9abad83875a10bd48d88cea90ebd" |
24 | SRCREV_spirv-tools = "f0cc85efdbbe3a46eae90e0f915dc1509836d0fc" | 24 | SRCREV_spirv-tools = "f0cc85efdbbe3a46eae90e0f915dc1509836d0fc" |
25 | SRCREV_spirv-headers = "1c6bb2743599e6eb6f37b2969acc0aef812e32e3" | 25 | SRCREV_spirv-headers = "1c6bb2743599e6eb6f37b2969acc0aef812e32e3" |