diff options
-rw-r--r-- | dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-build-with-GCC-13-and-possibly-Clang-15.patch | 36 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.17.0.bb | 1 |
2 files changed, 37 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-build-with-GCC-13-and-possibly-Clang-15.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-build-with-GCC-13-and-possibly-Clang-15.patch new file mode 100644 index 00000000..afe3c3ad --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-build-with-GCC-13-and-possibly-Clang-15.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Luya Tshimbalanga <luya@fedoraproject.org> | ||
3 | Date: Tue, 28 Feb 2023 17:20:21 -0800 | ||
4 | Subject: [PATCH] Fix build with GCC 13 and possibly Clang 15 | ||
5 | |||
6 | This fix add missing <cstdint> include to handle "uint32_t". | ||
7 | |||
8 | Upstream-Status: Backport [https://github.com/ispc/ispc/commit/ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9] | ||
9 | |||
10 | Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> | ||
11 | --- | ||
12 | src/target_registry.h | 3 ++- | ||
13 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/src/target_registry.h b/src/target_registry.h | ||
16 | index 2f7d13a8..bad4ed08 100644 | ||
17 | --- a/src/target_registry.h | ||
18 | +++ b/src/target_registry.h | ||
19 | @@ -1,5 +1,5 @@ | ||
20 | /* | ||
21 | - Copyright (c) 2019-2021, Intel Corporation | ||
22 | + Copyright (c) 2019-2023, Intel Corporation | ||
23 | All rights reserved. | ||
24 | |||
25 | Redistribution and use in source and binary forms, with or without | ||
26 | @@ -40,6 +40,7 @@ | ||
27 | #include "bitcode_lib.h" | ||
28 | |||
29 | #include <bitset> | ||
30 | +#include <cstdint> | ||
31 | #include <map> | ||
32 | #include <vector> | ||
33 | |||
34 | -- | ||
35 | 2.34.1 | ||
36 | |||
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.17.0.bb b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.17.0.bb index c50d8ef3..dd4841e7 100644 --- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.17.0.bb +++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.17.0.bb | |||
@@ -17,6 +17,7 @@ SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \ | |||
17 | file://0001-Enable-LLVM-15.0-support.patch \ | 17 | file://0001-Enable-LLVM-15.0-support.patch \ |
18 | file://0001-CMakeLists.txt-allow-to-pick-llvm-config-from-usr-bi.patch \ | 18 | file://0001-CMakeLists.txt-allow-to-pick-llvm-config-from-usr-bi.patch \ |
19 | file://0001-Produce-position-independent-code-for-testing.patch \ | 19 | file://0001-Produce-position-independent-code-for-testing.patch \ |
20 | file://0001-Fix-build-with-GCC-13-and-possibly-Clang-15.patch \ | ||
20 | " | 21 | " |
21 | SRCREV = "7ad8429369a4d5ced6b524fdfffe623939d8fe9a" | 22 | SRCREV = "7ad8429369a4d5ced6b524fdfffe623939d8fe9a" |
22 | 23 | ||