summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch
new file mode 100644
index 00000000..bc718eed
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch
@@ -0,0 +1,27 @@
1From a40ed1c5274f867385610bb57ceee75bf4722de9 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 30 May 2023 09:03:01 +0800
4Subject: [PATCH 1/5] intel-compute-runtime: fix build with gcc13
5
6Upstream-Status: Inappropriate
7Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
8---
9 CMakeLists.txt | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/CMakeLists.txt b/CMakeLists.txt
13index 5e43b4ad76..619243913b 100644
14--- a/CMakeLists.txt
15+++ b/CMakeLists.txt
16@@ -811,7 +811,7 @@ if(NOT MSVC)
17 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-noexcept-type") # Added for gtest
18 endif()
19 endif()
20- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Werror=vla")
21+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror=vla")
22
23 if(USE_SANITIZE_UB)
24 check_cxx_compiler_flag(-fsanitize=undefined COMPILER_SUPPORTS_UNDEFINED_BEHAVIOR_SANITIZER)
25--
262.34.1
27