summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch56
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch16
2 files changed, 72 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch
new file mode 100644
index 00000000..7f75cbb8
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch
@@ -0,0 +1,56 @@
1From 078af5b7ac3086d336f76183b798771263491c34 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 30 May 2023 11:07:10 +0800
4Subject: [PATCH] add missing cstdint header to fix compile with gcc13
5
6Include the headers as per:
7https://gcc.gnu.org/gcc-13/porting_to.html
8
9Upstream-Status: Pending
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 opencl/test/unit_test/built_ins/built_ins_file_names.h | 1 +
14 shared/test/common/os_interface/linux/sys_calls_linux_ult.h | 1 +
15 third_party/aot_config_headers/platforms.h | 1 +
16 3 files changed, 3 insertions(+)
17
18diff --git a/opencl/test/unit_test/built_ins/built_ins_file_names.h b/opencl/test/unit_test/built_ins/built_ins_file_names.h
19index 08dc38d406..e04f916e71 100644
20--- a/opencl/test/unit_test/built_ins/built_ins_file_names.h
21+++ b/opencl/test/unit_test/built_ins/built_ins_file_names.h
22@@ -9,6 +9,7 @@
23
24 #include <string>
25 #include <vector>
26+#include <cstdint>
27
28 namespace NEO {
29 std::vector<std::string> getBuiltInFileNames(bool imagesSupport);
30diff --git a/shared/test/common/os_interface/linux/sys_calls_linux_ult.h b/shared/test/common/os_interface/linux/sys_calls_linux_ult.h
31index 9f1fd4dacb..e64dd40254 100644
32--- a/shared/test/common/os_interface/linux/sys_calls_linux_ult.h
33+++ b/shared/test/common/os_interface/linux/sys_calls_linux_ult.h
34@@ -7,6 +7,7 @@
35
36 #pragma once
37
38+#include <cstdint>
39 #include <iostream>
40 #include <poll.h>
41 #include <sys/stat.h>
42diff --git a/third_party/aot_config_headers/platforms.h b/third_party/aot_config_headers/platforms.h
43index 056d615503..d2024d1b54 100644
44--- a/third_party/aot_config_headers/platforms.h
45+++ b/third_party/aot_config_headers/platforms.h
46@@ -7,6 +7,7 @@
47
48 #include <map>
49 #include <string>
50+#include <cstdint>
51
52 #pragma once
53
54--
552.37.3
56
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch
new file mode 100644
index 00000000..20d9b847
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch
@@ -0,0 +1,16 @@
1Upstream-Status: Inappropriate
2Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
3
4diff --git a/CMakeLists.txt b/CMakeLists.txt
5index d52e089778..bc0cf35014 100644
6--- a/CMakeLists.txt
7+++ b/CMakeLists.txt
8@@ -727,7 +727,7 @@ if(NOT MSVC)
9 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-noexcept-type") # Added for gtest
10 endif()
11 endif()
12- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Werror=vla")
13+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror=vla")
14
15 if(USE_SANITIZE_UB)
16 check_cxx_compiler_flag(-fsanitize=undefined COMPILER_SUPPORTS_UNDEFINED_BEHAVIOR_SANITIZER)