diff options
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch | 32 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.20.16837.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb) | 16 |
2 files changed, 45 insertions, 3 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch new file mode 100644 index 00000000..eae129c7 --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From d6c5bf050f3d50ca02866ec90e474ef540df2ffa Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Wed, 27 May 2020 11:12:09 +0000 | ||
4 | Subject: [PATCH] intel-compute-runtime: allow to find cpp_generation_tool | ||
5 | |||
6 | Build not able to locate cpp_generation_tool. | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe specific] | ||
9 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
10 | --- | ||
11 | shared/source/built_ins/kernels/CMakeLists.txt | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt | ||
15 | index 308a6cb3b..9f34359c3 100644 | ||
16 | --- a/shared/source/built_ins/kernels/CMakeLists.txt | ||
17 | +++ b/shared/source/built_ins/kernels/CMakeLists.txt | ||
18 | @@ -84,9 +84,9 @@ function(compile_builtin gen_type platform_type builtin bits builtin_options) | ||
19 | ) | ||
20 | add_custom_command( | ||
21 | OUTPUT ${OUTPUT_FILE_CPP} | ||
22 | - COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${BASENAME} --platform ${family_name_with_type} | ||
23 | + COMMAND cpp_generate_tool --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${BASENAME} --platform ${family_name_with_type} | ||
24 | WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} | ||
25 | - DEPENDS ${OUTPUTPATH_BASE}.gen $<TARGET_FILE:cpp_generate_tool> | ||
26 | + DEPENDS ${OUTPUTPATH_BASE}.gen cpp_generate_tool | ||
27 | ) | ||
28 | endfunction() | ||
29 | |||
30 | -- | ||
31 | 2.24.1 | ||
32 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.20.16837.bb index 5525b66a..102b91fd 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.20.16837.bb | |||
@@ -10,8 +10,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae27f47fd6755510247c19e547e4c804 \ | |||
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \ | 11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \ |
12 | " | 12 | " |
13 | SRC_URI_append_class-target = " file://allow-to-find-cpp-generation-tool.patch" | ||
13 | 14 | ||
14 | SRCREV = "e0633548a9bd025c70bc7f3539eef094b1bc9ce1" | 15 | SRCREV = "b9b34659c8817393dd8ce35bf37c167c23cefcff" |
15 | 16 | ||
16 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
17 | 18 | ||
@@ -30,12 +31,21 @@ EXTRA_OECMAKE = " \ | |||
30 | -DBUILD_TYPE=Release \ | 31 | -DBUILD_TYPE=Release \ |
31 | -DSKIP_UNIT_TESTS=1 \ | 32 | -DSKIP_UNIT_TESTS=1 \ |
32 | -DCCACHE_ALLOWED=FALSE \ | 33 | -DCCACHE_ALLOWED=FALSE \ |
33 | -Dcloc_cmd_prefix=ocloc \ | ||
34 | " | 34 | " |
35 | EXTRA_OECMAKE_append_class-target = " \ | ||
36 | -Dcloc_cmd_prefix=ocloc \ | ||
37 | " | ||
38 | do_install_append_class-native() { | ||
39 | install -d ${D}${bindir} | ||
40 | install ${B}/bin/cpp_generate_tool ${D}${bindir}/ | ||
41 | } | ||
42 | |||
43 | SOLIBS = ".so" | ||
44 | FILES_SOLIBSDEV = "" | ||
35 | 45 | ||
36 | FILES_${PN} += " \ | 46 | FILES_${PN} += " \ |
37 | ${libdir}/intel-opencl/libigdrcl.so \ | 47 | ${libdir}/intel-opencl/libigdrcl.so \ |
38 | ${libdir}/intel-opencl/libocloc.so \ | 48 | ${libdir}/libocloc.so \ |
39 | " | 49 | " |
40 | 50 | ||
41 | BBCLASSEXTEND = "native nativesdk" | 51 | BBCLASSEXTEND = "native nativesdk" |