diff options
Diffstat (limited to 'dynamic-layers/clang-layer')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-core/ispc/ispc/ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch | 32 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb | 1 |
2 files changed, 33 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch new file mode 100644 index 00000000..52fb8126 --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Luya Tshimbalanga <luya@fedoraproject.org> | ||
3 | Date: Tue, 28 Feb 2023 17:20:21 -0800 | ||
4 | Subject: [PATCH] Fix build with GCC 13 and possibly Clang 15 | ||
5 | |||
6 | This fix add missing <cstdint> include to handle "uint32_t". | ||
7 | |||
8 | Upstream-Status: Backport | ||
9 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
10 | --- | ||
11 | src/target_registry.h | 3 ++- | ||
12 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/src/target_registry.h b/src/target_registry.h | ||
15 | index 2f7d13a8af..bad4ed0815 100644 | ||
16 | --- a/src/target_registry.h | ||
17 | +++ b/src/target_registry.h | ||
18 | @@ -1,5 +1,5 @@ | ||
19 | /* | ||
20 | - Copyright (c) 2019-2021, Intel Corporation | ||
21 | + Copyright (c) 2019-2023, Intel Corporation | ||
22 | All rights reserved. | ||
23 | |||
24 | Redistribution and use in source and binary forms, with or without | ||
25 | @@ -40,6 +40,7 @@ | ||
26 | #include "bitcode_lib.h" | ||
27 | |||
28 | #include <bitset> | ||
29 | +#include <cstdint> | ||
30 | #include <map> | ||
31 | #include <vector> | ||
32 | |||
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb index a471b154..ab48f5fb 100644 --- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb +++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.19.0.bb | |||
@@ -17,6 +17,7 @@ SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \ | |||
17 | file://0001-Fix-QA-Issues.patch \ | 17 | file://0001-Fix-QA-Issues.patch \ |
18 | file://0001-Add-print-function-to-print-test-run-status-in-ptest.patch \ | 18 | file://0001-Add-print-function-to-print-test-run-status-in-ptest.patch \ |
19 | file://0001-CMakeLists.txt-allow-to-pick-llvm-config-from-usr-bi.patch \ | 19 | file://0001-CMakeLists.txt-allow-to-pick-llvm-config-from-usr-bi.patch \ |
20 | file://ffc75e464ff2b8fce7dbf74f1846ebd0852bc6f9.patch \ | ||
20 | file://run-ptest \ | 21 | file://run-ptest \ |
21 | " | 22 | " |
22 | 23 | ||