diff options
Diffstat (limited to 'dynamic-layers/clang-layer')
3 files changed, 13 insertions, 26 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc index 061ecbba..7c8c2513 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc +++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc | |||
@@ -19,4 +19,17 @@ DEPENDS:append:class-target = " opencl-clang-native" | |||
19 | COMPATIBLE_HOST = '(x86_64).*-linux' | 19 | COMPATIBLE_HOST = '(x86_64).*-linux' |
20 | COMPATIBLE_HOST:libc-musl = "null" | 20 | COMPATIBLE_HOST:libc-musl = "null" |
21 | 21 | ||
22 | DEPENDS += " spirv-llvm-translator" | ||
23 | |||
24 | EXTRA_OECMAKE += "\ | ||
25 | -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ | ||
26 | -DCMAKE_SKIP_RPATH=TRUE \ | ||
27 | -DPREFERRED_LLVM_VERSION=${LLVMVERSION} \ | ||
28 | " | ||
29 | |||
30 | do_install:append:class-native() { | ||
31 | install -d ${D}${bindir} | ||
32 | install -m 0755 ${B}/bin/linux_resource_linker ${D}${bindir}/ | ||
33 | } | ||
34 | |||
22 | BBCLASSEXTEND = "native nativesdk" | 35 | BBCLASSEXTEND = "native nativesdk" |
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb index a36bd53b..2a7af0c9 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb | |||
@@ -3,16 +3,3 @@ require opencl-clang.inc | |||
3 | SRCREV = "cf95b338d14685e4f3402ab1828bef31d48f1fd6" | 3 | SRCREV = "cf95b338d14685e4f3402ab1828bef31d48f1fd6" |
4 | 4 | ||
5 | BRANCH = "ocl-open-140" | 5 | BRANCH = "ocl-open-140" |
6 | |||
7 | DEPENDS += " spirv-llvm-translator" | ||
8 | |||
9 | EXTRA_OECMAKE += "\ | ||
10 | -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ | ||
11 | -DCMAKE_SKIP_RPATH=TRUE \ | ||
12 | -DPREFERRED_LLVM_VERSION=${LLVMVERSION} \ | ||
13 | " | ||
14 | |||
15 | do_install:append:class-native() { | ||
16 | install -d ${D}${bindir} | ||
17 | install -m 0755 ${B}/bin/linux_resource_linker ${D}${bindir}/ | ||
18 | } | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_15.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_15.0.0.bb index 84629cff..0865a2af 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_15.0.0.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_15.0.0.bb | |||
@@ -3,16 +3,3 @@ require opencl-clang.inc | |||
3 | SRCREV = "bc1d13ecc1c6f7aa5da3acf33165037d3fc5ed06" | 3 | SRCREV = "bc1d13ecc1c6f7aa5da3acf33165037d3fc5ed06" |
4 | 4 | ||
5 | BRANCH = "ocl-open-150" | 5 | BRANCH = "ocl-open-150" |
6 | |||
7 | DEPENDS += " spirv-llvm-translator" | ||
8 | |||
9 | EXTRA_OECMAKE += "\ | ||
10 | -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ | ||
11 | -DCMAKE_SKIP_RPATH=TRUE \ | ||
12 | -DPREFERRED_LLVM_VERSION=${LLVMVERSION} \ | ||
13 | " | ||
14 | |||
15 | do_install:append:class-native() { | ||
16 | install -d ${D}${bindir} | ||
17 | install -m 0755 ${B}/bin/linux_resource_linker ${D}${bindir}/ | ||
18 | } | ||