diff options
Diffstat (limited to 'dynamic-layers/clang-layer')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch | 10 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.22.26516.18.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.17.26241.22.bb) | 4 |
2 files changed, 7 insertions, 7 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch index 7f75cbb8..e39d801b 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/add-missing-cstdint-header-to-fix-compile-with-gcc13.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 078af5b7ac3086d336f76183b798771263491c34 Mon Sep 17 00:00:00 2001 | 1 | From 41d9b88b2edfcb9fee82ccfc68bd6030a282292c Mon Sep 17 00:00:00 2001 |
2 | From: Anuj Mittal <anuj.mittal@intel.com> | 2 | From: Anuj Mittal <anuj.mittal@intel.com> |
3 | Date: Tue, 30 May 2023 11:07:10 +0800 | 3 | Date: Tue, 30 May 2023 11:07:10 +0800 |
4 | Subject: [PATCH] add missing cstdint header to fix compile with gcc13 | 4 | Subject: [PATCH] add missing cstdint header to fix compile with gcc13 |
@@ -28,7 +28,7 @@ index 08dc38d406..e04f916e71 100644 | |||
28 | namespace NEO { | 28 | namespace NEO { |
29 | std::vector<std::string> getBuiltInFileNames(bool imagesSupport); | 29 | std::vector<std::string> getBuiltInFileNames(bool imagesSupport); |
30 | diff --git a/shared/test/common/os_interface/linux/sys_calls_linux_ult.h b/shared/test/common/os_interface/linux/sys_calls_linux_ult.h | 30 | diff --git a/shared/test/common/os_interface/linux/sys_calls_linux_ult.h b/shared/test/common/os_interface/linux/sys_calls_linux_ult.h |
31 | index 9f1fd4dacb..e64dd40254 100644 | 31 | index f30d425abe..1bc78d3335 100644 |
32 | --- a/shared/test/common/os_interface/linux/sys_calls_linux_ult.h | 32 | --- a/shared/test/common/os_interface/linux/sys_calls_linux_ult.h |
33 | +++ b/shared/test/common/os_interface/linux/sys_calls_linux_ult.h | 33 | +++ b/shared/test/common/os_interface/linux/sys_calls_linux_ult.h |
34 | @@ -7,6 +7,7 @@ | 34 | @@ -7,6 +7,7 @@ |
@@ -36,11 +36,11 @@ index 9f1fd4dacb..e64dd40254 100644 | |||
36 | #pragma once | 36 | #pragma once |
37 | 37 | ||
38 | +#include <cstdint> | 38 | +#include <cstdint> |
39 | #include <dirent.h> | ||
39 | #include <iostream> | 40 | #include <iostream> |
40 | #include <poll.h> | 41 | #include <poll.h> |
41 | #include <sys/stat.h> | ||
42 | diff --git a/third_party/aot_config_headers/platforms.h b/third_party/aot_config_headers/platforms.h | 42 | diff --git a/third_party/aot_config_headers/platforms.h b/third_party/aot_config_headers/platforms.h |
43 | index 056d615503..d2024d1b54 100644 | 43 | index 919e2714f2..ee82cb7ff2 100644 |
44 | --- a/third_party/aot_config_headers/platforms.h | 44 | --- a/third_party/aot_config_headers/platforms.h |
45 | +++ b/third_party/aot_config_headers/platforms.h | 45 | +++ b/third_party/aot_config_headers/platforms.h |
46 | @@ -7,6 +7,7 @@ | 46 | @@ -7,6 +7,7 @@ |
@@ -52,5 +52,5 @@ index 056d615503..d2024d1b54 100644 | |||
52 | #pragma once | 52 | #pragma once |
53 | 53 | ||
54 | -- | 54 | -- |
55 | 2.37.3 | 55 | 2.34.1 |
56 | 56 | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.17.26241.22.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.22.26516.18.bb index 8aef6e9a..f3372672 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.17.26241.22.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_23.22.26516.18.bb | |||
@@ -8,14 +8,14 @@ LICENSE = "MIT" | |||
8 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \ | 8 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \ |
9 | file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" | 9 | file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/23.17 \ | 11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/23.22 \ |
12 | file://disable-werror.patch \ | 12 | file://disable-werror.patch \ |
13 | file://add-missing-cstdint-header-to-fix-compile-with-gcc13.patch \ | 13 | file://add-missing-cstdint-header-to-fix-compile-with-gcc13.patch \ |
14 | file://allow-to-find-cpp-generation-tool.patch \ | 14 | file://allow-to-find-cpp-generation-tool.patch \ |
15 | file://external-ocloc.patch \ | 15 | file://external-ocloc.patch \ |
16 | " | 16 | " |
17 | 17 | ||
18 | SRCREV = "0bb5b3408e6cb61b477e7cad296fd278b11e73be" | 18 | SRCREV = "f6bf19f1dde6b852676c319a7c67a0a4c3f25d02" |
19 | 19 | ||
20 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
21 | 21 | ||