diff options
Diffstat (limited to 'dynamic-layers')
5 files changed, 25 insertions, 69 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch index 20d9b847..bc718eed 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/disable-werror.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch | |||
@@ -1,11 +1,19 @@ | |||
1 | From a40ed1c5274f867385610bb57ceee75bf4722de9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Anuj Mittal <anuj.mittal@intel.com> | ||
3 | Date: Tue, 30 May 2023 09:03:01 +0800 | ||
4 | Subject: [PATCH 1/5] intel-compute-runtime: fix build with gcc13 | ||
5 | |||
1 | Upstream-Status: Inappropriate | 6 | Upstream-Status: Inappropriate |
2 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | 7 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> |
8 | --- | ||
9 | CMakeLists.txt | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
3 | 11 | ||
4 | diff --git a/CMakeLists.txt b/CMakeLists.txt | 12 | diff --git a/CMakeLists.txt b/CMakeLists.txt |
5 | index d52e089778..bc0cf35014 100644 | 13 | index 5e43b4ad76..619243913b 100644 |
6 | --- a/CMakeLists.txt | 14 | --- a/CMakeLists.txt |
7 | +++ b/CMakeLists.txt | 15 | +++ b/CMakeLists.txt |
8 | @@ -727,7 +727,7 @@ if(NOT MSVC) | 16 | @@ -811,7 +811,7 @@ if(NOT MSVC) |
9 | set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-noexcept-type") # Added for gtest | 17 | set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-noexcept-type") # Added for gtest |
10 | endif() | 18 | endif() |
11 | endif() | 19 | endif() |
@@ -14,3 +22,6 @@ index d52e089778..bc0cf35014 100644 | |||
14 | 22 | ||
15 | if(USE_SANITIZE_UB) | 23 | if(USE_SANITIZE_UB) |
16 | check_cxx_compiler_flag(-fsanitize=undefined COMPILER_SUPPORTS_UNDEFINED_BEHAVIOR_SANITIZER) | 24 | check_cxx_compiler_flag(-fsanitize=undefined COMPILER_SUPPORTS_UNDEFINED_BEHAVIOR_SANITIZER) |
25 | -- | ||
26 | 2.34.1 | ||
27 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0002-Build-not-able-to-locate-cpp_generation_tool.patch index 265fcfa2..1ac21766 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0002-Build-not-able-to-locate-cpp_generation_tool.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From a6361d635e5f3046853883f3ac06fb175116933c Mon Sep 17 00:00:00 2001 | 1 | From 8c330d0cb5167612296801f0202b0de35e9ca88d Mon Sep 17 00:00:00 2001 |
2 | From: Dongwon Kim <dongwon.kim@intel.com> | 2 | From: Dongwon Kim <dongwon.kim@intel.com> |
3 | Date: Sat, 21 Aug 2021 16:09:39 -0700 | 3 | Date: Sat, 21 Aug 2021 16:09:39 -0700 |
4 | Subject: [PATCH] Build not able to locate cpp_generation_tool. | 4 | Subject: [PATCH 2/5] Build not able to locate cpp_generation_tool. |
5 | 5 | ||
6 | Upstream-Status: Inappropriate [oe specific] | 6 | Upstream-Status: Inappropriate [oe specific] |
7 | 7 | ||
@@ -47,5 +47,5 @@ index ed85a37c52..f7c9e79137 100644 | |||
47 | \ No newline at end of file | 47 | \ No newline at end of file |
48 | +apply_macro_for_each_core_type("SUPPORTED") | 48 | +apply_macro_for_each_core_type("SUPPORTED") |
49 | -- | 49 | -- |
50 | 2.43.2 | 50 | 2.34.1 |
51 | 51 | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/external-ocloc.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0003-external-ocloc.patch index 5f93b7b6..a0dec8af 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/external-ocloc.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0003-external-ocloc.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 1f58c22992ddea4167b01b44448528de427f50d5 Mon Sep 17 00:00:00 2001 | 1 | From 0006db5f55a9f08bd3452558a53704cd3bbb790f Mon Sep 17 00:00:00 2001 |
2 | From: Dongwon Kim <dongwon.kim@intel.com> | 2 | From: Dongwon Kim <dongwon.kim@intel.com> |
3 | Date: Wed, 2 Mar 2022 15:52:45 -0800 | 3 | Date: Wed, 2 Mar 2022 15:52:45 -0800 |
4 | Subject: [PATCH] external ocloc | 4 | Subject: [PATCH 3/5] external ocloc |
5 | 5 | ||
6 | Upstream-Status: Inappropriate | 6 | Upstream-Status: Inappropriate |
7 | 7 | ||
@@ -11,7 +11,7 @@ Signed-off-by: Dongwon Kim <dongwon.kim@intel.com> | |||
11 | 1 file changed, 8 insertions(+), 6 deletions(-) | 11 | 1 file changed, 8 insertions(+), 6 deletions(-) |
12 | 12 | ||
13 | diff --git a/cmake/ocloc_cmd_prefix.cmake b/cmake/ocloc_cmd_prefix.cmake | 13 | diff --git a/cmake/ocloc_cmd_prefix.cmake b/cmake/ocloc_cmd_prefix.cmake |
14 | index 2b44330831..03067c9df0 100644 | 14 | index 3fcadb682d..6d8022db2e 100644 |
15 | --- a/cmake/ocloc_cmd_prefix.cmake | 15 | --- a/cmake/ocloc_cmd_prefix.cmake |
16 | +++ b/cmake/ocloc_cmd_prefix.cmake | 16 | +++ b/cmake/ocloc_cmd_prefix.cmake |
17 | @@ -4,12 +4,14 @@ | 17 | @@ -4,12 +4,14 @@ |
@@ -36,5 +36,5 @@ index 2b44330831..03067c9df0 100644 | |||
36 | endif() | 36 | endif() |
37 | endif() | 37 | endif() |
38 | -- | 38 | -- |
39 | 2.37.3 | 39 | 2.34.1 |
40 | 40 | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/f10439aea214984a060566831f63d3aa198ef1b8.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/f10439aea214984a060566831f63d3aa198ef1b8.patch deleted file mode 100644 index b7fcb3d1..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/f10439aea214984a060566831f63d3aa198ef1b8.patch +++ /dev/null | |||
@@ -1,54 +0,0 @@ | |||
1 | From f10439aea214984a060566831f63d3aa198ef1b8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Pawel Cieslak <pawel.cieslak@intel.com> | ||
3 | Date: Tue, 14 May 2024 14:20:24 +0000 | ||
4 | Subject: [PATCH] fix: include <algorithm> where std::find is used | ||
5 | |||
6 | Related-To: NEO-11375 | ||
7 | Signed-off-by: Pawel Cieslak <pawel.cieslak@intel.com> | ||
8 | |||
9 | Upstream-Status: Backport [https://github.com/intel/compute-runtime/commit/f10439aea214984a060566831f63d3aa198ef1b8] | ||
10 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
11 | --- | ||
12 | .../sources/linux/nl_api/test_sysman_iaf_nl_api_prelim.cpp | 3 ++- | ||
13 | shared/test/unit_test/gmm_helper/gmm_resource_info_tests.cpp | 4 +++- | ||
14 | 2 files changed, 5 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/level_zero/sysman/test/unit_tests/sources/linux/nl_api/test_sysman_iaf_nl_api_prelim.cpp b/level_zero/sysman/test/unit_tests/sources/linux/nl_api/test_sysman_iaf_nl_api_prelim.cpp | ||
17 | index 6ab1b751d866..8a224752c8fc 100644 | ||
18 | --- a/level_zero/sysman/test/unit_tests/sources/linux/nl_api/test_sysman_iaf_nl_api_prelim.cpp | ||
19 | +++ b/level_zero/sysman/test/unit_tests/sources/linux/nl_api/test_sysman_iaf_nl_api_prelim.cpp | ||
20 | @@ -1,5 +1,5 @@ | ||
21 | /* | ||
22 | - * Copyright (C) 2021-2023 Intel Corporation | ||
23 | + * Copyright (C) 2021-2024 Intel Corporation | ||
24 | * | ||
25 | * SPDX-License-Identifier: MIT | ||
26 | * | ||
27 | @@ -13,6 +13,7 @@ | ||
28 | |||
29 | #include "gtest/gtest.h" | ||
30 | |||
31 | +#include <algorithm> | ||
32 | #include <limits> | ||
33 | #include <netlink/handlers.h> | ||
34 | |||
35 | diff --git a/shared/test/unit_test/gmm_helper/gmm_resource_info_tests.cpp b/shared/test/unit_test/gmm_helper/gmm_resource_info_tests.cpp | ||
36 | index 206c272c5bb2..e961248e73a3 100644 | ||
37 | --- a/shared/test/unit_test/gmm_helper/gmm_resource_info_tests.cpp | ||
38 | +++ b/shared/test/unit_test/gmm_helper/gmm_resource_info_tests.cpp | ||
39 | @@ -1,5 +1,5 @@ | ||
40 | /* | ||
41 | - * Copyright (C) 2021-2023 Intel Corporation | ||
42 | + * Copyright (C) 2021-2024 Intel Corporation | ||
43 | * | ||
44 | * SPDX-License-Identifier: MIT | ||
45 | * | ||
46 | @@ -17,6 +17,8 @@ | ||
47 | |||
48 | #include "gtest/gtest.h" | ||
49 | |||
50 | +#include <algorithm> | ||
51 | + | ||
52 | using namespace NEO; | ||
53 | |||
54 | struct MockGmmHandleAllocator : NEO::GmmHandleAllocator { | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.13.29138.7.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.22.29735.20.bb index 7280ed03..c7756bc6 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.13.29138.7.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.22.29735.20.bb | |||
@@ -8,14 +8,13 @@ LICENSE = "MIT & Apache-2.0" | |||
8 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \ | 8 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \ |
9 | file://third_party/opencl_headers/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | 9 | file://third_party/opencl_headers/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/24.13 \ | 11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/24.22 \ |
12 | file://disable-werror.patch \ | 12 | file://0001-intel-compute-runtime-fix-build-with-gcc13.patch \ |
13 | file://allow-to-find-cpp-generation-tool.patch \ | 13 | file://0002-Build-not-able-to-locate-cpp_generation_tool.patch \ |
14 | file://external-ocloc.patch \ | 14 | file://0003-external-ocloc.patch \ |
15 | file://f10439aea214984a060566831f63d3aa198ef1b8.patch \ | ||
16 | " | 15 | " |
17 | 16 | ||
18 | SRCREV = "7131387cdbb02d480a225c70daef913a6c024a6e" | 17 | SRCREV = "6aa72243a0916e05a6c1dbe8a0a46711a96fda98" |
19 | 18 | ||
20 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
21 | 20 | ||