diff options
-rw-r--r-- | recipes-core/jamvm/jamvm/annotations.patch | 31 | ||||
-rw-r--r-- | recipes-core/jamvm/jamvm_git.bb | 6 |
2 files changed, 34 insertions, 3 deletions
diff --git a/recipes-core/jamvm/jamvm/annotations.patch b/recipes-core/jamvm/jamvm/annotations.patch new file mode 100644 index 0000000..6279366 --- /dev/null +++ b/recipes-core/jamvm/jamvm/annotations.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | Index: git/src/classlib/gnuclasspath/annotations.c | ||
2 | =================================================================== | ||
3 | --- git.orig/src/classlib/gnuclasspath/annotations.c 2013-07-29 10:44:38.597241346 +0000 | ||
4 | +++ git/src/classlib/gnuclasspath/annotations.c 2013-07-29 11:03:42.927744962 +0000 | ||
5 | @@ -247,7 +247,7 @@ | ||
6 | return anno; | ||
7 | } | ||
8 | |||
9 | -Object *parseAnnotations(Class *class, AnnotationData *annotations) { | ||
10 | +Object *parseAnnotations(Class *class, AttributeData *annotations) { | ||
11 | if(!anno_inited && !initAnnotation()) | ||
12 | return NULL; | ||
13 | |||
14 | @@ -290,7 +290,7 @@ | ||
15 | } | ||
16 | |||
17 | Object *getMethodParameterAnnotations(MethodBlock *mb) { | ||
18 | - AnnotationData *annotations; | ||
19 | + AttributeData *annotations; | ||
20 | Object **outer_array_data; | ||
21 | Object *outer_array; | ||
22 | int no_params, i; | ||
23 | @@ -342,7 +342,7 @@ | ||
24 | } | ||
25 | |||
26 | Object *getMethodDefaultValue(MethodBlock *mb) { | ||
27 | - AnnotationData *annotations; | ||
28 | + AttributeData *annotations; | ||
29 | |||
30 | if(!anno_inited && !initAnnotation()) | ||
31 | return NULL; | ||
diff --git a/recipes-core/jamvm/jamvm_git.bb b/recipes-core/jamvm/jamvm_git.bb index 88df6fc..97ed1cc 100644 --- a/recipes-core/jamvm/jamvm_git.bb +++ b/recipes-core/jamvm/jamvm_git.bb | |||
@@ -3,15 +3,15 @@ | |||
3 | 3 | ||
4 | require jamvm.inc | 4 | require jamvm.inc |
5 | 5 | ||
6 | SRCREV = "0972452d441544f7dd29c55d64f1ce3a5db90d82" | 6 | SRCREV = "ac22c9948434e528ece451642b4ebde40953ee7e" |
7 | PV = "1.5.5+1.6.0-devel+git${SRCPV}" | 7 | PV = "1.5.5+1.6.0-devel+git${SRCPV}" |
8 | 8 | ||
9 | PR = "r4" | ||
10 | |||
11 | SRC_URI = "git://git.berlios.de/jamvm;protocol=git \ | 9 | SRC_URI = "git://git.berlios.de/jamvm;protocol=git \ |
12 | file://jamvm-jni_h-noinst.patch \ | 10 | file://jamvm-jni_h-noinst.patch \ |
13 | file://libffi.patch \ | 11 | file://libffi.patch \ |
14 | file://jamvm-minmax-heap.patch \ | 12 | file://jamvm-minmax-heap.patch \ |
13 | file://annotations.patch \ | ||
14 | file://java \ | ||
15 | " | 15 | " |
16 | 16 | ||
17 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |