diff options
-rw-r--r-- | recipes-core/cacao/cacao-initial_0.98.bb | 2 | ||||
-rw-r--r-- | recipes-core/cacao/cacao_1.6.1.bb | 2 | ||||
-rw-r--r-- | recipes-core/classpath/classpath-0.99/freetype2.patch | 36 | ||||
-rw-r--r-- | recipes-core/classpath/classpath_0.99.bb | 1 | ||||
-rw-r--r-- | recipes-core/ecj/ecj-bootstrap-native.bb | 2 | ||||
-rw-r--r-- | recipes-core/jikes/jikes-initial.bb | 2 | ||||
-rw-r--r-- | recipes-core/jlex/jlex_1.2.6.bb | 2 | ||||
-rw-r--r-- | recipes-core/openjdk/openjdk-6-common.inc | 6 | ||||
-rw-r--r-- | recipes-core/openjdk/openjdk-7-common.inc | 6 |
9 files changed, 48 insertions, 11 deletions
diff --git a/recipes-core/cacao/cacao-initial_0.98.bb b/recipes-core/cacao/cacao-initial_0.98.bb index b6bcd1c..ad9436b 100644 --- a/recipes-core/cacao/cacao-initial_0.98.bb +++ b/recipes-core/cacao/cacao-initial_0.98.bb | |||
@@ -6,7 +6,7 @@ SECTION = "interpreters" | |||
6 | 6 | ||
7 | PROVIDES = "virtual/java-initial" | 7 | PROVIDES = "virtual/java-initial" |
8 | 8 | ||
9 | inherit native autotools | 9 | inherit native autotools-brokensep |
10 | 10 | ||
11 | DEPENDS = "zlib-native libtool-native fastjar-native classpath-initial jikes-initial" | 11 | DEPENDS = "zlib-native libtool-native fastjar-native classpath-initial jikes-initial" |
12 | 12 | ||
diff --git a/recipes-core/cacao/cacao_1.6.1.bb b/recipes-core/cacao/cacao_1.6.1.bb index 4ad81db..eb86b49 100644 --- a/recipes-core/cacao/cacao_1.6.1.bb +++ b/recipes-core/cacao/cacao_1.6.1.bb | |||
@@ -15,7 +15,7 @@ SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao- | |||
15 | SRC_URI[md5sum] = "2c18478404afd1cffdd15ad1e9d85a57" | 15 | SRC_URI[md5sum] = "2c18478404afd1cffdd15ad1e9d85a57" |
16 | SRC_URI[sha256sum] = "eecc8bd1b528a028f43d9d1d0c06b97855bbf1d40e03826d911ebbc0b6971e12" | 16 | SRC_URI[sha256sum] = "eecc8bd1b528a028f43d9d1d0c06b97855bbf1d40e03826d911ebbc0b6971e12" |
17 | 17 | ||
18 | inherit java autotools update-alternatives pkgconfig | 18 | inherit java autotools-brokensep update-alternatives pkgconfig |
19 | 19 | ||
20 | EXTRA_OECONF_class-native = "\ | 20 | EXTRA_OECONF_class-native = "\ |
21 | --enable-debug \ | 21 | --enable-debug \ |
diff --git a/recipes-core/classpath/classpath-0.99/freetype2.patch b/recipes-core/classpath/classpath-0.99/freetype2.patch new file mode 100644 index 0000000..cf0c02e --- /dev/null +++ b/recipes-core/classpath/classpath-0.99/freetype2.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | Index: classpath-0.99/native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c | ||
2 | =================================================================== | ||
3 | --- classpath-0.99.orig/native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c 2014-02-10 12:01:26.826613065 +0100 | ||
4 | +++ classpath-0.99/native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c 2014-02-10 12:01:46.230613171 +0100 | ||
5 | @@ -42,8 +42,9 @@ | ||
6 | #include <pango/pango.h> | ||
7 | #include <pango/pangoft2.h> | ||
8 | #include <pango/pangofc-font.h> | ||
9 | -#include <freetype/ftglyph.h> | ||
10 | -#include <freetype/ftoutln.h> | ||
11 | +#include <ft2build.h> | ||
12 | +#include FT_GLYPH_H | ||
13 | +#include FT_OUTLINE_H | ||
14 | #include "jcl.h" | ||
15 | #include "gdkfont.h" | ||
16 | #include "gnu_java_awt_peer_gtk_FreetypeGlyphVector.h" | ||
17 | Index: classpath-0.99/native/jni/gtk-peer/gnu_java_awt_peer_gtk_GdkFontPeer.c | ||
18 | =================================================================== | ||
19 | --- classpath-0.99.orig/native/jni/gtk-peer/gnu_java_awt_peer_gtk_GdkFontPeer.c 2014-02-10 12:01:21.158613034 +0100 | ||
20 | +++ classpath-0.99/native/jni/gtk-peer/gnu_java_awt_peer_gtk_GdkFontPeer.c 2014-02-10 12:01:54.338613216 +0100 | ||
21 | @@ -39,10 +39,11 @@ | ||
22 | #include <pango/pango.h> | ||
23 | #include <pango/pangoft2.h> | ||
24 | #include <pango/pangofc-font.h> | ||
25 | -#include <freetype/ftglyph.h> | ||
26 | -#include <freetype/ftoutln.h> | ||
27 | -#include <freetype/fttypes.h> | ||
28 | -#include <freetype/tttables.h> | ||
29 | +#include <ft2build.h> | ||
30 | +#include FT_GLYPH_H | ||
31 | +#include FT_OUTLINE_H | ||
32 | +#include FT_TYPES_H | ||
33 | +#include FT_TRUETYPE_TABLES_H | ||
34 | #include "gdkfont.h" | ||
35 | #include "gtkpeer.h" | ||
36 | #include "gnu_java_awt_peer_gtk_GdkFontPeer.h" | ||
diff --git a/recipes-core/classpath/classpath_0.99.bb b/recipes-core/classpath/classpath_0.99.bb index 7839519..8b3a6e3 100644 --- a/recipes-core/classpath/classpath_0.99.bb +++ b/recipes-core/classpath/classpath_0.99.bb | |||
@@ -9,6 +9,7 @@ SRC_URI += " \ | |||
9 | file://miscompilation.patch \ | 9 | file://miscompilation.patch \ |
10 | file://toolwrapper-exithook.patch \ | 10 | file://toolwrapper-exithook.patch \ |
11 | file://use_libdir.patch \ | 11 | file://use_libdir.patch \ |
12 | file://freetype2.patch \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4" | 15 | SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4" |
diff --git a/recipes-core/ecj/ecj-bootstrap-native.bb b/recipes-core/ecj/ecj-bootstrap-native.bb index dded41b..c9be269 100644 --- a/recipes-core/ecj/ecj-bootstrap-native.bb +++ b/recipes-core/ecj/ecj-bootstrap-native.bb | |||
@@ -7,7 +7,7 @@ DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant" | |||
7 | HOMEPAGE = "http://www.eclipse.org/" | 7 | HOMEPAGE = "http://www.eclipse.org/" |
8 | SECTION = "devel" | 8 | SECTION = "devel" |
9 | LICENSE = "MIT" | 9 | LICENSE = "MIT" |
10 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \ | 10 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ |
11 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \ | 11 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \ |
12 | " | 12 | " |
13 | PR = "r1" | 13 | PR = "r1" |
diff --git a/recipes-core/jikes/jikes-initial.bb b/recipes-core/jikes/jikes-initial.bb index b07a5e3..4e6e870 100644 --- a/recipes-core/jikes/jikes-initial.bb +++ b/recipes-core/jikes/jikes-initial.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler" | 1 | SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler" |
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" | 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690" |
4 | DEPENDS = "jikes-native classpath-initial" | 4 | DEPENDS = "jikes-native classpath-initial" |
5 | 5 | ||
6 | S = "${WORKDIR}" | 6 | S = "${WORKDIR}" |
diff --git a/recipes-core/jlex/jlex_1.2.6.bb b/recipes-core/jlex/jlex_1.2.6.bb index 5282980..4dbe63e 100644 --- a/recipes-core/jlex/jlex_1.2.6.bb +++ b/recipes-core/jlex/jlex_1.2.6.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | DESCRIPTION = "Lexical analyzer generator for Java" | 1 | DESCRIPTION = "Lexical analyzer generator for Java" |
2 | AUTHOR = "Elliot Berk, A. Appel, C. Scott Ananian" | 2 | AUTHOR = "Elliot Berk, A. Appel, C. Scott Ananian" |
3 | LICENSE = "JLEX" | 3 | LICENSE = "JLEX" |
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \ | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ |
5 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \ | 5 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \ |
6 | " | 6 | " |
7 | 7 | ||
diff --git a/recipes-core/openjdk/openjdk-6-common.inc b/recipes-core/openjdk/openjdk-6-common.inc index f900362..5aa435d 100644 --- a/recipes-core/openjdk/openjdk-6-common.inc +++ b/recipes-core/openjdk/openjdk-6-common.inc | |||
@@ -36,8 +36,8 @@ DEPENDS = "giflib libpng jpeg cups \ | |||
36 | # No package should directly depend on this (it should require | 36 | # No package should directly depend on this (it should require |
37 | # java2-runtime instead). | 37 | # java2-runtime instead). |
38 | PRIVATE_LIBS = "\ | 38 | PRIVATE_LIBS = "\ |
39 | libunpack.so libverify.so libjava.so libzip.so libnpt.so \ | 39 | lib.so libunpack.so libverify.so libjava.so libzip.so libnpt.so \ |
40 | libjava_crw_demo.so libhprof.so libnet.so libnio.so \ | 40 | libjava_crw_demo.so libhprof.so libjavanet.so libnio.so \ |
41 | libmanagement.so libinstrument.so libjsound.so libjsoundalsa.so \ | 41 | libmanagement.so libinstrument.so libjsound.so libjsoundalsa.so \ |
42 | libj2pcsc.so libj2pkcs11.so libj2gss.so libmlib_image.so \ | 42 | libj2pcsc.so libj2pkcs11.so libj2gss.so libmlib_image.so \ |
43 | libawt.so libsplashscreen.so libfreetype.so.6 libfontmanager.so \ | 43 | libawt.so libsplashscreen.so libfreetype.so.6 libfontmanager.so \ |
@@ -234,7 +234,7 @@ do_compile() { | |||
234 | 234 | ||
235 | do_install() { | 235 | do_install() { |
236 | install -d ${D}${libdir_jvm} | 236 | install -d ${D}${libdir_jvm} |
237 | cp -R ${S}/build/${BUILD_DIR}/j2sdk-image ${D}${JDK_HOME} | 237 | cp -R ${WORKDIR}/build/${BUILD_DIR}/j2sdk-image ${D}${JDK_HOME} |
238 | 238 | ||
239 | chmod u+rw -R ${D}${JDK_HOME} | 239 | chmod u+rw -R ${D}${JDK_HOME} |
240 | 240 | ||
diff --git a/recipes-core/openjdk/openjdk-7-common.inc b/recipes-core/openjdk/openjdk-7-common.inc index 9ecc990..32fab16 100644 --- a/recipes-core/openjdk/openjdk-7-common.inc +++ b/recipes-core/openjdk/openjdk-7-common.inc | |||
@@ -39,8 +39,8 @@ DEPENDS = " \ | |||
39 | # No package should directly depend on this (it should require | 39 | # No package should directly depend on this (it should require |
40 | # java2-runtime instead). | 40 | # java2-runtime instead). |
41 | PRIVATE_LIBS = "\ | 41 | PRIVATE_LIBS = "\ |
42 | libunpack.so libverify.so libjava.so libzip.so libnpt.so \ | 42 | lib.so libunpack.so libverify.so libjava.so libzip.so libnpt.so \ |
43 | libjava_crw_demo.so libhprof.so libnet.so libnio.so \ | 43 | libjava_crw_demo.so libhprof.so libjavanet.so libnio.so \ |
44 | libmanagement.so libinstrument.so libjsound.so libjsoundalsa.so \ | 44 | libmanagement.so libinstrument.so libjsound.so libjsoundalsa.so \ |
45 | libj2pcsc.so libj2pkcs11.so libj2gss.so libmlib_image.so \ | 45 | libj2pcsc.so libj2pkcs11.so libj2gss.so libmlib_image.so \ |
46 | libawt.so libsplashscreen.so libfreetype.so.6 libfontmanager.so \ | 46 | libawt.so libsplashscreen.so libfreetype.so.6 libfontmanager.so \ |
@@ -172,7 +172,7 @@ do_compile() { | |||
172 | 172 | ||
173 | do_install() { | 173 | do_install() { |
174 | install -d ${D}${libdir_jvm} | 174 | install -d ${D}${libdir_jvm} |
175 | cp -R ${S}/build/${BUILD_DIR}/j2sdk-image ${D}${JDK_HOME} | 175 | cp -R ${WORKDIR}/build/${BUILD_DIR}/j2sdk-image ${D}${JDK_HOME} |
176 | 176 | ||
177 | chmod u+rw -R ${D}${JDK_HOME} | 177 | chmod u+rw -R ${D}${JDK_HOME} |
178 | 178 | ||