diff options
Diffstat (limited to 'recipes-core')
-rw-r--r-- | recipes-core/classpath/classpath-initial-native_0.93.bb | 54 | ||||
-rw-r--r-- | recipes-core/classpath/classpath-native.inc | 25 | ||||
-rw-r--r-- | recipes-core/classpath/classpath-native_0.99.bb | 31 |
3 files changed, 51 insertions, 59 deletions
diff --git a/recipes-core/classpath/classpath-initial-native_0.93.bb b/recipes-core/classpath/classpath-initial-native_0.93.bb index 0cfa693..51229ec 100644 --- a/recipes-core/classpath/classpath-initial-native_0.93.bb +++ b/recipes-core/classpath/classpath-initial-native_0.93.bb | |||
@@ -4,7 +4,6 @@ | |||
4 | require classpath-native.inc | 4 | require classpath-native.inc |
5 | 5 | ||
6 | DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native." | 6 | DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native." |
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510" | ||
8 | DEPENDS += "jikes-native" | 7 | DEPENDS += "jikes-native" |
9 | 8 | ||
10 | PR = "${INC_PR}.2" | 9 | PR = "${INC_PR}.2" |
@@ -13,38 +12,35 @@ SRC_URI += " \ | |||
13 | file://autotools.patch \ | 12 | file://autotools.patch \ |
14 | file://miscompilation.patch \ | 13 | file://miscompilation.patch \ |
15 | " | 14 | " |
15 | SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d" | ||
16 | SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945" | ||
16 | 17 | ||
17 | EXTRA_OECONF = " \ | 18 | EXTRA_OECONF += "\ |
18 | --with-jikes=jikes \ | 19 | --with-jikes=jikes \ |
19 | --with-fastjar=fastjar \ | 20 | --with-fastjar=fastjar \ |
20 | --with-glibj \ | 21 | --disable-local-sockets \ |
21 | --disable-Werror \ | 22 | --with-glibj-dir=${STAGING_DATADIR_NATIVE}/classpath-initial \ |
22 | --disable-local-sockets \ | 23 | --with-native-libdir=${STAGING_LIBDIR_NATIVE}/classpath-initial \ |
23 | --disable-alsa \ | 24 | --includedir=${STAGING_INCDIR_NATIVE}/classpath-initial \ |
24 | --disable-gconf-peer \ | 25 | --with-vm=java \ |
25 | --disable-gtk-peer \ | 26 | " |
26 | --disable-plugin \ | ||
27 | --disable-dssi \ | ||
28 | --disable-examples \ | ||
29 | --with-glibj-dir=${STAGING_DATADIR_NATIVE}/classpath-initial \ | ||
30 | --with-native-libdir=${STAGING_LIBDIR_NATIVE}/classpath-initial \ | ||
31 | --includedir=${STAGING_INCDIR_NATIVE}/classpath-initial \ | ||
32 | --with-vm=java \ | ||
33 | " | ||
34 | 27 | ||
35 | # Ensure tools.zip is not installed at same path as classpath-native | 28 | # Ensure tools.zip is not installed at same path as classpath-native |
36 | EXTRA_OEMAKE += "pkgdatadir=${STAGING_DATADIR_NATIVE}/classpath-initial" | 29 | EXTRA_OEMAKE += "pkgdatadir=${STAGING_DATADIR_NATIVE}/classpath-initial" |
37 | 30 | ||
38 | # remove files clashing with classpath-native in sysroot | ||
39 | do_install_append() { | 31 | do_install_append() { |
40 | 32 | # remove files clashing with classpath-native in sysroot | |
41 | for i in gappletviewer gjarsigner gkeytool gjar gnative2ascii gserialver grmiregistry gtnameserv gorbd grmid | 33 | rm \ |
42 | do | 34 | ${D}${bindir}/gappletviewer \ |
43 | rm ${D}${bindir}/${i} | 35 | ${D}${bindir}/gjarsigner \ |
44 | done | 36 | ${D}${bindir}/gkeytool \ |
45 | rm ${D}${libdir}/logging.properties | 37 | ${D}${bindir}/gjar \ |
46 | rm ${D}${libdir}/security/classpath.security | 38 | ${D}${bindir}/gnative2ascii \ |
39 | ${D}${bindir}/gserialver \ | ||
40 | ${D}${bindir}/grmiregistry \ | ||
41 | ${D}${bindir}/gtnameserv \ | ||
42 | ${D}${bindir}/gorbd \ | ||
43 | ${D}${bindir}/grmid \ | ||
44 | ${D}${libdir}/logging.properties \ | ||
45 | ${D}${libdir}/security/classpath.security | ||
47 | } | 46 | } |
48 | SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d" | ||
49 | SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945" | ||
50 | |||
diff --git a/recipes-core/classpath/classpath-native.inc b/recipes-core/classpath/classpath-native.inc index 6a56337..b1de458 100644 --- a/recipes-core/classpath/classpath-native.inc +++ b/recipes-core/classpath/classpath-native.inc | |||
@@ -1,6 +1,7 @@ | |||
1 | SUMMARY = "GNU Classpath standard Java libraries - For native Java-dependent programs" | 1 | SUMMARY = "GNU Classpath standard Java libraries - For native Java-dependent programs" |
2 | HOMEPAGE = "http://www.gnu.org/software/classpath/" | 2 | HOMEPAGE = "http://www.gnu.org/software/classpath/" |
3 | LICENSE = "GPL-2.0 & SAX-PD" | 3 | LICENSE = "GPL-2.0 & SAX-PD" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510" | ||
4 | 5 | ||
5 | DEPENDS = "fastjar-native zip-native" | 6 | DEPENDS = "fastjar-native zip-native" |
6 | 7 | ||
@@ -14,17 +15,13 @@ export JAVA="${STAGING_BINDIR_NATIVE}/java-initial" | |||
14 | export JAVAC="${STAGING_BINDIR_NATIVE}/ecj-initial" | 15 | export JAVAC="${STAGING_BINDIR_NATIVE}/ecj-initial" |
15 | export JAVACFLAGS="-nowarn" | 16 | export JAVACFLAGS="-nowarn" |
16 | 17 | ||
17 | EXTRA_OECONF = " \ | 18 | EXTRA_OECONF = "\ |
18 | --with-glibj \ | 19 | --with-glibj \ |
19 | --enable-local-sockets \ | 20 | --disable-Werror \ |
20 | --disable-Werror \ | 21 | --disable-alsa \ |
21 | --disable-alsa \ | 22 | --disable-gconf-peer \ |
22 | --disable-gconf-peer \ | 23 | --disable-gtk-peer \ |
23 | --disable-gtk-peer \ | 24 | --disable-plugin \ |
24 | --disable-plugin \ | 25 | --disable-dssi \ |
25 | --disable-dssi \ | 26 | --disable-examples \ |
26 | --disable-gjdoc \ | 27 | " |
27 | --disable-examples \ | ||
28 | --enable-tools \ | ||
29 | --includedir=${STAGING_INCDIR}/classpath \ | ||
30 | " | ||
diff --git a/recipes-core/classpath/classpath-native_0.99.bb b/recipes-core/classpath/classpath-native_0.99.bb index a97cae0..a1e1e0f 100644 --- a/recipes-core/classpath/classpath-native_0.99.bb +++ b/recipes-core/classpath/classpath-native_0.99.bb | |||
@@ -1,6 +1,5 @@ | |||
1 | require classpath-native.inc | 1 | require classpath-native.inc |
2 | 2 | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510" | ||
4 | DEPENDS += "classpath-initial-native ecj-initial-native virtual/java-initial-native" | 3 | DEPENDS += "classpath-initial-native ecj-initial-native virtual/java-initial-native" |
5 | 4 | ||
6 | PR = "${INC_PR}.0" | 5 | PR = "${INC_PR}.0" |
@@ -12,21 +11,21 @@ SRC_URI += " \ | |||
12 | file://miscompilation.patch \ | 11 | file://miscompilation.patch \ |
13 | file://toolwrapper-exithook.patch \ | 12 | file://toolwrapper-exithook.patch \ |
14 | " | 13 | " |
15 | |||
16 | # tools using java-initial rather than java sed it out | ||
17 | do_compile_append () { | ||
18 | |||
19 | COMMANDS="gappletviewer gjarsigner gkeytool \ | ||
20 | gjar gnative2ascii gserialver grmiregistry \ | ||
21 | gtnameserv gorbd grmid grmic gjavah \ | ||
22 | " | ||
23 | |||
24 | for i in ${COMMANDS}; | ||
25 | do | ||
26 | sed -i -e "s/java-initial/java/g" tools/${i} | ||
27 | done | ||
28 | } | ||
29 | |||
30 | SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4" | 14 | SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4" |
31 | SRC_URI[sha256sum] = "f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8" | 15 | SRC_URI[sha256sum] = "f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8" |
32 | 16 | ||
17 | EXTRA_OECONF += "\ | ||
18 | --enable-local-sockets \ | ||
19 | --disable-gjdoc \ | ||
20 | --enable-tools \ | ||
21 | --includedir=${STAGING_INCDIR}/classpath \ | ||
22 | " | ||
23 | |||
24 | do_compile_append () { | ||
25 | # tools using java-initial rather than java sed it out | ||
26 | cd tools | ||
27 | sed -e "s/java-initial/java/g" \ | ||
28 | -i gappletviewer gjarsigner gkeytool \ | ||
29 | gjar gnative2ascii gserialver grmiregistry \ | ||
30 | gtnameserv gorbd grmid grmic gjavah | ||
31 | } | ||