diff options
-rw-r--r-- | recipes-devtools/mingw-w64/files/0001-crt-Fix-a-typo-in-the-ucrt-__imp_vfscanf-assignment.patch | 30 | ||||
-rw-r--r-- | recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_9.0.0.bb | 2 |
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-devtools/mingw-w64/files/0001-crt-Fix-a-typo-in-the-ucrt-__imp_vfscanf-assignment.patch b/recipes-devtools/mingw-w64/files/0001-crt-Fix-a-typo-in-the-ucrt-__imp_vfscanf-assignment.patch new file mode 100644 index 0000000..bc41482 --- /dev/null +++ b/recipes-devtools/mingw-w64/files/0001-crt-Fix-a-typo-in-the-ucrt-__imp_vfscanf-assignment.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From b0dcc496228373417e4f6134beb2f13ca3ed807e Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Martin=20Storsj=C3=B6?= <martin@martin.st> | ||
3 | Date: Thu, 5 Aug 2021 11:08:39 +0300 | ||
4 | Subject: [PATCH] crt: Fix a typo in the ucrt __imp_vfscanf assignment | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | The wrong function was assigned; this was a bug present since | ||
10 | 0dd9563a3ad71ad75cab1699ba5cfef2dd0bf9d8 (April 2021). | ||
11 | |||
12 | Upstream-Status: Backport [https://sourceforge.net/p/mingw-w64/mingw-w64/ci/b0dcc496228373417e4f6134beb2f13ca3ed807e] | ||
13 | Signed-off-by: Martin Storsjö <martin@martin.st> | ||
14 | --- | ||
15 | mingw-w64-crt/stdio/ucrt_vfscanf.c | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/mingw-w64-crt/stdio/ucrt_vfscanf.c b/mingw-w64-crt/stdio/ucrt_vfscanf.c | ||
19 | index fe44cdf71..8d1a76a8b 100644 | ||
20 | --- a/mingw-w64-crt/stdio/ucrt_vfscanf.c | ||
21 | +++ b/mingw-w64-crt/stdio/ucrt_vfscanf.c | ||
22 | @@ -11,4 +11,4 @@ | ||
23 | int __cdecl vfscanf (FILE *__stream, const char *__format, __builtin_va_list __local_argv) { | ||
24 | return __stdio_common_vfscanf(0, __stream, __format, NULL, __local_argv); | ||
25 | } | ||
26 | -int __cdecl (*__MINGW_IMP_SYMBOL(vfscanf))(FILE *, const char *, __builtin_va_list) = vsscanf; | ||
27 | +int __cdecl (*__MINGW_IMP_SYMBOL(vfscanf))(FILE *, const char *, __builtin_va_list) = vfscanf; | ||
28 | -- | ||
29 | 2.43.0 | ||
30 | |||
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_9.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_9.0.0.bb index e2ca6a5..1aa470e 100644 --- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_9.0.0.bb +++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_9.0.0.bb | |||
@@ -2,6 +2,8 @@ DESCRIPTION = "Runtime libraries from MinGW-w64 project" | |||
2 | 2 | ||
3 | require mingw-w64.inc | 3 | require mingw-w64.inc |
4 | 4 | ||
5 | SRC_URI += "file://0001-crt-Fix-a-typo-in-the-ucrt-__imp_vfscanf-assignment.patch;striplevel=2" | ||
6 | |||
5 | S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt" | 7 | S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt" |
6 | B = "${WORKDIR}/build-${TARGET_SYS}" | 8 | B = "${WORKDIR}/build-${TARGET_SYS}" |
7 | 9 | ||