summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-gnome/recipes-gnome/gdm/gdm/a3e0aca75e16aeafc171751028406b54f5ed8397.patch56
-rw-r--r--meta-gnome/recipes-gnome/gdm/gdm_48.0.bb1
-rw-r--r--meta-gnome/recipes-gnome/mutter/mutter_48.0.bb2
-rw-r--r--meta-oe/recipes-benchmark/iperf3/iperf3_3.18.bb2
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb1
-rw-r--r--meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb1
-rw-r--r--meta-oe/recipes-extended/etcd/etcd_3.5.7.bb1
-rw-r--r--meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.10.bb40
-rw-r--r--meta-python/recipes-devtools/python/python3-setproctitle_1.3.6.bb (renamed from meta-python/recipes-devtools/python/python3-setproctitle_1.3.5.bb)2
9 files changed, 63 insertions, 43 deletions
diff --git a/meta-gnome/recipes-gnome/gdm/gdm/a3e0aca75e16aeafc171751028406b54f5ed8397.patch b/meta-gnome/recipes-gnome/gdm/gdm/a3e0aca75e16aeafc171751028406b54f5ed8397.patch
new file mode 100644
index 0000000000..8363a7f41d
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gdm/gdm/a3e0aca75e16aeafc171751028406b54f5ed8397.patch
@@ -0,0 +1,56 @@
1From 2fbc2ac50b9f143eb594e5f77a8051222ffbd2c9 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
3Date: Mon, 27 Jan 2025 14:01:23 +0100
4Subject: [PATCH] gdm-settings-utils: rename variable to fix build with gcc 15
5
6In GNU23 C, bool is a keyword. Rename the variable to avoid syntax error.
7---
8 common/gdm-settings-utils.c | 8 ++++----
9 common/gdm-settings-utils.h | 2 +-
10 2 files changed, 5 insertions(+), 5 deletions(-)
11
12 Signed-off-by: Markus Volk <f_l_k@t-online.de>
13
14Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/gdm/-/commit/a3e0aca75e16aeafc171751028406b54f5ed8397.patch]
15
16diff --git a/common/gdm-settings-utils.c b/common/gdm-settings-utils.c
17index 636be3a9e..da4c7aefb 100644
18--- a/common/gdm-settings-utils.c
19+++ b/common/gdm-settings-utils.c
20@@ -287,16 +287,16 @@ gdm_settings_parse_boolean_as_value (gboolean boolval)
21 /* adapted from GKeyFile */
22 gboolean
23 gdm_settings_parse_value_as_boolean (const char *value,
24- gboolean *bool)
25+ gboolean *boolval)
26 {
27 g_return_val_if_fail (value != NULL, FALSE);
28- g_return_val_if_fail (bool != NULL, FALSE);
29+ g_return_val_if_fail (boolval != NULL, FALSE);
30
31 if (g_ascii_strcasecmp (value, "true") == 0 || strcmp (value, "1") == 0) {
32- *bool = TRUE;
33+ *boolval = TRUE;
34 return TRUE;
35 } else if (g_ascii_strcasecmp (value, "false") == 0 || strcmp (value, "0") == 0) {
36- *bool = FALSE;
37+ *boolval = FALSE;
38 return TRUE;
39 } else {
40 return FALSE;
41diff --git a/common/gdm-settings-utils.h b/common/gdm-settings-utils.h
42index 4f2362ce7..734d625c7 100644
43--- a/common/gdm-settings-utils.h
44+++ b/common/gdm-settings-utils.h
45@@ -44,7 +44,7 @@ gboolean gdm_settings_parse_schemas (const char *fil
46 GSList **list);
47
48 gboolean gdm_settings_parse_value_as_boolean (const char *value,
49- gboolean *bool);
50+ gboolean *boolval);
51 gboolean gdm_settings_parse_value_as_integer (const char *value,
52 int *intval);
53 gboolean gdm_settings_parse_value_as_double (const char *value,
54--
55GitLab
56
diff --git a/meta-gnome/recipes-gnome/gdm/gdm_48.0.bb b/meta-gnome/recipes-gnome/gdm/gdm_48.0.bb
index 1c8076e6c7..92ddc143f6 100644
--- a/meta-gnome/recipes-gnome/gdm/gdm_48.0.bb
+++ b/meta-gnome/recipes-gnome/gdm/gdm_48.0.bb
@@ -21,6 +21,7 @@ GIR_MESON_OPTION = ""
21 21
22inherit gnomebase gsettings pkgconfig gobject-introspection gettext systemd useradd itstool gnome-help features_check 22inherit gnomebase gsettings pkgconfig gobject-introspection gettext systemd useradd itstool gnome-help features_check
23 23
24SRC_URI += "file://a3e0aca75e16aeafc171751028406b54f5ed8397.patch"
24SRC_URI[archive.sha256sum] = "1bc06daff093ec7b5e37ecb4f92e5da3474a1b1ba076edb9151ee967d1c30adf" 25SRC_URI[archive.sha256sum] = "1bc06daff093ec7b5e37ecb4f92e5da3474a1b1ba076edb9151ee967d1c30adf"
25 26
26PACKAGECONFIG ??= "" 27PACKAGECONFIG ??= ""
diff --git a/meta-gnome/recipes-gnome/mutter/mutter_48.0.bb b/meta-gnome/recipes-gnome/mutter/mutter_48.0.bb
index 777fef79b0..6f799ad57a 100644
--- a/meta-gnome/recipes-gnome/mutter/mutter_48.0.bb
+++ b/meta-gnome/recipes-gnome/mutter/mutter_48.0.bb
@@ -3,7 +3,6 @@ LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4 4
5DEPENDS = " \ 5DEPENDS = " \
6 xserver-xorg-cvt-native \
7 wayland-native \ 6 wayland-native \
8 virtual/libx11 \ 7 virtual/libx11 \
9 colord \ 8 colord \
@@ -16,6 +15,7 @@ DEPENDS = " \
16 json-glib \ 15 json-glib \
17 libdisplay-info \ 16 libdisplay-info \
18 libei \ 17 libei \
18 libxcvt-native \
19 libxtst \ 19 libxtst \
20 libxkbfile \ 20 libxkbfile \
21 python3-argcomplete-native \ 21 python3-argcomplete-native \
diff --git a/meta-oe/recipes-benchmark/iperf3/iperf3_3.18.bb b/meta-oe/recipes-benchmark/iperf3/iperf3_3.18.bb
index 77b441e506..4a71e83b73 100644
--- a/meta-oe/recipes-benchmark/iperf3/iperf3_3.18.bb
+++ b/meta-oe/recipes-benchmark/iperf3/iperf3_3.18.bb
@@ -30,3 +30,5 @@ PACKAGECONFIG[lksctp] = "ac_cv_header_netinet_sctp_h=yes,ac_cv_header_netinet_sc
30PACKAGECONFIG[openssl] = "--with-openssl=${RECIPE_SYSROOT}${prefix},--without-openssl,openssl" 30PACKAGECONFIG[openssl] = "--with-openssl=${RECIPE_SYSROOT}${prefix},--without-openssl,openssl"
31 31
32CFLAGS += "-D_GNU_SOURCE" 32CFLAGS += "-D_GNU_SOURCE"
33
34BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index 1d6c45c518..2055a0ff91 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -201,7 +201,6 @@ RDEPENDS:packagegroup-meta-oe-crypto = "\
201RDEPENDS:packagegroup-meta-oe-crypto:remove:riscv32 = "botan" 201RDEPENDS:packagegroup-meta-oe-crypto:remove:riscv32 = "botan"
202 202
203RDEPENDS:packagegroup-meta-oe-dbs = "\ 203RDEPENDS:packagegroup-meta-oe-dbs = "\
204 influxdb \
205 leveldb \ 204 leveldb \
206 libdbi \ 205 libdbi \
207 lmdb \ 206 lmdb \
diff --git a/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb b/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
index cc8161cc3d..580b92b3b3 100644
--- a/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
+++ b/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
@@ -77,3 +77,4 @@ INITSCRIPT_PARAMS = "defaults"
77SYSTEMD_SERVICE:${PN} = "influxdb.service" 77SYSTEMD_SERVICE:${PN} = "influxdb.service"
78 78
79CVE_STATUS[CVE-2019-10329] = "cpe-incorrect: Version does not match and only the Jenkins plugin is affected." 79CVE_STATUS[CVE-2019-10329] = "cpe-incorrect: Version does not match and only the Jenkins plugin is affected."
80SKIP_RECIPE[influxdb] ?= "QA Issue: task do_compile has network enabled"
diff --git a/meta-oe/recipes-extended/etcd/etcd_3.5.7.bb b/meta-oe/recipes-extended/etcd/etcd_3.5.7.bb
index d665357702..dd30543a41 100644
--- a/meta-oe/recipes-extended/etcd/etcd_3.5.7.bb
+++ b/meta-oe/recipes-extended/etcd/etcd_3.5.7.bb
@@ -70,3 +70,4 @@ do_install:append() {
70 70
71FILES:${PN}:append = " ${sysconfdir}/etcd.d/etcd-existing.conf" 71FILES:${PN}:append = " ${sysconfdir}/etcd.d/etcd-existing.conf"
72 72
73SKIP_RECIPE[etcd] ?= "QA Issue: task do_compile has network enabled"
diff --git a/meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.10.bb b/meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.10.bb
deleted file mode 100644
index e672701ae0..0000000000
--- a/meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.10.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "X.Org X cvt"
2HOMEPAGE = "https://linux.die.net/man/1/cvt"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880"
5
6DEPENDS += "pixman-native xorgproto-native libxrandr-native"
7
8XORG_PN = "xorg-server"
9
10SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2"
11SRC_URI[sha256sum] = "977420c082450dc808de301ef56af4856d653eea71519a973c3490a780cb7c99"
12
13S = "${WORKDIR}/${XORG_PN}-${PV}"
14B = "${WORKDIR}/build"
15
16inherit pkgconfig native
17
18do_configure[noexec] = "1"
19
20do_compile() {
21 cd ${S}
22 for header in `find -name '*.h'`; do
23 path=`dirname $header`
24 if ! echo "$incpaths" | grep -q "$path" ; then
25 incpaths="$incpaths -I$path"
26 fi
27 done
28 CFLAGS="${CFLAGS} -DXORG_VERSION_CURRENT=1 $incpaths `pkg-config --cflags pixman-1`"
29 LDFLAGS="${LDFLAGS} -lm `pkg-config --libs pixman-1`"
30 ${CC} $CFLAGS -o ${B}/cvt \
31 ${S}/hw/xfree86/utils/cvt/cvt.c \
32 ${S}/hw/xfree86/modes/xf86cvt.c \
33 ${S}/os/xprintf.c \
34 $LDFLAGS
35}
36
37do_install() {
38 install -d ${D}${bindir}
39 install -m 755 ${B}/cvt ${D}${bindir}
40}
diff --git a/meta-python/recipes-devtools/python/python3-setproctitle_1.3.5.bb b/meta-python/recipes-devtools/python/python3-setproctitle_1.3.6.bb
index 6be65469af..e4a392726b 100644
--- a/meta-python/recipes-devtools/python/python3-setproctitle_1.3.5.bb
+++ b/meta-python/recipes-devtools/python/python3-setproctitle_1.3.6.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=86d2d41b5f4f023f43466f8cb7adebaa"
9 9
10inherit pypi setuptools3 ptest 10inherit pypi setuptools3 ptest
11 11
12SRC_URI[sha256sum] = "1e6eaeaf8a734d428a95d8c104643b39af7d247d604f40a7bebcf3960a853c5e" 12SRC_URI[sha256sum] = "c9f32b96c700bb384f33f7cf07954bb609d35dd82752cef57fb2ee0968409169"
13 13
14SRC_URI += " \ 14SRC_URI += " \
15 file://run-ptest \ 15 file://run-ptest \