diff options
-rwxr-xr-x | meta-oe/conf/include/non-repro-meta-oe.inc | 3 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/libglvnd/libglvnd_1.7.0.bb | 4 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash.inc | 1 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash/0001-Use-CC-env-var-to-get-compiler-version.patch | 48 | ||||
-rw-r--r-- | meta-oe/recipes-support/libserialmodule/libserialmodule_1.0.7.bb (renamed from meta-oe/recipes-support/libserialmodule/libserialmodule_1.0.6.bb) | 2 |
5 files changed, 52 insertions, 6 deletions
diff --git a/meta-oe/conf/include/non-repro-meta-oe.inc b/meta-oe/conf/include/non-repro-meta-oe.inc index 894d7f330a..ae4fb1d194 100755 --- a/meta-oe/conf/include/non-repro-meta-oe.inc +++ b/meta-oe/conf/include/non-repro-meta-oe.inc | |||
@@ -7,9 +7,6 @@ KNOWN_NON_REPRO_META_OE = " \ | |||
7 | asio-ptest \ | 7 | asio-ptest \ |
8 | asio-src \ | 8 | asio-src \ |
9 | cpuid-doc \ | 9 | cpuid-doc \ |
10 | crash \ | ||
11 | crash-dbg \ | ||
12 | crash-src \ | ||
13 | dhrystone \ | 10 | dhrystone \ |
14 | dhrystone-dbg \ | 11 | dhrystone-dbg \ |
15 | dhrystone-dev \ | 12 | dhrystone-dev \ |
diff --git a/meta-oe/recipes-graphics/libglvnd/libglvnd_1.7.0.bb b/meta-oe/recipes-graphics/libglvnd/libglvnd_1.7.0.bb index 8f80358963..a737a735b7 100644 --- a/meta-oe/recipes-graphics/libglvnd/libglvnd_1.7.0.bb +++ b/meta-oe/recipes-graphics/libglvnd/libglvnd_1.7.0.bb | |||
@@ -22,8 +22,8 @@ PACKAGECONFIG ?= "\ | |||
22 | " | 22 | " |
23 | 23 | ||
24 | PACKAGECONFIG[x11] = "-Dx11=enabled,-Dx11=disabled,libx11 libxext xorgproto" | 24 | PACKAGECONFIG[x11] = "-Dx11=enabled,-Dx11=disabled,libx11 libxext xorgproto" |
25 | PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,libx11 libxext xorgproto" | 25 | PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,libx11 libxext xorgproto,,libglx-icd" |
26 | PACKAGECONFIG[egl] = "-Degl=true,-Degl=false," | 26 | PACKAGECONFIG[egl] = "-Degl=true,-Degl=false,,libegl-icd" |
27 | PACKAGECONFIG[gles1] = "-Dgles1=true,-Dgles1=false," | 27 | PACKAGECONFIG[gles1] = "-Dgles1=true,-Dgles1=false," |
28 | PACKAGECONFIG[gles2] = "-Dgles2=true,-Dgles2=false," | 28 | PACKAGECONFIG[gles2] = "-Dgles2=true,-Dgles2=false," |
29 | 29 | ||
diff --git a/meta-oe/recipes-kernel/crash/crash.inc b/meta-oe/recipes-kernel/crash/crash.inc index aef77be1a0..45fc9cd1fd 100644 --- a/meta-oe/recipes-kernel/crash/crash.inc +++ b/meta-oe/recipes-kernel/crash/crash.inc | |||
@@ -27,6 +27,7 @@ SRC_URI = "git://github.com/crash-utility/${BPN}.git;branch=master;protocol=http | |||
27 | file://0003-Fix-build-failure-in-readline-lib.patch \ | 27 | file://0003-Fix-build-failure-in-readline-lib.patch \ |
28 | file://0004-tools.c-do-not-use-keywords-nullptr-as-a-variable-in.patch \ | 28 | file://0004-tools.c-do-not-use-keywords-nullptr-as-a-variable-in.patch \ |
29 | file://0005-Fix-build-failure-on-32bit-machine-i686.patch \ | 29 | file://0005-Fix-build-failure-on-32bit-machine-i686.patch \ |
30 | file://0001-Use-CC-env-var-to-get-compiler-version.patch \ | ||
30 | " | 31 | " |
31 | SRCREV = "f13853cef53f5c5463a51021edbc81977e2b1405" | 32 | SRCREV = "f13853cef53f5c5463a51021edbc81977e2b1405" |
32 | 33 | ||
diff --git a/meta-oe/recipes-kernel/crash/crash/0001-Use-CC-env-var-to-get-compiler-version.patch b/meta-oe/recipes-kernel/crash/crash/0001-Use-CC-env-var-to-get-compiler-version.patch new file mode 100644 index 0000000000..d51008886e --- /dev/null +++ b/meta-oe/recipes-kernel/crash/crash/0001-Use-CC-env-var-to-get-compiler-version.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | From 31b789d1b21ed26315d08798d6044450e3545ddf Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?K=C3=A9l=C3=A9fa=20San=C3=A9?= <kelefa.sane@smile.fr> | ||
3 | Date: Fri, 16 May 2025 16:18:28 +0200 | ||
4 | Subject: [PATCH] Use CC env var to get compiler version | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | The source file build_data.c generated at compilation time define a | ||
10 | variable compiler_version which is obtained by calling "gcc --version" | ||
11 | cmd. This call retrieve the native gcc compiler install on host build | ||
12 | machine but not necessarily the compiler use to build the project (ex: | ||
13 | cross compilation). | ||
14 | |||
15 | The CC env variable commonly used in Makefile project define the | ||
16 | compiler to use at build, so this is the appropriate way to retrieve the | ||
17 | compiler version, when the CC env var is define. | ||
18 | |||
19 | Upstream-Status: Submitted [https://lists.crash-utility.osci.io/archives/list/devel@lists.crash-utility.osci.io/thread/MIPWYZGF3EIC47FVNNYK77FI4ZJ3FHON/] | ||
20 | |||
21 | Signed-off-by: Kéléfa Sané <kelefa.sane@smile.fr> | ||
22 | --- | ||
23 | configure.c | 12 +++++++++++- | ||
24 | 1 file changed, 11 insertions(+), 1 deletion(-) | ||
25 | |||
26 | diff --git a/configure.c b/configure.c | ||
27 | index 4668c9a..a20e174 100644 | ||
28 | --- a/configure.c | ||
29 | +++ b/configure.c | ||
30 | @@ -1362,7 +1362,17 @@ make_build_data(char *target) | ||
31 | |||
32 | fp1 = popen("date", "r"); | ||
33 | fp2 = popen("id", "r"); | ||
34 | - fp3 = popen("gcc --version", "r"); | ||
35 | + | ||
36 | + const char *cc_env = getenv("CC"); | ||
37 | + if(NULL == cc_env) { | ||
38 | + fp3 = popen("gcc --version", "r"); | ||
39 | + } | ||
40 | + else { | ||
41 | + char compiler_version_cmd[512]; | ||
42 | + | ||
43 | + snprintf(compiler_version_cmd, sizeof(compiler_version_cmd)-1, "%s --version", cc_env); | ||
44 | + fp3 = popen(compiler_version_cmd, "r"); | ||
45 | + } | ||
46 | |||
47 | if ((fp4 = fopen("build_data.c", "w")) == NULL) { | ||
48 | perror("build_data.c"); | ||
diff --git a/meta-oe/recipes-support/libserialmodule/libserialmodule_1.0.6.bb b/meta-oe/recipes-support/libserialmodule/libserialmodule_1.0.7.bb index 558547c1ed..ac5a3eaf09 100644 --- a/meta-oe/recipes-support/libserialmodule/libserialmodule_1.0.6.bb +++ b/meta-oe/recipes-support/libserialmodule/libserialmodule_1.0.7.bb | |||
@@ -6,7 +6,7 @@ LICENSE = "MIT" | |||
6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=22cdd382a6275cb4c2e75c517952ac7c" | 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=22cdd382a6275cb4c2e75c517952ac7c" |
7 | DEPENDS = "libsimplelog" | 7 | DEPENDS = "libsimplelog" |
8 | SRC_URI = "git://git@github.com/thuanalg/libserialmodule.git;branch=main;protocol=https;tag=v${PV}" | 8 | SRC_URI = "git://git@github.com/thuanalg/libserialmodule.git;branch=main;protocol=https;tag=v${PV}" |
9 | SRCREV = "975a95d38ba6bd4ae214567ed2bacd4b3e9f0268" | 9 | SRCREV = "b5a5a436900d0bd69f990ca062de916c65f7e2e0" |
10 | S = "${WORKDIR}/git" | 10 | S = "${WORKDIR}/git" |
11 | inherit cmake | 11 | inherit cmake |
12 | EXTRA_OECMAKE = "-DUNIX_LINUX=1 -DMETA_OPENEMBEDDED=1" | 12 | EXTRA_OECMAKE = "-DUNIX_LINUX=1 -DMETA_OPENEMBEDDED=1" |