diff options
-rw-r--r-- | meta-oe/recipes-dbs/lmdb/files/0001-make-set-soname-on-liblmdb.patch | 22 | ||||
-rw-r--r-- | meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb | 3 |
2 files changed, 23 insertions, 2 deletions
diff --git a/meta-oe/recipes-dbs/lmdb/files/0001-make-set-soname-on-liblmdb.patch b/meta-oe/recipes-dbs/lmdb/files/0001-make-set-soname-on-liblmdb.patch new file mode 100644 index 0000000000..312809d1d2 --- /dev/null +++ b/meta-oe/recipes-dbs/lmdb/files/0001-make-set-soname-on-liblmdb.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | From b4d418bf3f78748d84e3cfb110833443eef34284 Mon Sep 17 00:00:00 2001 | ||
2 | From: Justin Bronder <jsbronder@cold-front.org> | ||
3 | Date: Thu, 25 Aug 2022 17:22:20 -0400 | ||
4 | Subject: [PATCH] make: set soname on liblmdb | ||
5 | |||
6 | --- | ||
7 | libraries/liblmdb/Makefile | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/libraries/liblmdb/Makefile b/libraries/liblmdb/Makefile | ||
11 | index 1ec74e6..ea08cd6 100644 | ||
12 | --- a/libraries/liblmdb/Makefile | ||
13 | +++ b/libraries/liblmdb/Makefile | ||
14 | @@ -66,7 +66,7 @@ liblmdb.a: mdb.o midl.o | ||
15 | |||
16 | liblmdb$(SOEXT): mdb.lo midl.lo | ||
17 | # $(CC) $(LDFLAGS) -pthread -shared -Wl,-Bsymbolic -o $@ mdb.o midl.o $(SOLIBS) | ||
18 | - $(CC) $(LDFLAGS) -pthread -shared -o $@ mdb.lo midl.lo $(SOLIBS) | ||
19 | + $(CC) $(LDFLAGS) -pthread -shared -Wl,-soname,$@ -o $@ mdb.lo midl.lo $(SOLIBS) | ||
20 | |||
21 | mdb_stat: mdb_stat.o liblmdb.a | ||
22 | mdb_copy: mdb_copy.o liblmdb.a | ||
diff --git a/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb b/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb index 0590ce008c..a76d388d70 100644 --- a/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb +++ b/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb | |||
@@ -11,6 +11,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=153d07ef052c4a37a8fac23bc6031972" | |||
11 | SRC_URI = "git://github.com/LMDB/lmdb.git;nobranch=1;protocol=https \ | 11 | SRC_URI = "git://github.com/LMDB/lmdb.git;nobranch=1;protocol=https \ |
12 | file://run-ptest \ | 12 | file://run-ptest \ |
13 | file://0001-Makefile-use-libprefix-instead-of-libdir.patch \ | 13 | file://0001-Makefile-use-libprefix-instead-of-libdir.patch \ |
14 | file://0001-make-set-soname-on-liblmdb.patch;patchdir=../.. \ | ||
14 | " | 15 | " |
15 | 16 | ||
16 | SRCREV = "8ad7be2510414b9506ec9f9e24f24d04d9b04a1a" | 17 | SRCREV = "8ad7be2510414b9506ec9f9e24f24d04d9b04a1a" |
@@ -19,8 +20,6 @@ inherit ptest | |||
19 | 20 | ||
20 | S = "${WORKDIR}/git/libraries/liblmdb" | 21 | S = "${WORKDIR}/git/libraries/liblmdb" |
21 | 22 | ||
22 | LDFLAGS += "-Wl,-soname,lib${PN}.so.${PV}" | ||
23 | |||
24 | do_compile() { | 23 | do_compile() { |
25 | oe_runmake CC="${CC}" SOEXT=".so.${PV}" LDFLAGS="${LDFLAGS}" | 24 | oe_runmake CC="${CC}" SOEXT=".so.${PV}" LDFLAGS="${LDFLAGS}" |
26 | } | 25 | } |