summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-dasbus/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-dasbus_1.7.bb13
2 files changed, 2 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dasbus/run-ptest b/meta-python/recipes-devtools/python/python3-dasbus/run-ptest
deleted file mode 100755
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-dasbus/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-dasbus_1.7.bb b/meta-python/recipes-devtools/python/python3-dasbus_1.7.bb
index d1d294a284..141e6bfbaf 100644
--- a/meta-python/recipes-devtools/python/python3-dasbus_1.7.bb
+++ b/meta-python/recipes-devtools/python/python3-dasbus_1.7.bb
@@ -5,18 +5,14 @@ LICENSE = "LGPL-2.1-or-later"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742"
6 6
7SRC_URI = "git://github.com/dasbus-project/dasbus.git;protocol=https;branch=master \ 7SRC_URI = "git://github.com/dasbus-project/dasbus.git;protocol=https;branch=master \
8 file://run-ptest \
9" 8"
10SRCREV = "413cf9a0b7c231468f1d28d9a29dd8dd8bda15c5" 9SRCREV = "413cf9a0b7c231468f1d28d9a29dd8dd8bda15c5"
11 10
12S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
13 12
14inherit setuptools3 ptest 13inherit setuptools3 ptest-python-pytest
15
16do_install_ptest() {
17 install -d ${D}${PTEST_PATH}/tests
18 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
19 14
15do_install_ptest:append () {
20 # Remove the problematic cases 16 # Remove the problematic cases
21 # https://github.com/dasbus-project/dasbus/issues/128 17 # https://github.com/dasbus-project/dasbus/issues/128
22 rm -rf ${D}${PTEST_PATH}/tests/lib_dbus.py 18 rm -rf ${D}${PTEST_PATH}/tests/lib_dbus.py
@@ -25,8 +21,3 @@ do_install_ptest() {
25} 21}
26 22
27RDEPENDS:${PN} = "python3-pygobject" 23RDEPENDS:${PN} = "python3-pygobject"
28
29RDEPENDS:${PN}-ptest += " \
30 python3-pytest \
31 python3-unittest-automake-output \
32"