diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-jsmin/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-jsmin_2.2.2.bb | 14 |
2 files changed, 16 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsmin/run-ptest b/meta-python/recipes-devtools/python/python3-jsmin/run-ptest new file mode 100644 index 0000000000..cbcfffda5b --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-jsmin/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | python3 test.py | ||
diff --git a/meta-python/recipes-devtools/python/python3-jsmin_2.2.2.bb b/meta-python/recipes-devtools/python/python3-jsmin_2.2.2.bb index ab657e6f08..9b7a824087 100644 --- a/meta-python/recipes-devtools/python/python3-jsmin_2.2.2.bb +++ b/meta-python/recipes-devtools/python/python3-jsmin_2.2.2.bb | |||
@@ -4,8 +4,20 @@ SECTION = "devel/python" | |||
4 | LICENSE = "MIT" | 4 | LICENSE = "MIT" |
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3a3301ce2ad647e172f4a1016c67324d" | 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3a3301ce2ad647e172f4a1016c67324d" |
6 | 6 | ||
7 | inherit setuptools3 pypi | 7 | inherit setuptools3 pypi ptest |
8 | SRC_URI[md5sum] = "00e7a3179a4591aab2ee707b3214e2fd" | 8 | SRC_URI[md5sum] = "00e7a3179a4591aab2ee707b3214e2fd" |
9 | SRC_URI[sha256sum] = "b6df99b2cd1c75d9d342e4335b535789b8da9107ec748212706ef7bbe5c2553b" | 9 | SRC_URI[sha256sum] = "b6df99b2cd1c75d9d342e4335b535789b8da9107ec748212706ef7bbe5c2553b" |
10 | 10 | ||
11 | BBCLASSEXTEND = "native nativesdk" | 11 | BBCLASSEXTEND = "native nativesdk" |
12 | |||
13 | SRC_URI += " \ | ||
14 | file://run-ptest \ | ||
15 | " | ||
16 | |||
17 | RDEPENDS_${PN}-ptest += " \ | ||
18 | ${PYTHON_PN}-pytest \ | ||
19 | " | ||
20 | |||
21 | do_install_ptest() { | ||
22 | cp -f ${S}/jsmin/test.py ${D}${PTEST_PATH}/ | ||
23 | } | ||