summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-dbusmock/0001-Add-functionality-to-add-own-objects-to-internal-obj.patch (renamed from meta-python/recipes-devtools/python/python-dbusmock/0001-Add-functionality-to-add-own-objects-to-internal-obj.patch)0
-rw-r--r--meta-python/recipes-devtools/python/python3-dbusmock/0002-Add-possibility-to-import-templates-from-packages.patch (renamed from meta-python/recipes-devtools/python/python-dbusmock/0002-Add-possibility-to-import-templates-from-packages.patch)0
-rw-r--r--meta-python/recipes-devtools/python/python3-dbusmock_0.16.7.bb25
3 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-dbusmock/0001-Add-functionality-to-add-own-objects-to-internal-obj.patch b/meta-python/recipes-devtools/python/python3-dbusmock/0001-Add-functionality-to-add-own-objects-to-internal-obj.patch
index c4d817849f..c4d817849f 100644
--- a/meta-python/recipes-devtools/python/python-dbusmock/0001-Add-functionality-to-add-own-objects-to-internal-obj.patch
+++ b/meta-python/recipes-devtools/python/python3-dbusmock/0001-Add-functionality-to-add-own-objects-to-internal-obj.patch
diff --git a/meta-python/recipes-devtools/python/python-dbusmock/0002-Add-possibility-to-import-templates-from-packages.patch b/meta-python/recipes-devtools/python/python3-dbusmock/0002-Add-possibility-to-import-templates-from-packages.patch
index 06ab1f05e2..06ab1f05e2 100644
--- a/meta-python/recipes-devtools/python/python-dbusmock/0002-Add-possibility-to-import-templates-from-packages.patch
+++ b/meta-python/recipes-devtools/python/python3-dbusmock/0002-Add-possibility-to-import-templates-from-packages.patch
diff --git a/meta-python/recipes-devtools/python/python3-dbusmock_0.16.7.bb b/meta-python/recipes-devtools/python/python3-dbusmock_0.16.7.bb
new file mode 100644
index 0000000000..cd760ab893
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dbusmock_0.16.7.bb
@@ -0,0 +1,25 @@
1# Copyright (c) 2014 LG Electronics, Inc.
2
3SUMMARY = "With this program/Python library you can easily create mock objects on D-Bus"
4AUTHOR = "Martin Pitt <martin.pitt@ubuntu.com>"
5
6LICENSE = "GPL-3.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
8
9SRC_URI[md5sum] = "80f8caa838fad96483a8751e11d384f9"
10SRC_URI[sha256sum] = "2d2ea892fa4633c3ec6ac1e912120ec493047a5c6522849b7d1c95ad755bce75"
11
12SRC_URI += " \
13 file://0001-Add-functionality-to-add-own-objects-to-internal-obj.patch \
14 file://0002-Add-possibility-to-import-templates-from-packages.patch \
15"
16
17PYPI_PACKAGE = "python-dbusmock"
18
19inherit pypi setuptools3
20
21RDEPENDS_${PN} += "\
22 ${PYTHON_PN}-dbus \
23 ${PYTHON_PN}-pygobject \
24 ${PYTHON_PN}-xml \
25 "