diff options
-rw-r--r-- | meta-oe/recipes-support/thin-provisioning-tools/files/0001-do-not-strip-pdata_tools-at-do_install.patch | 12 | ||||
-rw-r--r-- | meta-oe/recipes-support/thin-provisioning-tools/files/0001-fix-compile-failed-with-libc-musl.patch | 42 | ||||
-rw-r--r-- | meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.7.6.bb (renamed from meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.6.3.bb) | 3 |
3 files changed, 50 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/thin-provisioning-tools/files/0001-do-not-strip-pdata_tools-at-do_install.patch b/meta-oe/recipes-support/thin-provisioning-tools/files/0001-do-not-strip-pdata_tools-at-do_install.patch index b4cdda1327..547949dd60 100644 --- a/meta-oe/recipes-support/thin-provisioning-tools/files/0001-do-not-strip-pdata_tools-at-do_install.patch +++ b/meta-oe/recipes-support/thin-provisioning-tools/files/0001-do-not-strip-pdata_tools-at-do_install.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From e8be402e20cbdfbd8192a171ac9904d9362103bf Mon Sep 17 00:00:00 2001 | 1 | From de869ad2cb19d81257a159770ebe27593a71593c Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Wed, 31 Aug 2016 01:35:40 -0400 | 3 | Date: Tue, 31 Jul 2018 11:29:51 +0800 |
4 | Subject: [PATCH] do not strip pdata_tools at do_install | 4 | Subject: [PATCH] do not strip pdata_tools at do_install |
5 | 5 | ||
6 | It caused QA Issue: | 6 | It caused QA Issue: |
@@ -17,11 +17,11 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | |||
17 | 1 file changed, 1 deletion(-) | 17 | 1 file changed, 1 deletion(-) |
18 | 18 | ||
19 | diff --git a/Makefile.in b/Makefile.in | 19 | diff --git a/Makefile.in b/Makefile.in |
20 | index 4264191..ac22042 100644 | 20 | index 02b75dd..df590b4 100644 |
21 | --- a/Makefile.in | 21 | --- a/Makefile.in |
22 | +++ b/Makefile.in | 22 | +++ b/Makefile.in |
23 | @@ -189,7 +189,6 @@ distclean: clean | 23 | @@ -267,7 +267,6 @@ MANPAGES:=$(patsubst %,man8/%.8,$(TOOLS)) |
24 | install: bin/pdata_tools | 24 | install: bin/pdata_tools $(MANPAGES) |
25 | $(INSTALL_DIR) $(BINDIR) | 25 | $(INSTALL_DIR) $(BINDIR) |
26 | $(INSTALL_PROGRAM) bin/pdata_tools $(BINDIR) | 26 | $(INSTALL_PROGRAM) bin/pdata_tools $(BINDIR) |
27 | - $(STRIP) $(BINDIR)/pdata_tools | 27 | - $(STRIP) $(BINDIR)/pdata_tools |
@@ -29,5 +29,5 @@ index 4264191..ac22042 100644 | |||
29 | ln -s -f pdata_tools $(BINDIR)/cache_dump | 29 | ln -s -f pdata_tools $(BINDIR)/cache_dump |
30 | ln -s -f pdata_tools $(BINDIR)/cache_metadata_size | 30 | ln -s -f pdata_tools $(BINDIR)/cache_metadata_size |
31 | -- | 31 | -- |
32 | 2.8.1 | 32 | 2.7.4 |
33 | 33 | ||
diff --git a/meta-oe/recipes-support/thin-provisioning-tools/files/0001-fix-compile-failed-with-libc-musl.patch b/meta-oe/recipes-support/thin-provisioning-tools/files/0001-fix-compile-failed-with-libc-musl.patch new file mode 100644 index 0000000000..28b44da567 --- /dev/null +++ b/meta-oe/recipes-support/thin-provisioning-tools/files/0001-fix-compile-failed-with-libc-musl.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From fcbcf9c494cca166106ae4cb03c1dd135ee4f25c Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Wed, 1 Aug 2018 09:34:00 +0800 | ||
4 | Subject: [PATCH] fix compile failed with libc musl | ||
5 | |||
6 | There is a failure while compiling with libc musl: | ||
7 | [snip] | ||
8 | |./block-cache/io_engine.h:18:17: error: expected | ||
9 | unqualified-id before numeric constant | ||
10 | | unsigned const PAGE_SIZE = 4096; | ||
11 | [snip] | ||
12 | |||
13 | The musl defeines macro PAGE_SIZE, undef it conditionally | ||
14 | could fix the issue. | ||
15 | |||
16 | http://musl.openwall.narkive.com/tO8vrHdP/why-musl-define-page-size | ||
17 | |||
18 | Upstream-Status: Submitted [git://github.com/jthornber/thin-provisioning-tools] | ||
19 | |||
20 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
21 | --- | ||
22 | block-cache/io_engine.h | 4 ++++ | ||
23 | 1 file changed, 4 insertions(+) | ||
24 | |||
25 | diff --git a/block-cache/io_engine.h b/block-cache/io_engine.h | ||
26 | index 1704251..e36b932 100644 | ||
27 | --- a/block-cache/io_engine.h | ||
28 | +++ b/block-cache/io_engine.h | ||
29 | @@ -12,6 +12,10 @@ | ||
30 | |||
31 | //---------------------------------------------------------------- | ||
32 | |||
33 | +// Musl defines | ||
34 | +#ifdef PAGE_SIZE | ||
35 | +#undef PAGE_SIZE | ||
36 | +#endif | ||
37 | namespace bcache { | ||
38 | using sector_t = uint64_t; | ||
39 | |||
40 | -- | ||
41 | 2.7.4 | ||
42 | |||
diff --git a/meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.6.3.bb b/meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.7.6.bb index 4a692dcf69..20cb17aa2c 100644 --- a/meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.6.3.bb +++ b/meta-oe/recipes-support/thin-provisioning-tools/thin-provisioning-tools_0.7.6.bb | |||
@@ -9,9 +9,10 @@ S = "${WORKDIR}/git" | |||
9 | 9 | ||
10 | SRC_URI = "git://github.com/jthornber/thin-provisioning-tools \ | 10 | SRC_URI = "git://github.com/jthornber/thin-provisioning-tools \ |
11 | file://0001-do-not-strip-pdata_tools-at-do_install.patch \ | 11 | file://0001-do-not-strip-pdata_tools-at-do_install.patch \ |
12 | file://0001-fix-compile-failed-with-libc-musl.patch \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | SRCREV = "49bfc12e9c7956c1ac134b24afbe1a6a602ce7d5" | 15 | SRCREV = "6f936992b8e6208a7838fcf1ec87c5bd3a694a77" |
15 | 16 | ||
16 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" | 17 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
17 | 18 | ||