diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyasn1-modules.inc | 29 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.7.bb | 31 |
2 files changed, 29 insertions, 31 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyasn1-modules.inc b/meta-python/recipes-devtools/python/python-pyasn1-modules.inc deleted file mode 100644 index ce9791993c..0000000000 --- a/meta-python/recipes-devtools/python/python-pyasn1-modules.inc +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | SUMMARY = "A collection of ASN.1-based protocols modules." | ||
2 | DESCRIPTION = "A collection of ASN.1 modules expressed in form of pyasn1\ | ||
3 | classes. Includes protocols PDUs definition (SNMP, LDAP etc.) and various\ | ||
4 | data structures (X.509, PKCS etc.)." | ||
5 | HOMEPAGE = "https://github.com/etingof/pyasn1-modules" | ||
6 | LICENSE = "BSD-2-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a14482d15c2249de3b6f0e8a47e021fd" | ||
8 | |||
9 | SRC_URI[md5sum] = "18c77d56abeef631d94f95ff2d652859" | ||
10 | SRC_URI[sha256sum] = "0c35a52e00b672f832e5846826f1fb7507907f7d52fba6faa9e3c4cbe874fe4b" | ||
11 | |||
12 | inherit pypi ptest | ||
13 | |||
14 | RDEPENDS_${PN} = "${PYTHON_PN}-pyasn1" | ||
15 | |||
16 | BBCLASSEXTEND = "native nativesdk" | ||
17 | |||
18 | SRC_URI += " \ | ||
19 | file://run-ptest \ | ||
20 | " | ||
21 | |||
22 | RDEPENDS_${PN}-ptest += " \ | ||
23 | ${PYTHON_PN}-pytest \ | ||
24 | " | ||
25 | |||
26 | do_install_ptest() { | ||
27 | install -d ${D}${PTEST_PATH}/tests | ||
28 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
29 | } | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.7.bb b/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.7.bb index 3b1186f06c..f2a836b04a 100644 --- a/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.7.bb +++ b/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.7.bb | |||
@@ -1,2 +1,29 @@ | |||
1 | require python-pyasn1-modules.inc | 1 | SUMMARY = "A collection of ASN.1-based protocols modules." |
2 | inherit setuptools3 | 2 | DESCRIPTION = "A collection of ASN.1 modules expressed in form of pyasn1\ |
3 | classes. Includes protocols PDUs definition (SNMP, LDAP etc.) and various\ | ||
4 | data structures (X.509, PKCS etc.)." | ||
5 | HOMEPAGE = "https://github.com/etingof/pyasn1-modules" | ||
6 | LICENSE = "BSD-2-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a14482d15c2249de3b6f0e8a47e021fd" | ||
8 | |||
9 | SRC_URI[md5sum] = "18c77d56abeef631d94f95ff2d652859" | ||
10 | SRC_URI[sha256sum] = "0c35a52e00b672f832e5846826f1fb7507907f7d52fba6faa9e3c4cbe874fe4b" | ||
11 | |||
12 | inherit pypi ptest setuptools3 | ||
13 | |||
14 | RDEPENDS_${PN} = "${PYTHON_PN}-pyasn1" | ||
15 | |||
16 | BBCLASSEXTEND = "native nativesdk" | ||
17 | |||
18 | SRC_URI += " \ | ||
19 | file://run-ptest \ | ||
20 | " | ||
21 | |||
22 | RDEPENDS_${PN}-ptest += " \ | ||
23 | ${PYTHON_PN}-pytest \ | ||
24 | " | ||
25 | |||
26 | do_install_ptest() { | ||
27 | install -d ${D}${PTEST_PATH}/tests | ||
28 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
29 | } | ||