summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch19
1 files changed, 11 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
index 819c8e5697..c71b16fece 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
+++ b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -1,4 +1,4 @@
1From f11b9c71080513f9b867ba8f40613ba2ebc6e960 Mon Sep 17 00:00:00 2001 1From dfb83a41aaeae326e9b6f02b233af375bc7b8815 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 29 Mar 2013 15:17:17 +0100 3Date: Fri, 29 Mar 2013 15:17:17 +0100
4Subject: [PATCH] setup.py: link in sysroot, not in host directories 4Subject: [PATCH] setup.py: link in sysroot, not in host directories
@@ -10,12 +10,12 @@ Upstream-status: Unknown
10 setup.py | 6 +++--- 10 setup.py | 6 +++---
11 1 file changed, 3 insertions(+), 3 deletions(-) 11 1 file changed, 3 insertions(+), 3 deletions(-)
12 12
13Index: M2Crypto-0.23.0/setup.py 13diff --git a/setup.py b/setup.py
14=================================================================== 14index 3407c82..15ed7cd 100644
15--- M2Crypto-0.23.0.orig/setup.py 15--- a/setup.py
16+++ M2Crypto-0.23.0/setup.py 16+++ b/setup.py
17@@ -62,7 +62,7 @@ class _M2CryptoBuildExt(build_ext.build_ 17@@ -127,7 +127,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
18 self.openssl = 'c:\\pkg' 18 self.openssl = os.path.join(self.openssl, 'OpenSSL')
19 else: 19 else:
20 self.libraries = ['ssl', 'crypto'] 20 self.libraries = ['ssl', 'crypto']
21- self.openssl = '/usr' 21- self.openssl = '/usr'
@@ -23,7 +23,7 @@ Index: M2Crypto-0.23.0/setup.py
23 23
24 def finalize_options(self): 24 def finalize_options(self):
25 '''Overloaded build_ext implementation to append custom openssl 25 '''Overloaded build_ext implementation to append custom openssl
26@@ -75,8 +75,8 @@ class _M2CryptoBuildExt(build_ext.build_ 26@@ -143,8 +143,8 @@ class _M2CryptoBuildExt(build_ext.build_ext):
27 if _openssl and os.path.isdir(_openssl): 27 if _openssl and os.path.isdir(_openssl):
28 self.openssl = _openssl 28 self.openssl = _openssl
29 29
@@ -34,3 +34,6 @@ Index: M2Crypto-0.23.0/setup.py
34 34
35 if platform.system() == "Linux": 35 if platform.system() == "Linux":
36 if _multiarch: # on Fedora/RHEL it is an empty string 36 if _multiarch: # on Fedora/RHEL it is an empty string
37--
382.7.4
39