diff options
-rw-r--r-- | meta-oe/recipes-support/links/files/ac-prog-cxx.patch | 24 | ||||
-rw-r--r-- | meta-oe/recipes-support/links/links-x11_2.16.bb | 53 | ||||
-rw-r--r-- | meta-oe/recipes-support/links/links-x11_2.7.bb | 31 | ||||
-rw-r--r-- | meta-oe/recipes-support/links/links.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/links/links_2.16.bb (renamed from meta-oe/recipes-support/links/links_2.7.bb) | 6 |
5 files changed, 75 insertions, 41 deletions
diff --git a/meta-oe/recipes-support/links/files/ac-prog-cxx.patch b/meta-oe/recipes-support/links/files/ac-prog-cxx.patch index 41c3826850..2dc57a5c83 100644 --- a/meta-oe/recipes-support/links/files/ac-prog-cxx.patch +++ b/meta-oe/recipes-support/links/files/ac-prog-cxx.patch | |||
@@ -1,11 +1,21 @@ | |||
1 | --- links-2.1pre20/configure.in.orig 2005-12-21 15:23:49.000000000 +0000 | 1 | From c00668541f68c17a5e453a4dcc2a86022b20af87 Mon Sep 17 00:00:00 2001 |
2 | +++ links-2.1pre20/configure.in 2005-12-21 15:23:59.000000000 +0000 | 2 | From: Martin Jansa <Martin.Jansa@gmail.com> |
3 | @@ -18,7 +18,7 @@ | 3 | Date: Mon, 30 Jul 2012 23:52:49 +0200 |
4 | |||
5 | --- | ||
6 | configure.in | 2 +- | ||
7 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
8 | |||
9 | diff --git a/configure.in b/configure.in | ||
10 | index 7c15b6b..9896631 100644 | ||
11 | --- a/configure.in | ||
12 | +++ b/configure.in | ||
13 | @@ -23,7 +23,7 @@ AM_CONFIG_HEADER(config.h) | ||
4 | dnl Checks for programs. | 14 | dnl Checks for programs. |
5 | AC_PROG_CC | 15 | AC_PROG_CC |
6 | 16 | ||
7 | -#AC_PROG_CXX | 17 | -dnl AC_PROG_CXX |
8 | +AC_PROG_CXX | 18 | +AC_PROG_CXX |
9 | #AC_PROG_AWK | 19 | dnl AC_PROG_AWK |
10 | #AM_PROG_LEX | 20 | dnl AM_PROG_LEX |
11 | #AC_PROG_YACC | 21 | dnl AC_PROG_YACC |
diff --git a/meta-oe/recipes-support/links/links-x11_2.16.bb b/meta-oe/recipes-support/links/links-x11_2.16.bb new file mode 100644 index 0000000000..f55a6fc7b3 --- /dev/null +++ b/meta-oe/recipes-support/links/links-x11_2.16.bb | |||
@@ -0,0 +1,53 @@ | |||
1 | # FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'. | ||
2 | # The following is the difference between the old and the new license text. | ||
3 | # Please update the LICENSE value if needed, and summarize the changes in | ||
4 | # the commit message via 'License-Update:' tag. | ||
5 | # (example: 'License-Update: copyright years updated.') | ||
6 | # | ||
7 | # The changes: | ||
8 | # | ||
9 | # --- COPYING | ||
10 | # +++ COPYING | ||
11 | # @@ -293,7 +293,7 @@ | ||
12 | # <one line to give the program's name and a brief idea of what it does.> | ||
13 | # Copyright (C) <year> <name of author> | ||
14 | # | ||
15 | # - on, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USAThis program is free software; you can redistribute it and/or modify | ||
16 | # + This program is free software; you can redistribute it and/or modify | ||
17 | # it under the terms of the GNU General Public License as published by | ||
18 | # the Free Software Foundation; either version 2 of the License, or | ||
19 | # (at your option) any later version. | ||
20 | # | ||
21 | # | ||
22 | |||
23 | require links.inc | ||
24 | |||
25 | DEPENDS += "virtual/libx11" | ||
26 | RCONFLICTS_${PN} = "links" | ||
27 | |||
28 | inherit distro_features_check | ||
29 | # depends on virtual/libx11 | ||
30 | REQUIRED_DISTRO_FEATURES = "x11" | ||
31 | |||
32 | SRC_URI += " file://links2.desktop \ | ||
33 | http://www.xora.org.uk/oe/links2.png;name=icon" | ||
34 | |||
35 | S = "${WORKDIR}/links-${PV}" | ||
36 | |||
37 | EXTRA_OECONF = "--enable-graphics \ | ||
38 | --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \ | ||
39 | --without-libtiff --without-svgalib --without-fb \ | ||
40 | --without-directfb --without-pmshell --without-atheos \ | ||
41 | --with-x --without-gpm" | ||
42 | |||
43 | do_install_append() { | ||
44 | install -d ${D}/${datadir}/applications | ||
45 | install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications | ||
46 | install -d ${D}/${datadir}/pixmaps | ||
47 | install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps | ||
48 | } | ||
49 | |||
50 | SRC_URI[md5sum] = "645fb0c0294e4c3268f94d307d394ffb" | ||
51 | SRC_URI[sha256sum] = "82f03038d5e050a65681b9888762af41c40fd42dec7e59a8d630bfb0ee134a3f" | ||
52 | SRC_URI[icon.md5sum] = "477e8787927c634614bac01b44355a33" | ||
53 | SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47" | ||
diff --git a/meta-oe/recipes-support/links/links-x11_2.7.bb b/meta-oe/recipes-support/links/links-x11_2.7.bb deleted file mode 100644 index 2ae11ac97e..0000000000 --- a/meta-oe/recipes-support/links/links-x11_2.7.bb +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | require links.inc | ||
2 | |||
3 | DEPENDS += "virtual/libx11" | ||
4 | RCONFLICTS_${PN} = "links" | ||
5 | |||
6 | inherit distro_features_check | ||
7 | # depends on virtual/libx11 | ||
8 | REQUIRED_DISTRO_FEATURES = "x11" | ||
9 | |||
10 | SRC_URI += " file://links2.desktop \ | ||
11 | http://www.xora.org.uk/oe/links2.png;name=icon" | ||
12 | |||
13 | S = "${WORKDIR}/links-${PV}" | ||
14 | |||
15 | EXTRA_OECONF = "--enable-graphics \ | ||
16 | --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \ | ||
17 | --without-libtiff --without-svgalib --without-fb \ | ||
18 | --without-directfb --without-pmshell --without-atheos \ | ||
19 | --with-x --without-gpm" | ||
20 | |||
21 | do_install_append() { | ||
22 | install -d ${D}/${datadir}/applications | ||
23 | install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications | ||
24 | install -d ${D}/${datadir}/pixmaps | ||
25 | install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps | ||
26 | } | ||
27 | |||
28 | SRC_URI[md5sum] = "d06aa6e14b2172d73188871a5357185a" | ||
29 | SRC_URI[sha256sum] = "0c182b1cbcdfd5cdcd2f75a6032d1a4b660d07c1225c1e07757cec81d3302130" | ||
30 | SRC_URI[icon.md5sum] = "477e8787927c634614bac01b44355a33" | ||
31 | SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47" | ||
diff --git a/meta-oe/recipes-support/links/links.inc b/meta-oe/recipes-support/links/links.inc index e072408206..d6aa2d2d4e 100644 --- a/meta-oe/recipes-support/links/links.inc +++ b/meta-oe/recipes-support/links/links.inc | |||
@@ -3,7 +3,7 @@ browser, similar to Lynx." | |||
3 | HOMEPAGE = "http://links.twibright.com/" | 3 | HOMEPAGE = "http://links.twibright.com/" |
4 | SECTION = "console/network" | 4 | SECTION = "console/network" |
5 | LICENSE = "GPLv2" | 5 | LICENSE = "GPLv2" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=65e735be2e05d5943803344148f57603" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b0c80473f97008e42e29a9f80fcc55ff" |
7 | DEPENDS = "jpeg libpng flex openssl zlib" | 7 | DEPENDS = "jpeg libpng flex openssl zlib" |
8 | 8 | ||
9 | SRC_URI = "http://links.twibright.com/download/links-${PV}.tar.bz2 \ | 9 | SRC_URI = "http://links.twibright.com/download/links-${PV}.tar.bz2 \ |
diff --git a/meta-oe/recipes-support/links/links_2.7.bb b/meta-oe/recipes-support/links/links_2.16.bb index e80dd7bca3..19ea7a67ba 100644 --- a/meta-oe/recipes-support/links/links_2.7.bb +++ b/meta-oe/recipes-support/links/links_2.16.bb | |||
@@ -9,5 +9,7 @@ EXTRA_OECONF = "--enable-graphics \ | |||
9 | --without-directfb --without-pmshell --without-atheos \ | 9 | --without-directfb --without-pmshell --without-atheos \ |
10 | --without-x" | 10 | --without-x" |
11 | 11 | ||
12 | SRC_URI[md5sum] = "d06aa6e14b2172d73188871a5357185a" | 12 | SRC_URI[md5sum] = "645fb0c0294e4c3268f94d307d394ffb" |
13 | SRC_URI[sha256sum] = "0c182b1cbcdfd5cdcd2f75a6032d1a4b660d07c1225c1e07757cec81d3302130" | 13 | SRC_URI[sha256sum] = "82f03038d5e050a65681b9888762af41c40fd42dec7e59a8d630bfb0ee134a3f" |
14 | SRC_URI[icon.md5sum] = "477e8787927c634614bac01b44355a33" | ||
15 | SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47" | ||