summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/asio/asio/0001-tests-Remove-blocking_adaptation.cpp.patch37
-rw-r--r--meta-oe/recipes-support/asio/asio/run-ptest19
-rw-r--r--meta-oe/recipes-support/asio/asio_1.30.2.bb19
3 files changed, 73 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/asio/asio/0001-tests-Remove-blocking_adaptation.cpp.patch b/meta-oe/recipes-support/asio/asio/0001-tests-Remove-blocking_adaptation.cpp.patch
new file mode 100644
index 0000000000..5aa502916d
--- /dev/null
+++ b/meta-oe/recipes-support/asio/asio/0001-tests-Remove-blocking_adaptation.cpp.patch
@@ -0,0 +1,37 @@
1From 7d76513b82a67e117d195a1b5a0d6c2e8591488b Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Thu, 10 Oct 2024 13:58:38 +0800
4Subject: [PATCH] tests: Remove blocking_adaptation.cpp
5
6The test failed to build with clang as below.
7../../../asio-1.30.2/src/tests/../../include/asio/execution/blocking_adaptation.hpp:216:13: error: call to 'query' is ambiguous
8 216 | conditional_t<true, T, P>::query(static_cast<P&&>(p))
9 | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
10../../../asio-1.30.2/src/tests/../../include/asio/execution/blocking_adaptation.hpp:213:29: note: in instantiation of exception specification for 'query<asio::execution::detail::blocking_adaptation::allowed_t<>>' requested here
11 213 | static constexpr auto query(P&& p)
12 |
13
14We can add the case back once the above build failure resolved then.
15
16Upstream-Status: Pending
17
18Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
19---
20 src/tests/Makefile.am | 1 -
21 1 file changed, 1 deletion(-)
22
23diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
24index 04f8a03..eab2d56 100644
25--- a/src/tests/Makefile.am
26+++ b/src/tests/Makefile.am
27@@ -68,7 +68,6 @@ check_PROGRAMS = \
28 unit/error \
29 unit/execution/any_executor \
30 unit/execution/blocking \
31- unit/execution/blocking_adaptation \
32 unit/execution/context_as \
33 unit/execution/executor \
34 unit/execution/invocable_archetype \
35--
362.34.1
37
diff --git a/meta-oe/recipes-support/asio/asio/run-ptest b/meta-oe/recipes-support/asio/asio/run-ptest
new file mode 100644
index 0000000000..d37db0b315
--- /dev/null
+++ b/meta-oe/recipes-support/asio/asio/run-ptest
@@ -0,0 +1,19 @@
1#!/bin/sh
2
3ptestdir=$(dirname "$(readlink -f "$0")")
4cd "$ptestdir"/tests || exit
5
6tests=$(find * -type f -executable)
7
8rm -rf test.log
9
10for f in $tests
11do
12 if test -x ./"$f"; then
13 if ./"$f" > test.log 2>&1; then
14 echo "PASS: $f"
15 else
16 echo "FAIL: $f"
17 fi
18 fi
19done
diff --git a/meta-oe/recipes-support/asio/asio_1.30.2.bb b/meta-oe/recipes-support/asio/asio_1.30.2.bb
index 6930381ecd..1f492b71eb 100644
--- a/meta-oe/recipes-support/asio/asio_1.30.2.bb
+++ b/meta-oe/recipes-support/asio/asio_1.30.2.bb
@@ -8,9 +8,12 @@ LICENSE = "BSL-1.0"
8 8
9DEPENDS = "openssl" 9DEPENDS = "openssl"
10 10
11SRC_URI = "${SOURCEFORGE_MIRROR}/asio/${BP}.tar.bz2" 11SRC_URI = "${SOURCEFORGE_MIRROR}/asio/${BP}.tar.bz2 \
12 file://0001-tests-Remove-blocking_adaptation.cpp.patch \
13 file://run-ptest \
14"
12 15
13inherit autotools 16inherit autotools ptest
14 17
15ALLOW_EMPTY:${PN} = "1" 18ALLOW_EMPTY:${PN} = "1"
16 19
@@ -22,4 +25,16 @@ PACKAGECONFIG ??= "boost"
22 25
23PACKAGECONFIG[boost] = "--with-boost=${STAGING_LIBDIR},--without-boost,boost" 26PACKAGECONFIG[boost] = "--with-boost=${STAGING_LIBDIR},--without-boost,boost"
24 27
28TESTDIR = "src/tests"
29do_compile_ptest() {
30 echo 'buildtest-TESTS: $(check_PROGRAMS)' >> ${TESTDIR}/Makefile
31 oe_runmake -C ${TESTDIR} buildtest-TESTS
32}
33
34do_install_ptest() {
35 install -d ${D}${PTEST_PATH}/tests
36 # copy executables
37 find ${B}/${TESTDIR}/unit -type f -executable -exec cp {} ${D}${PTEST_PATH}/tests/ \;
38}
39
25BBCLASSEXTEND = "native nativesdk" 40BBCLASSEXTEND = "native nativesdk"