summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-webserver/recipes-devtools/swagger-ui/swagger-ui_5.17.14.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-webserver/recipes-devtools/swagger-ui/swagger-ui_5.17.14.bb b/meta-webserver/recipes-devtools/swagger-ui/swagger-ui_5.17.14.bb
new file mode 100644
index 0000000000..de54370274
--- /dev/null
+++ b/meta-webserver/recipes-devtools/swagger-ui/swagger-ui_5.17.14.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Visually render documentation for an API defined with the OpenAPI"
2DESCRIPTION = "\
3 Swagger UI allows anyone — be it your development team or your end consumers — to visualize and \
4 interact with the API’s resources without having any of the implementation logic in place. \
5 It’s automatically generated from your OpenAPI (formerly known as Swagger) Specification, \
6 with the visual documentation making it easy for back end implementation and client side consumption. \
7 "
8HOMEPAGE = "https://github.com/swagger-api/swagger-ui"
9SECTION = "net"
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
12
13SRC_URI = "git://github.com/swagger-api/swagger-ui;branch=master;protocol=https"
14
15SRCREV = "74ed0adebfc9c8dd0de2bf8e81495b022a66c083"
16
17S = "${WORKDIR}/git"
18
19do_install() {
20 install -d ${D}${localstatedir}/www/openapi/static
21 cp -r ${S}/dist/* ${D}${localstatedir}/www/openapi/static
22}