diff options
-rw-r--r-- | meta-multimedia/recipes-multimedia/x265/x265/0001-json11.cpp-Include-cstdint.patch | 33 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/x265/x265_4.1.bb | 5 |
2 files changed, 37 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/x265/x265/0001-json11.cpp-Include-cstdint.patch b/meta-multimedia/recipes-multimedia/x265/x265/0001-json11.cpp-Include-cstdint.patch new file mode 100644 index 0000000000..f32316009f --- /dev/null +++ b/meta-multimedia/recipes-multimedia/x265/x265/0001-json11.cpp-Include-cstdint.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 6cbd417be3f6bcbda77464db6a4d83cef3df8904 Mon Sep 17 00:00:00 2001 | ||
2 | From: Leon Anavi <leon.anavi@konsulko.com> | ||
3 | Date: Mon, 5 May 2025 14:08:36 +0000 | ||
4 | Subject: [PATCH] json11.cpp: Include cstdint | ||
5 | |||
6 | Fixes: | ||
7 | |||
8 | json11.cpp:101:32: error: 'uint8_t' does not name a type | ||
9 | |||
10 | This work was sponsored by GOVCERT.LU. | ||
11 | |||
12 | Upstream-Status: Pending [https://bitbucket.org/multicoreware/x265_git/pull-requests/33] | ||
13 | |||
14 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
15 | --- | ||
16 | dynamicHDR10/json11/json11.cpp | 1 + | ||
17 | 1 file changed, 1 insertion(+) | ||
18 | |||
19 | diff --git a/dynamicHDR10/json11/json11.cpp b/dynamicHDR10/json11/json11.cpp | ||
20 | index 7625777..74f990a 100644 | ||
21 | --- a/dynamicHDR10/json11/json11.cpp | ||
22 | +++ b/dynamicHDR10/json11/json11.cpp | ||
23 | @@ -25,6 +25,7 @@ | ||
24 | #include <cstdlib> | ||
25 | #include <cstdio> | ||
26 | #include <limits> | ||
27 | +#include <cstdint> | ||
28 | |||
29 | #if _MSC_VER | ||
30 | #pragma warning(disable: 4510) //const member cannot be default initialized | ||
31 | -- | ||
32 | 2.39.5 | ||
33 | |||
diff --git a/meta-multimedia/recipes-multimedia/x265/x265_4.1.bb b/meta-multimedia/recipes-multimedia/x265/x265_4.1.bb index 23d6342d26..ae0f7758c1 100644 --- a/meta-multimedia/recipes-multimedia/x265/x265_4.1.bb +++ b/meta-multimedia/recipes-multimedia/x265/x265_4.1.bb | |||
@@ -8,7 +8,10 @@ LIC_FILES_CHKSUM = "file://../COPYING;md5=c9e0427bc58f129f99728c62d4ad4091" | |||
8 | 8 | ||
9 | DEPENDS = "nasm-native gnutls zlib libpcre numactl" | 9 | DEPENDS = "nasm-native gnutls zlib libpcre numactl" |
10 | 10 | ||
11 | SRC_URI = "https://bitbucket.org/multicoreware/x265_git/downloads/x265_${PV}.tar.gz" | 11 | SRC_URI = " \ |
12 | https://bitbucket.org/multicoreware/x265_git/downloads/x265_${PV}.tar.gz \ | ||
13 | file://0001-json11.cpp-Include-cstdint.patch \ | ||
14 | " | ||
12 | SRC_URI[sha256sum] = "a31699c6a89806b74b0151e5e6a7df65de4b49050482fe5ebf8a4379d7af8f29" | 15 | SRC_URI[sha256sum] = "a31699c6a89806b74b0151e5e6a7df65de4b49050482fe5ebf8a4379d7af8f29" |
13 | S = "${WORKDIR}/x265_${PV}/source" | 16 | S = "${WORKDIR}/x265_${PV}/source" |
14 | 17 | ||