summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-core/opencl/files/0001-Command-buffer-supported-queue-properties-265.patch42
-rw-r--r--meta-oe/recipes-core/opencl/opencl-headers_2024.10.24.bb4
2 files changed, 45 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/opencl/files/0001-Command-buffer-supported-queue-properties-265.patch b/meta-oe/recipes-core/opencl/files/0001-Command-buffer-supported-queue-properties-265.patch
new file mode 100644
index 0000000000..1654bf48c6
--- /dev/null
+++ b/meta-oe/recipes-core/opencl/files/0001-Command-buffer-supported-queue-properties-265.patch
@@ -0,0 +1,42 @@
1From 85888592e178c7923cd1bc1d69cee530906c80a4 Mon Sep 17 00:00:00 2001
2From: Ewan Crawford <ewan@codeplay.com>
3Date: Tue, 14 Jan 2025 17:14:29 +0000
4Subject: [PATCH] Command-buffer supported queue properties (#265)
5
6Header update generated from OpenCL-Docs PR XML change
7https://github.com/KhronosGroup/OpenCL-Docs/pull/850
8
9Upstream-Status: Backport [https://github.com/KhronosGroup/OpenCL-Headers/commit/d32c5bb219d7ba90ad4f251cf0bb903c08f8e5db]
10Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>
11---
12 CL/cl_ext.h | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/CL/cl_ext.h b/CL/cl_ext.h
16index 1a48985e167b..be5b473ff150 100644
17--- a/CL/cl_ext.h
18+++ b/CL/cl_ext.h
19@@ -52,7 +52,7 @@ extern "C" {
20 "cl_khr_command_buffer"
21
22
23-#define CL_KHR_COMMAND_BUFFER_EXTENSION_VERSION CL_MAKE_VERSION(0, 9, 5)
24+#define CL_KHR_COMMAND_BUFFER_EXTENSION_VERSION CL_MAKE_VERSION(0, 9, 6)
25
26 typedef cl_bitfield cl_device_command_buffer_capabilities_khr;
27 typedef struct _cl_command_buffer_khr* cl_command_buffer_khr;
28@@ -66,13 +66,13 @@ typedef struct _cl_mutable_command_khr* cl_mutable_command_khr;
29
30 /* cl_device_info */
31 #define CL_DEVICE_COMMAND_BUFFER_CAPABILITIES_KHR 0x12A9
32+#define CL_DEVICE_COMMAND_BUFFER_SUPPORTED_QUEUE_PROPERTIES_KHR 0x129A
33 #define CL_DEVICE_COMMAND_BUFFER_REQUIRED_QUEUE_PROPERTIES_KHR 0x12AA
34
35 /* cl_device_command_buffer_capabilities_khr - bitfield */
36 #define CL_COMMAND_BUFFER_CAPABILITY_KERNEL_PRINTF_KHR (1 << 0)
37 #define CL_COMMAND_BUFFER_CAPABILITY_DEVICE_SIDE_ENQUEUE_KHR (1 << 1)
38 #define CL_COMMAND_BUFFER_CAPABILITY_SIMULTANEOUS_USE_KHR (1 << 2)
39-#define CL_COMMAND_BUFFER_CAPABILITY_OUT_OF_ORDER_KHR (1 << 3)
40
41 /* cl_command_buffer_properties_khr */
42 #define CL_COMMAND_BUFFER_FLAGS_KHR 0x1293
diff --git a/meta-oe/recipes-core/opencl/opencl-headers_2024.10.24.bb b/meta-oe/recipes-core/opencl/opencl-headers_2024.10.24.bb
index b47d3f9711..412b573cb4 100644
--- a/meta-oe/recipes-core/opencl/opencl-headers_2024.10.24.bb
+++ b/meta-oe/recipes-core/opencl/opencl-headers_2024.10.24.bb
@@ -6,7 +6,9 @@ SECTION = "base"
6 6
7S = "${WORKDIR}/git" 7S = "${WORKDIR}/git"
8SRCREV = "4ea6df132107e3b4b9407f903204b5522fdffcd6" 8SRCREV = "4ea6df132107e3b4b9407f903204b5522fdffcd6"
9SRC_URI = "git://github.com/KhronosGroup/OpenCL-Headers.git;branch=main;protocol=https" 9SRC_URI = "git://github.com/KhronosGroup/OpenCL-Headers.git;branch=main;protocol=https \
10 file://0001-Command-buffer-supported-queue-properties-265.patch \
11 "
10 12
11inherit cmake 13inherit cmake
12 14