diff options
-rw-r--r-- | meta-oe/recipes-navigation/omgps/omgps/fix.build.with.gcc.4.9.patch | 22 | ||||
-rw-r--r-- | meta-oe/recipes-navigation/omgps/omgps_svn.bb | 3 |
2 files changed, 23 insertions, 2 deletions
diff --git a/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.gcc.4.9.patch b/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.gcc.4.9.patch new file mode 100644 index 0000000000..1680bc0627 --- /dev/null +++ b/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.gcc.4.9.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | omgps: omgps fails compilation due to uninitialized variables | ||
2 | |||
3 | omgps does not compile with gcc 4.9 due to uninitialized variables | ||
4 | with the option -Werror=maybe-uninitialized | ||
5 | To solve the problem, just initiated the variable and checked for side | ||
6 | effects. | ||
7 | Upstream-Status: Submitted | ||
8 | +https://code.google.com/p/omgps/issues/detail?id=16 | ||
9 | |||
10 | Signed-off-by: Raphael Silva <rapphil@gmail.com> | ||
11 | diff -urpN omgps.orig/src/sound.c omgps/src/sound.c | ||
12 | --- omgps.orig/src/sound.c 2014-12-14 15:13:29.609243994 -0200 | ||
13 | +++ omgps/src/sound.c 2014-12-14 15:14:13.831116745 -0200 | ||
14 | @@ -44,7 +44,7 @@ static gboolean play_sound_files(char *f | ||
15 | return FALSE; | ||
16 | |||
17 | char *bak = strdup(files); | ||
18 | - char *saveptr; | ||
19 | + char *saveptr = NULL; | ||
20 | char *p = strtok_r(bak, ";", &saveptr); | ||
21 | |||
22 | #define MAX_SOUND_FILES 14 | ||
diff --git a/meta-oe/recipes-navigation/omgps/omgps_svn.bb b/meta-oe/recipes-navigation/omgps/omgps_svn.bb index aabdd43f17..ea879d5612 100644 --- a/meta-oe/recipes-navigation/omgps/omgps_svn.bb +++ b/meta-oe/recipes-navigation/omgps/omgps_svn.bb | |||
@@ -9,8 +9,6 @@ PV = "0.1+svnr${SRCPV}" | |||
9 | PR = "r2" | 9 | PR = "r2" |
10 | S = "${WORKDIR}/${PN}" | 10 | S = "${WORKDIR}/${PN}" |
11 | 11 | ||
12 | PNBLACKLIST[omgps] ?= "BROKEN: sound.c:61:35: error: 'saveptr' may be used uninitialized in this function [-Werror=maybe-uninitialized]" | ||
13 | |||
14 | do_configure_prepend() { | 12 | do_configure_prepend() { |
15 | sed -i "s#PY_VERSION = 2.6#PY_VERSION = ${PYTHON_BASEVERSION}#g" ${S}/Makefile.am | 13 | sed -i "s#PY_VERSION = 2.6#PY_VERSION = ${PYTHON_BASEVERSION}#g" ${S}/Makefile.am |
16 | sed -i "s#PY_INC_DIR = \$(OPIEDIR)#PY_INC_DIR = ${STAGING_DIR_HOST}#g" ${S}/Makefile.am | 14 | sed -i "s#PY_INC_DIR = \$(OPIEDIR)#PY_INC_DIR = ${STAGING_DIR_HOST}#g" ${S}/Makefile.am |
@@ -24,6 +22,7 @@ SRC_URI = "svn://omgps.googlecode.com/svn/trunk;module=omgps;protocol=http \ | |||
24 | file://fix.build.with.glib.2.34.patch \ | 22 | file://fix.build.with.glib.2.34.patch \ |
25 | file://gdk-pixbuf-2.26.5.patch \ | 23 | file://gdk-pixbuf-2.26.5.patch \ |
26 | file://0001-g_type_init-is-deprecated-for-glib-2.35.0.patch \ | 24 | file://0001-g_type_init-is-deprecated-for-glib-2.35.0.patch \ |
25 | file://fix.build.with.gcc.4.9.patch \ | ||
27 | " | 26 | " |
28 | 27 | ||
29 | inherit autotools pkgconfig | 28 | inherit autotools pkgconfig |