summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-twisted.inc266
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted/0001-fix-MemoryReactor-import-in-test_runner-to-be-from-t.patch (renamed from meta-python/recipes-devtools/python/python-twisted/0001-fix-MemoryReactor-import-in-test_runner-to-be-from-t.patch)0
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted_19.10.0.bb264
3 files changed, 263 insertions, 267 deletions
diff --git a/meta-python/recipes-devtools/python/python-twisted.inc b/meta-python/recipes-devtools/python/python-twisted.inc
deleted file mode 100644
index 7537bafd3a..0000000000
--- a/meta-python/recipes-devtools/python/python-twisted.inc
+++ /dev/null
@@ -1,266 +0,0 @@
1DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
2Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \
3(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
4HOMEPAGE = "http://www.twistedmatrix.com"
5
6#twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL.
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=1743f12d8b8f5aec625c0569a058f0a6"
9
10# allow for common patches for python- and python3-twisted
11FILESEXTRAPATHS_prepend := "${THISDIR}/python-twisted:"
12
13SRC_URI += "file://0001-fix-MemoryReactor-import-in-test_runner-to-be-from-t.patch"
14
15SRC_URI[sha256sum] = "7394ba7f272ae722a74f3d969dcf599bc4ef093bc392038748a490f1724a515d"
16SRC_URI[md5sum] = "f2d70f7a66ecdf54152310164cceadfe"
17
18PYPI_PACKAGE = "Twisted"
19PYPI_PACKAGE_EXT = "tar.bz2"
20
21do_install_append() {
22 # remove some useless files before packaging
23 find ${D} \( -name "*.bat" -o -name "*.c" -o -name "*.h" \) -exec rm -f {} \;
24}
25
26PACKAGES += "\
27 ${PN}-zsh \
28 ${PN}-test \
29 ${PN}-protocols \
30 ${PN}-conch \
31 ${PN}-mail \
32 ${PN}-names \
33 ${PN}-news \
34 ${PN}-runner \
35 ${PN}-web \
36 ${PN}-words \
37 ${PN}-flow \
38 ${PN}-pair \
39 ${PN}-core \
40"
41
42PACKAGES =+ "\
43 ${PN}-bin \
44"
45
46DEPENDS += " \
47 ${PYTHON_PN}-incremental-native \
48"
49
50RDEPENDS_${PN} = "\
51 ${PN}-bin \
52 ${PN}-core \
53 ${PN}-conch \
54 ${PN}-mail \
55 ${PN}-names \
56 ${PN}-pair \
57 ${PN}-protocols \
58 ${PN}-runner \
59 ${PN}-web \
60 ${PN}-words \
61 ${PN}-zsh \
62"
63
64RDEPENDS_${PN}-core = "${PYTHON_PN}-appdirs \
65 ${PYTHON_PN}-automat \
66 ${PYTHON_PN}-constantly \
67 ${PYTHON_PN}-core \
68 ${PYTHON_PN}-debugger \
69 ${PYTHON_PN}-hyperlink \
70 ${PYTHON_PN}-incremental \
71 ${PYTHON_PN}-pyhamcrest \
72 ${PYTHON_PN}-pyserial \
73 ${PYTHON_PN}-unixadmin \
74 ${PYTHON_PN}-zopeinterface \
75"
76RDEPENDS_${PN}-test = "${PN}"
77RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols ${PYTHON_PN}-bcrypt ${PYTHON_PN}-cryptography ${PYTHON_PN}-pyasn1 ${PYTHON_PN}-pickle"
78RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols"
79RDEPENDS_${PN}-names = "${PN}-core"
80RDEPENDS_${PN}-news = "${PN}-core ${PN}-protocols"
81RDEPENDS_${PN}-runner = "${PN}-core ${PN}-protocols"
82RDEPENDS_${PN}-web += "${PN}-core ${PN}-protocols"
83RDEPENDS_${PN}-words += "${PN}-core"
84RDEPENDS_${PN}-flow += "${PN}-core"
85RDEPENDS_${PN}-pair += "${PN}-core"
86RDEPENDS_${PN}-dbg = "${PN}"
87
88ALLOW_EMPTY_${PN} = "1"
89FILES_${PN} = ""
90
91FILES_${PN}-test = " \
92 ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
93 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \
94 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy/test/ \
95"
96
97FILES_${PN}-protocols = " \
98 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \
99 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \
100 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \
101 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy \
102"
103
104FILES_${PN}-zsh = " \
105 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \
106 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
107 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/twisted-completion.zsh \
108"
109
110FILES_${PN}-conch = " \
111 ${bindir}/ckeygen \
112 ${bindir}/tkconch \
113 ${bindir}/conch \
114 ${bindir}/conchftp \
115 ${bindir}/cftp \
116 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
117 ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \
118"
119
120FILES_${PN}-core = " \
121${bindir}/manhole \
122${bindir}/mktap \
123${bindir}/twistd \
124${bindir}/tap2deb \
125${bindir}/tap2rpm \
126${bindir}/tapconvert \
127${bindir}/tkmktap \
128${bindir}/trial \
129${bindir}/easy_install* \
130${bindir}/pyhtmlizer \
131${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.so \
132${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
133${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \
134${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \
135${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \
136${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \
137${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \
138${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \
139${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \
140${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \
141${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \
142${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \
143${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \
144${libdir}/${PYTHON_DIR}/site-packages/twisted/application \
145${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \
146${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \
147${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \
148${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
149${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
150${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \
151${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\
152${libdir}/${PYTHON_DIR}/site-packages/twisted/python\
153${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \
154${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \
155${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \
156${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \
157${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \
158${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \
159${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \
160${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \
161${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \
162${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \
163${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \
164${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \
165${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \
166${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \
167${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \
168${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \
169${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \
170${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \
171${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \
172${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \
173${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \
174${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \
175${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \
176${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \
177${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \
178${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \
179${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \
180${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \
181${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \
182${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \
183${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \
184${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \
185${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \
186${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \
187${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \
188${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \
189${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \
190${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \
191${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \
192${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \
193${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \
194${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \
195${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
196${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
197${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
198${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
199${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
200${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
201${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
202${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \
203${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \
204${libdir}/${PYTHON_DIR}/site-packages/twisted/logger/ \
205${libdir}/${PYTHON_DIR}/site-packages/twisted/_threads/ \
206${libdir}/${PYTHON_DIR}/site-packages/twisted/positioning/ \
207"
208
209FILES_${PN}-mail = " \
210${bindir}/mailmail \
211${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \
212${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \
213"
214
215FILES_${PN}-names = " \
216${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \
217${libdir}/${PYTHON_DIR}/site-packages/twisted/names \
218"
219
220FILES_${PN}-news = " \
221${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \
222${libdir}/${PYTHON_DIR}/site-packages/twisted/news \
223"
224
225FILES_${PN}-runner = " \
226${libdir}/site-packages/twisted/runner/portmap.so \
227${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\
228"
229
230FILES_${PN}-web = " \
231${bindir}/websetroot \
232${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \
233${libdir}/${PYTHON_DIR}/site-packages/twisted/web\
234"
235
236FILES_${PN}-words = " \
237${bindir}/im \
238${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \
239${libdir}/${PYTHON_DIR}/site-packages/twisted/words\
240"
241
242FILES_${PN}-flow = " \
243${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \
244${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \"
245
246FILES_${PN}-pair = " \
247${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \
248${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \
249"
250
251FILES_${PN}-dbg += " \
252${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
253${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
254"
255
256FILES_${PN}-doc += " \
257 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_pydoctortemplates/ \
258"
259
260RDEPENDS_${PN}-src = "${PN}"
261FILES_${PN}-src = " \
262 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \
263 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \
264 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \
265"
266
diff --git a/meta-python/recipes-devtools/python/python-twisted/0001-fix-MemoryReactor-import-in-test_runner-to-be-from-t.patch b/meta-python/recipes-devtools/python/python3-twisted/0001-fix-MemoryReactor-import-in-test_runner-to-be-from-t.patch
index 39fc7d43e1..39fc7d43e1 100644
--- a/meta-python/recipes-devtools/python/python-twisted/0001-fix-MemoryReactor-import-in-test_runner-to-be-from-t.patch
+++ b/meta-python/recipes-devtools/python/python3-twisted/0001-fix-MemoryReactor-import-in-test_runner-to-be-from-t.patch
diff --git a/meta-python/recipes-devtools/python/python3-twisted_19.10.0.bb b/meta-python/recipes-devtools/python/python3-twisted_19.10.0.bb
index c12d1cc04e..f2fcd30b77 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_19.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_19.10.0.bb
@@ -1,5 +1,267 @@
1DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
2Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \
3(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
4HOMEPAGE = "http://www.twistedmatrix.com"
5
6#twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL.
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=1743f12d8b8f5aec625c0569a058f0a6"
9
10SRC_URI += "file://0001-fix-MemoryReactor-import-in-test_runner-to-be-from-t.patch"
11
12SRC_URI[sha256sum] = "7394ba7f272ae722a74f3d969dcf599bc4ef093bc392038748a490f1724a515d"
13SRC_URI[md5sum] = "f2d70f7a66ecdf54152310164cceadfe"
14
15PYPI_PACKAGE = "Twisted"
16PYPI_PACKAGE_EXT = "tar.bz2"
17
1inherit pypi setuptools3 18inherit pypi setuptools3
2require python-twisted.inc 19
20do_install_append() {
21 # remove some useless files before packaging
22 find ${D} \( -name "*.bat" -o -name "*.c" -o -name "*.h" \) -exec rm -f {} \;
23}
24
25PACKAGES += "\
26 ${PN}-zsh \
27 ${PN}-test \
28 ${PN}-protocols \
29 ${PN}-conch \
30 ${PN}-mail \
31 ${PN}-names \
32 ${PN}-news \
33 ${PN}-runner \
34 ${PN}-web \
35 ${PN}-words \
36 ${PN}-flow \
37 ${PN}-pair \
38 ${PN}-core \
39"
40
41PACKAGES =+ "\
42 ${PN}-bin \
43"
44
45DEPENDS += " \
46 ${PYTHON_PN}-incremental-native \
47"
48
49RDEPENDS_${PN} = "\
50 ${PN}-bin \
51 ${PN}-core \
52 ${PN}-conch \
53 ${PN}-mail \
54 ${PN}-names \
55 ${PN}-pair \
56 ${PN}-protocols \
57 ${PN}-runner \
58 ${PN}-web \
59 ${PN}-words \
60 ${PN}-zsh \
61"
62
63RDEPENDS_${PN}-core = "${PYTHON_PN}-appdirs \
64 ${PYTHON_PN}-automat \
65 ${PYTHON_PN}-constantly \
66 ${PYTHON_PN}-core \
67 ${PYTHON_PN}-debugger \
68 ${PYTHON_PN}-hyperlink \
69 ${PYTHON_PN}-incremental \
70 ${PYTHON_PN}-pyhamcrest \
71 ${PYTHON_PN}-pyserial \
72 ${PYTHON_PN}-unixadmin \
73 ${PYTHON_PN}-zopeinterface \
74"
75RDEPENDS_${PN}-test = "${PN}"
76RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols ${PYTHON_PN}-bcrypt ${PYTHON_PN}-cryptography ${PYTHON_PN}-pyasn1 ${PYTHON_PN}-pickle"
77RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols"
78RDEPENDS_${PN}-names = "${PN}-core"
79RDEPENDS_${PN}-news = "${PN}-core ${PN}-protocols"
80RDEPENDS_${PN}-runner = "${PN}-core ${PN}-protocols"
81RDEPENDS_${PN}-web += "${PN}-core ${PN}-protocols"
82RDEPENDS_${PN}-words += "${PN}-core"
83RDEPENDS_${PN}-flow += "${PN}-core"
84RDEPENDS_${PN}-pair += "${PN}-core"
85RDEPENDS_${PN}-dbg = "${PN}"
86
87ALLOW_EMPTY_${PN} = "1"
88FILES_${PN} = ""
89
90FILES_${PN}-test = " \
91 ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
92 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \
93 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy/test/ \
94"
95
96FILES_${PN}-protocols = " \
97 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \
98 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \
99 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \
100 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/haproxy \
101"
102
103FILES_${PN}-zsh = " \
104 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \
105 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
106 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/twisted-completion.zsh \
107"
108
109FILES_${PN}-conch = " \
110 ${bindir}/ckeygen \
111 ${bindir}/tkconch \
112 ${bindir}/conch \
113 ${bindir}/conchftp \
114 ${bindir}/cftp \
115 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
116 ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \
117"
118
119FILES_${PN}-core = " \
120${bindir}/manhole \
121${bindir}/mktap \
122${bindir}/twistd \
123${bindir}/tap2deb \
124${bindir}/tap2rpm \
125${bindir}/tapconvert \
126${bindir}/tkmktap \
127${bindir}/trial \
128${bindir}/easy_install* \
129${bindir}/pyhtmlizer \
130${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.so \
131${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
132${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \
133${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \
134${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \
135${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \
136${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \
137${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \
138${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \
139${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \
140${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \
141${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \
142${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \
143${libdir}/${PYTHON_DIR}/site-packages/twisted/application \
144${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \
145${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \
146${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \
147${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
148${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
149${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \
150${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\
151${libdir}/${PYTHON_DIR}/site-packages/twisted/python\
152${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \
153${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \
154${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \
155${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \
156${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \
157${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \
158${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \
159${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \
160${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \
161${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \
162${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \
163${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \
164${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \
165${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \
166${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \
167${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \
168${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \
169${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \
170${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \
171${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \
172${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \
173${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \
174${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \
175${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \
176${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \
177${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \
178${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \
179${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \
180${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \
181${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \
182${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \
183${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \
184${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \
185${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \
186${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \
187${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \
188${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \
189${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \
190${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \
191${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \
192${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \
193${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \
194${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
195${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
196${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
197${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
198${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
199${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
200${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
201${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \
202${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \
203${libdir}/${PYTHON_DIR}/site-packages/twisted/logger/ \
204${libdir}/${PYTHON_DIR}/site-packages/twisted/_threads/ \
205${libdir}/${PYTHON_DIR}/site-packages/twisted/positioning/ \
206"
207
208FILES_${PN}-mail = " \
209${bindir}/mailmail \
210${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \
211${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \
212"
213
214FILES_${PN}-names = " \
215${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \
216${libdir}/${PYTHON_DIR}/site-packages/twisted/names \
217"
218
219FILES_${PN}-news = " \
220${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \
221${libdir}/${PYTHON_DIR}/site-packages/twisted/news \
222"
223
224FILES_${PN}-runner = " \
225${libdir}/site-packages/twisted/runner/portmap.so \
226${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\
227"
228
229FILES_${PN}-web = " \
230${bindir}/websetroot \
231${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \
232${libdir}/${PYTHON_DIR}/site-packages/twisted/web\
233"
234
235FILES_${PN}-words = " \
236${bindir}/im \
237${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \
238${libdir}/${PYTHON_DIR}/site-packages/twisted/words\
239"
240
241FILES_${PN}-flow = " \
242${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \
243${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \"
244
245FILES_${PN}-pair = " \
246${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \
247${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \
248"
249
250FILES_${PN}-dbg += " \
251${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
252${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
253"
254
255FILES_${PN}-doc += " \
256 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_pydoctortemplates/ \
257"
258
259RDEPENDS_${PN}-src = "${PN}"
260FILES_${PN}-src = " \
261 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \
262 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \
263 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \
264"
3 265
4FILES_${PN}-core_append = " \ 266FILES_${PN}-core_append = " \
5 ${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \ 267 ${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \