diff options
-rw-r--r-- | meta-oe/recipes-extended/mraa/mraa/0001-include-endian.h-for-be16toh-and-le16toh-declaration.patch | 27 | ||||
-rw-r--r-- | meta-oe/recipes-extended/mraa/mraa_git.bb | 4 |
2 files changed, 30 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/mraa/mraa/0001-include-endian.h-for-be16toh-and-le16toh-declaration.patch b/meta-oe/recipes-extended/mraa/mraa/0001-include-endian.h-for-be16toh-and-le16toh-declaration.patch new file mode 100644 index 0000000000..711738a92b --- /dev/null +++ b/meta-oe/recipes-extended/mraa/mraa/0001-include-endian.h-for-be16toh-and-le16toh-declaration.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 2c85decc3b93bfe7322309d2ca7d6377e746c18f Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 5 Feb 2018 09:51:08 -0800 | ||
4 | Subject: [PATCH] include endian.h for be16toh and le16toh declarations | ||
5 | |||
6 | Upstream-Status: Submitted [https://github.com/intel-iot-devkit/mraa/pull/863] | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | examples/iio_driver.c | 1 + | ||
11 | 1 file changed, 1 insertion(+) | ||
12 | |||
13 | diff --git a/examples/iio_driver.c b/examples/iio_driver.c | ||
14 | index c5a0181..568011c 100644 | ||
15 | --- a/examples/iio_driver.c | ||
16 | +++ b/examples/iio_driver.c | ||
17 | @@ -22,6 +22,7 @@ | ||
18 | * WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. | ||
19 | */ | ||
20 | |||
21 | +#include <endian.h> | ||
22 | #include <unistd.h> | ||
23 | #include "mraa/iio.h" | ||
24 | |||
25 | -- | ||
26 | 2.16.1 | ||
27 | |||
diff --git a/meta-oe/recipes-extended/mraa/mraa_git.bb b/meta-oe/recipes-extended/mraa/mraa_git.bb index 16883be3a7..366d6b70f5 100644 --- a/meta-oe/recipes-extended/mraa/mraa_git.bb +++ b/meta-oe/recipes-extended/mraa/mraa_git.bb | |||
@@ -8,7 +8,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4b92a3b497d7943042a6db40c088c3f2" | |||
8 | SRCREV = "fbb7d9232067eac3f4508a37a8f7ea0c4fcebacb" | 8 | SRCREV = "fbb7d9232067eac3f4508a37a8f7ea0c4fcebacb" |
9 | PV = "1.9.0-git${SRCPV}" | 9 | PV = "1.9.0-git${SRCPV}" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http" | 11 | SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http \ |
12 | file://0001-include-endian.h-for-be16toh-and-le16toh-declaration.patch \ | ||
13 | " | ||
12 | 14 | ||
13 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
14 | 16 | ||