diff options
-rw-r--r-- | meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch | 42 | ||||
-rw-r--r-- | meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb | 1 |
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch b/meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch new file mode 100644 index 0000000000..cf97b491e1 --- /dev/null +++ b/meta-oe/recipes-support/multipath-tools/files/0001-fix-boolean-value-with-json-c-0.14.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From 5ae81386a8cfea4180738c261cd3f7944a631199 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 3 Jun 2020 16:03:56 -0700 | ||
4 | Subject: [PATCH] fix boolean value with json-c 0.14 | ||
5 | |||
6 | Patch from Christian Hesse posted here | ||
7 | https://www.spinics.net/lists/dm-devel/msg40646.html | ||
8 | |||
9 | Upstream json-c 0.14+ removed the TRUE and FALSE defines in commit | ||
10 | 0992aac61f8b087efd7094e9ac2b84fa9c040fcd. | ||
11 | |||
12 | Upstream-Status: Submitted [https://www.spinics.net/lists/dm-devel/msg40646.html] | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | libdmmp/libdmmp_private.h | 4 ++-- | ||
16 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
17 | |||
18 | diff --git a/libdmmp/libdmmp_private.h b/libdmmp/libdmmp_private.h | ||
19 | index ac85b63f..29400826 100644 | ||
20 | --- a/libdmmp/libdmmp_private.h | ||
21 | +++ b/libdmmp/libdmmp_private.h | ||
22 | @@ -82,7 +82,7 @@ static out_type func_name(struct dmmp_context *ctx, const char *var_name) { \ | ||
23 | do { \ | ||
24 | json_type j_type = json_type_null; \ | ||
25 | json_object *j_obj_tmp = NULL; \ | ||
26 | - if (json_object_object_get_ex(j_obj, key, &j_obj_tmp) != TRUE) { \ | ||
27 | + if (json_object_object_get_ex(j_obj, key, &j_obj_tmp) != 1) { \ | ||
28 | _error(ctx, "Invalid JSON output from multipathd IPC: " \ | ||
29 | "key '%s' not found", key); \ | ||
30 | rc = DMMP_ERR_IPC_ERROR; \ | ||
31 | @@ -90,7 +90,7 @@ do { \ | ||
32 | } \ | ||
33 | if (j_obj_tmp == NULL) { \ | ||
34 | _error(ctx, "BUG: Got NULL j_obj_tmp from " \ | ||
35 | - "json_object_object_get_ex() while it return TRUE"); \ | ||
36 | + "json_object_object_get_ex() while it return 1"); \ | ||
37 | rc = DMMP_ERR_BUG; \ | ||
38 | goto out; \ | ||
39 | } \ | ||
40 | -- | ||
41 | 2.27.0 | ||
42 | |||
diff --git a/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb b/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb index af34a4b392..0d03191373 100644 --- a/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb +++ b/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb | |||
@@ -45,6 +45,7 @@ SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http \ | |||
45 | file://0031-Always-use-devmapper-for-kpartx.patch \ | 45 | file://0031-Always-use-devmapper-for-kpartx.patch \ |
46 | file://0001-fix-bug-of-do_compile-and-do_install.patch \ | 46 | file://0001-fix-bug-of-do_compile-and-do_install.patch \ |
47 | file://0001-add-explicit-dependency-on-libraries.patch \ | 47 | file://0001-add-explicit-dependency-on-libraries.patch \ |
48 | file://0001-fix-boolean-value-with-json-c-0.14.patch \ | ||
48 | " | 49 | " |
49 | 50 | ||
50 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" | 51 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |