summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/perfetto/files/0001-Add-missing-header-cstdint-for-uintXX_t-types.patch58
-rw-r--r--meta-oe/recipes-devtools/perfetto/perfetto.bb3
2 files changed, 60 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/perfetto/files/0001-Add-missing-header-cstdint-for-uintXX_t-types.patch b/meta-oe/recipes-devtools/perfetto/files/0001-Add-missing-header-cstdint-for-uintXX_t-types.patch
new file mode 100644
index 0000000000..d08721ae65
--- /dev/null
+++ b/meta-oe/recipes-devtools/perfetto/files/0001-Add-missing-header-cstdint-for-uintXX_t-types.patch
@@ -0,0 +1,58 @@
1From e63949205682bbd2a0e33e256119472d704a2549 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 29 Jan 2023 22:03:01 -0800
4Subject: [PATCH] Add missing header <cstdint> for uintXX_t types
5
6This is detected by gcc-13
7gcc 13 moved some includes around and as a result <cstdint> is no
8longer transitively included [1]. Explicitly include it for uintXX_t.
9
10[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
11
12Upstream-Status: Submitted [https://android-review.googlesource.com/c/platform/external/perfetto/+/2399128]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 include/perfetto/ext/base/http/sha1.h | 1 +
16 include/perfetto/ext/base/uuid.h | 1 +
17 src/traced/probes/common/cpu_freq_info.h | 1 +
18 3 files changed, 3 insertions(+)
19
20diff --git a/include/perfetto/ext/base/http/sha1.h b/include/perfetto/ext/base/http/sha1.h
21index c583d69d4..7e3a48c83 100644
22--- a/include/perfetto/ext/base/http/sha1.h
23+++ b/include/perfetto/ext/base/http/sha1.h
24@@ -20,6 +20,7 @@
25 #include <stddef.h>
26
27 #include <array>
28+#include <cstdint>
29 #include <string>
30
31 namespace perfetto {
32diff --git a/include/perfetto/ext/base/uuid.h b/include/perfetto/ext/base/uuid.h
33index 1b4c53815..472042fab 100644
34--- a/include/perfetto/ext/base/uuid.h
35+++ b/include/perfetto/ext/base/uuid.h
36@@ -18,6 +18,7 @@
37 #define INCLUDE_PERFETTO_EXT_BASE_UUID_H_
38
39 #include <array>
40+#include <cstdint>
41 #include <string>
42
43 #include "perfetto/ext/base/optional.h"
44diff --git a/src/traced/probes/common/cpu_freq_info.h b/src/traced/probes/common/cpu_freq_info.h
45index 36f7f9c09..8232cbf64 100644
46--- a/src/traced/probes/common/cpu_freq_info.h
47+++ b/src/traced/probes/common/cpu_freq_info.h
48@@ -17,6 +17,7 @@
49 #ifndef SRC_TRACED_PROBES_COMMON_CPU_FREQ_INFO_H_
50 #define SRC_TRACED_PROBES_COMMON_CPU_FREQ_INFO_H_
51
52+#include <cstdint>
53 #include <map>
54 #include <string>
55 #include <vector>
56--
572.39.1
58
diff --git a/meta-oe/recipes-devtools/perfetto/perfetto.bb b/meta-oe/recipes-devtools/perfetto/perfetto.bb
index 1605de489f..3cc732b700 100644
--- a/meta-oe/recipes-devtools/perfetto/perfetto.bb
+++ b/meta-oe/recipes-devtools/perfetto/perfetto.bb
@@ -17,7 +17,8 @@ SRC_URI:append = " \
17 git://chromium.googlesource.com/external/github.com/llvm/llvm-project/libunwind.git;protocol=https;destsuffix=git/buildtools/libunwind;branch=main;name=libunwind \ 17 git://chromium.googlesource.com/external/github.com/llvm/llvm-project/libunwind.git;protocol=https;destsuffix=git/buildtools/libunwind;branch=main;name=libunwind \
18 git://android.googlesource.com/platform/external/zlib.git;branch=master;protocol=https;destsuffix=git/buildtools/zlib;name=zlib \ 18 git://android.googlesource.com/platform/external/zlib.git;branch=master;protocol=https;destsuffix=git/buildtools/zlib;name=zlib \
19 https://storage.googleapis.com/perfetto/gn-linux64-1968-0725d782;subdir=git/buildtools/;name=gn \ 19 https://storage.googleapis.com/perfetto/gn-linux64-1968-0725d782;subdir=git/buildtools/;name=gn \
20 file://0001-Remove-check_build_deps-build-steps.patch " 20 file://0001-Remove-check_build_deps-build-steps.patch \
21 file://0001-Add-missing-header-cstdint-for-uintXX_t-types.patch"
21 22
22SRCREV_protobuf = "6a59a2ad1f61d9696092f79b6d74368b4d7970a3" 23SRCREV_protobuf = "6a59a2ad1f61d9696092f79b6d74368b4d7970a3"
23SRCREV_libcxx = "d9040c75cfea5928c804ab7c235fed06a63f743a" 24SRCREV_libcxx = "d9040c75cfea5928c804ab7c235fed06a63f743a"