diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch | 29 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-anyjson/run-ptest | 3 |
2 files changed, 0 insertions, 32 deletions
diff --git a/meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch b/meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch deleted file mode 100644 index 2b9e6e52e8..0000000000 --- a/meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 4fb61d7c621599b0db9c2c45f4243f07936c5953 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 13 Oct 2021 08:20:00 -0700 | ||
4 | Subject: [PATCH] setup.py: Do not use 2to3 | ||
5 | |||
6 | This helps compiling with setuptools 0.58+ | ||
7 | and it seems to compile fine with python3 | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | setup.py | 2 -- | ||
12 | 1 file changed, 2 deletions(-) | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index 9fe4902..f2098e1 100644 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -2,8 +2,6 @@ import os | ||
19 | import sys | ||
20 | |||
21 | extra = {} | ||
22 | -if sys.version_info >= (3, 0): | ||
23 | - extra.update(use_2to3=True) | ||
24 | |||
25 | try: | ||
26 | from setuptools import setup, find_packages | ||
27 | -- | ||
28 | 2.33.0 | ||
29 | |||
diff --git a/meta-python/recipes-devtools/python/python3-anyjson/run-ptest b/meta-python/recipes-devtools/python/python3-anyjson/run-ptest deleted file mode 100644 index b63c4de0d9..0000000000 --- a/meta-python/recipes-devtools/python/python3-anyjson/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||