diff options
3 files changed, 0 insertions, 34 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb index a8a09b4d56..d90e6551e7 100644 --- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb +++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb | |||
@@ -424,7 +424,6 @@ RDEPENDS:packagegroup-meta-python3 = "\ | |||
424 | python3-tabulate \ | 424 | python3-tabulate \ |
425 | python3-term \ | 425 | python3-term \ |
426 | python3-termcolor \ | 426 | python3-termcolor \ |
427 | python3-test-generator \ | ||
428 | python3-textparser \ | 427 | python3-textparser \ |
429 | python3-texttable \ | 428 | python3-texttable \ |
430 | python3-thrift \ | 429 | python3-thrift \ |
@@ -535,7 +534,6 @@ RDEPENDS:packagegroup-meta-python3-ptest = "\ | |||
535 | python3-smpplib-ptest \ | 534 | python3-smpplib-ptest \ |
536 | python3-soupsieve-ptest \ | 535 | python3-soupsieve-ptest \ |
537 | python3-sqlparse-ptest \ | 536 | python3-sqlparse-ptest \ |
538 | python3-test-generator-ptest \ | ||
539 | python3-typeguard-ptest \ | 537 | python3-typeguard-ptest \ |
540 | python3-ujson-ptest \ | 538 | python3-ujson-ptest \ |
541 | python3-u-msgpack-python-ptest \ | 539 | python3-u-msgpack-python-ptest \ |
diff --git a/meta-python/recipes-devtools/python/python3-test-generator/run-ptest b/meta-python/recipes-devtools/python/python3-test-generator/run-ptest deleted file mode 100644 index 5cec711696..0000000000 --- a/meta-python/recipes-devtools/python/python3-test-generator/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb b/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb deleted file mode 100644 index 7f212ddd87..0000000000 --- a/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | SUMMARY = "Generator is a helper for generating test methods for nose while still using unittest." | ||
2 | DESCRIPTION = "Python package with modified subclasses of all stdlib XML \ | ||
3 | parsers that prevent any potentially malicious operation." | ||
4 | |||
5 | LICENSE = "ISC" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=041a2bff595d40ccb4b36356f89dab00" | ||
7 | |||
8 | SRC_URI += " \ | ||
9 | file://run-ptest \ | ||
10 | " | ||
11 | |||
12 | SRC_URI[md5sum] = "6c69e73ba5b4b3ed62f7bcda071c64f1" | ||
13 | SRC_URI[sha256sum] = "ad5925c814bfe79497b43df096e3bb52c166d1577f7aff160137301676232f4a" | ||
14 | |||
15 | inherit pypi setuptools3 ptest | ||
16 | |||
17 | RDEPENDS:${PN}-ptest += " \ | ||
18 | ${PYTHON_PN}-pytest \ | ||
19 | ${PYTHON_PN}-mock \ | ||
20 | " | ||
21 | |||
22 | do_install_ptest() { | ||
23 | install -d ${D}${PTEST_PATH}/tests | ||
24 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
25 | } | ||
26 | |||
27 | DEPENDS += "python3-nose-native" | ||
28 | |||
29 | RDEPENDS:${PN} += "python3-six" | ||