summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/itstool/itstool_2.0.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/itstool/itstool_2.0.5.bb b/meta-oe/recipes-support/itstool/itstool_2.0.5.bb
new file mode 100644
index 0000000000..b74d5f6078
--- /dev/null
+++ b/meta-oe/recipes-support/itstool/itstool_2.0.5.bb
@@ -0,0 +1,22 @@
1SUMMARY = "ITS Tool allows you to translate your XML documents with PO files"
2HOMEPAGE = "http://itstool.org/"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5"
5
6inherit autotools python3native
7
8DEPENDS = "python3-native python3-lxml-native"
9
10SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2"
11SRC_URI[md5sum] = "655c6f78fc64faee45adcc45ccc5a57e"
12SRC_URI[sha256sum] = "100506f8df62cca6225ec3e631a8237e9c04650c77495af4919ac6a100d4b308"
13
14do_install_append() {
15 # fix shebang of main script
16 sed -i 's:${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN}:${bindir}/${PYTHON_PN}:g' ${D}${bindir}/itstool
17}
18
19BBCLASSEXTEND = "native"
20
21RDEPENDS_${PN} += "python3 python3-lxml"
22