diff options
3 files changed, 93 insertions, 44 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/0001-Set-paths-to-ssh-agent-and-ssh-add-by-configure-opti.patch b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/0001-Set-paths-to-ssh-agent-and-ssh-add-by-configure-opti.patch new file mode 100644 index 0000000000..32eecf8fb7 --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/0001-Set-paths-to-ssh-agent-and-ssh-add-by-configure-opti.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From e6464e01bc1cdf5496be2942d1bac41aa609f47e Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> | ||
3 | Date: Thu, 23 May 2019 23:44:06 +0200 | ||
4 | Subject: [PATCH] Set paths to ssh-agent and ssh-add by configure options | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | We have no executables in our sysroot so configuration won't find them. | ||
10 | |||
11 | Upstream-Status: Inappropriate [OE specific] | ||
12 | |||
13 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> | ||
14 | --- | ||
15 | configure.ac | 11 +++++++++-- | ||
16 | 1 file changed, 9 insertions(+), 2 deletions(-) | ||
17 | |||
18 | diff --git a/configure.ac b/configure.ac | ||
19 | index 4b83664..eda0c96 100644 | ||
20 | --- a/configure.ac | ||
21 | +++ b/configure.ac | ||
22 | @@ -351,8 +351,15 @@ if test "$enable_ssh_agent" = "no"; then | ||
23 | SSH_AGENT=false | ||
24 | SSH_ADD=false | ||
25 | else | ||
26 | - AC_PATH_PROG([SSH_AGENT], [ssh-agent], [no]) | ||
27 | - AC_PATH_PROG([SSH_ADD], [ssh-add], [no]) | ||
28 | + AC_ARG_WITH([ssh-agent-path], | ||
29 | + [AC_HELP_STRING([--with-ssh-agent-path=PATH], | ||
30 | + [path to ssh-agent])], | ||
31 | + [SSH_AGENT=$with_ssh_agent_path], [SSH_AGENT=no]) | ||
32 | + AC_ARG_WITH([ssh-add-path], | ||
33 | + [AC_HELP_STRING([--with-ssh-add-path=PATH], | ||
34 | + [path to ssh-add])], | ||
35 | + [SSH_ADD=$with_ssh_add_path], [SSH_ADD=no]) | ||
36 | + | ||
37 | if test "$SSH_AGENT" = "no" -o "$SSH_ADD" = "no"; then | ||
38 | AC_MSG_ERROR([the ssh-agent and ssh-add commands were not found]) | ||
39 | else | ||
40 | -- | ||
41 | 2.20.1 | ||
42 | |||
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.28.2.bb b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.28.2.bb deleted file mode 100644 index a84c218e6f..0000000000 --- a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.28.2.bb +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | SUMMARY = "Password and keyring managing daemon" | ||
2 | HOMEPAGE = "http://www.gnome.org/" | ||
3 | BUGTRACKER = "https://bugzilla.gnome.org/" | ||
4 | SECTION = "x11/gnome" | ||
5 | |||
6 | LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+" | ||
7 | LIC_FILES_CHKSUM = " \ | ||
8 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
9 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ | ||
10 | " | ||
11 | |||
12 | inherit features_check gnomebase remove-libtool gettext upstream-version-is-even | ||
13 | |||
14 | DEPENDS = " \ | ||
15 | intltool-native \ | ||
16 | glib-2.0-native \ | ||
17 | gtk+3 \ | ||
18 | gcr \ | ||
19 | libgcrypt \ | ||
20 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} \ | ||
21 | " | ||
22 | |||
23 | SRC_URI[archive.md5sum] = "284580f954f762caf62aed2ae7358177" | ||
24 | SRC_URI[archive.sha256sum] = "81171b7d07211b216b4c9bb79bf2deb3deca18fe8d56d46dda1c4549b4a2646a" | ||
25 | SRC_URI += "file://musl.patch" | ||
26 | |||
27 | REQUIRED_DISTRO_FEATURES = "x11" | ||
28 | |||
29 | RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils" | ||
30 | |||
31 | EXTRA_OECONF = "--disable-doc \ | ||
32 | ac_cv_path_SSH_AGENT=${bindir}/ssh-agent \ | ||
33 | ac_cv_path_SSH_ADD=${bindir}/ssh-add" | ||
34 | |||
35 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" | ||
36 | PACKAGECONFIG[pam] = "--enable-pam --with-pam-dir=${base_libdir}/security, --disable-pam" | ||
37 | PACKAGECONFIG[ssh-agent] = "--enable-ssh-agent,--disable-ssh-agent,,openssh-misc" | ||
38 | |||
39 | FILES_${PN} += " \ | ||
40 | ${datadir}/dbus-1/services \ | ||
41 | ${datadir}/p11-kit \ | ||
42 | ${base_libdir}/security/*${SOLIBSDEV} \ | ||
43 | ${libdir}/pkcs11/gnome-keyring-pkcs11.so \ | ||
44 | " | ||
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.34.0.bb b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.34.0.bb new file mode 100644 index 0000000000..52c254b288 --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_3.34.0.bb | |||
@@ -0,0 +1,51 @@ | |||
1 | SUMMARY = "Password and keyring managing daemon" | ||
2 | HOMEPAGE = "http://www.gnome.org/" | ||
3 | BUGTRACKER = "https://bugzilla.gnome.org/" | ||
4 | SECTION = "x11/gnome" | ||
5 | |||
6 | LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+" | ||
7 | LIC_FILES_CHKSUM = " \ | ||
8 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
9 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ | ||
10 | " | ||
11 | |||
12 | DEPENDS = " \ | ||
13 | glib-2.0-native \ | ||
14 | gtk+3 \ | ||
15 | gcr \ | ||
16 | libgcrypt \ | ||
17 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} \ | ||
18 | " | ||
19 | |||
20 | inherit gnomebase gsettings features_check remove-libtool gettext upstream-version-is-even | ||
21 | |||
22 | REQUIRED_DISTRO_FEATURES = "x11" | ||
23 | |||
24 | SRC_URI[archive.md5sum] = "7c8fd85e46ed4ba1add0288b2ead9aec" | ||
25 | SRC_URI[archive.sha256sum] = "e9cda9542a3e37c61636145e7e9e2513c569092ea8020752a834e1f40ad41943" | ||
26 | SRC_URI += " \ | ||
27 | file://0001-Set-paths-to-ssh-agent-and-ssh-add-by-configure-opti.patch \ | ||
28 | file://musl.patch \ | ||
29 | " | ||
30 | |||
31 | PACKAGECONFIG ??= "ssh-agent" | ||
32 | PACKAGECONFIG[ssh-agent] = "--enable-ssh-agent --with-ssh-agent-path=${bindir}/ssh-agent --with-ssh-add-path=${bindir}/ssh-add,--disable-ssh-agent,,openssh-misc" | ||
33 | |||
34 | EXTRA_OECONF = " \ | ||
35 | --disable-doc \ | ||
36 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam --with-pam-dir=${base_libdir}/security', '--disable-pam', d)} \ | ||
37 | " | ||
38 | |||
39 | FILES_${PN} += " \ | ||
40 | ${datadir}/dbus-1/services \ | ||
41 | ${datadir}/p11-kit \ | ||
42 | ${base_libdir}/security/*${SOLIBSDEV} \ | ||
43 | ${libdir}/pkcs11/gnome-keyring-pkcs11.so \ | ||
44 | " | ||
45 | |||
46 | # fix | gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used | ||
47 | # This does not make it through pseudo so perform on-target - sigh | ||
48 | pkg_postinst_ontarget_${PN} () { | ||
49 | setcap cap_ipc_lock+ep `which gnome-keyring-daemon` | ||
50 | } | ||
51 | RDEPENDS_${PN} += "libcap-bin" | ||