diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pytest-mock/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pytest-mock_3.10.0.bb | 26 |
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock/run-ptest b/meta-python/recipes-devtools/python/python3-pytest-mock/run-ptest new file mode 100644 index 0000000000..b63c4de0d9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pytest-mock/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock_3.10.0.bb b/meta-python/recipes-devtools/python/python3-pytest-mock_3.10.0.bb new file mode 100644 index 0000000000..c4e672f333 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pytest-mock_3.10.0.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | SUMMARY = "Thin-wrapper around the mock package for easier use with pytest" | ||
2 | HOMEPAGE = "https://github.com/pytest-dev/pytest-mock/" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = " \ | ||
5 | file://LICENSE;md5=b2ddb1e69238461b7e4ef2a84d874109 \ | ||
6 | " | ||
7 | |||
8 | SRC_URI = " \ | ||
9 | git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \ | ||
10 | file://run-ptest \ | ||
11 | " | ||
12 | |||
13 | SRCREV ?= "6c03dfd4240de4a178bab67c0a32fba28d8bcf91" | ||
14 | |||
15 | SRC_URI[sha256sum] = "fbbdb085ef7c252a326fd8cdcac0aa3b1333d8811f131bdcc701002e1be7ed4f" | ||
16 | |||
17 | inherit setuptools3 ptest | ||
18 | |||
19 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
20 | |||
21 | S = "${WORKDIR}/git" | ||
22 | |||
23 | do_install_ptest() { | ||
24 | install -d ${D}${PTEST_PATH}/tests | ||
25 | cp -rf ${S}/tests ${D}${PTEST_PATH}/ | ||
26 | } | ||