summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/librcf/librcf/aarch64-support.patch16
-rw-r--r--meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb4
2 files changed, 10 insertions, 10 deletions
diff --git a/meta-oe/recipes-devtools/librcf/librcf/aarch64-support.patch b/meta-oe/recipes-devtools/librcf/librcf/aarch64-support.patch
index 28cd0fe60b..e08efb92f7 100644
--- a/meta-oe/recipes-devtools/librcf/librcf/aarch64-support.patch
+++ b/meta-oe/recipes-devtools/librcf/librcf/aarch64-support.patch
@@ -3,11 +3,11 @@ Index: RCF-2.2.0.0/src/RCF/ByteOrdering.cpp
3--- RCF-2.2.0.0.orig/src/RCF/ByteOrdering.cpp 3--- RCF-2.2.0.0.orig/src/RCF/ByteOrdering.cpp
4+++ RCF-2.2.0.0/src/RCF/ByteOrdering.cpp 4+++ RCF-2.2.0.0/src/RCF/ByteOrdering.cpp
5@@ -60,7 +60,7 @@ namespace RCF { 5@@ -60,7 +60,7 @@ namespace RCF {
6 6
7 const ByteOrder MachineByteOrder = LittleEndian; 7 const ByteOrder MachineByteOrder = LittleEndian;
8 8
9-#elif defined(__arm__) 9-#elif defined(__arm__)
10+#elif defined(__arm__) || defined(__aarch64__) 10+#elif defined(__arm__) || defined(__aarch64__)
11 11
12 const ByteOrder MachineByteOrder = LittleEndian; 12 const ByteOrder MachineByteOrder = LittleEndian;
13 13
diff --git a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
index 51ad7ec9cd..cf0a8e7b1c 100644
--- a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
+++ b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
@@ -8,7 +8,7 @@ HOMEPAGE = "http://www.deltavsoft.com/"
8SECTION = "libs" 8SECTION = "libs"
9PRIORITY = "optional" 9PRIORITY = "optional"
10LICENSE = "GPLv2" 10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://license.txt;md5=137c2935b51c95068a8b1bbd434ffe2d" 11LIC_FILES_CHKSUM = "file://license.txt;md5=7586a312b9e978f9d6fac9a5780d1f84"
12 12
13SRC_URI = "http://www.deltavsoft.com/downloads/RCF-${PV}.tar.gz \ 13SRC_URI = "http://www.deltavsoft.com/downloads/RCF-${PV}.tar.gz \
14 file://0001-Add-CMake-build-files.patch \ 14 file://0001-Add-CMake-build-files.patch \
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "bbfcc88de502c39604878c395f516b03fff4eac63eb4f7f44c07d43383
20 20
21S = "${WORKDIR}/RCF-${PV}" 21S = "${WORKDIR}/RCF-${PV}"
22 22
23inherit cmake 23inherit cmake dos2unix
24 24
25PACKAGECONFIG ?= "zlib openssl sf-serialization boost-filesystem boost-asio protobuf json dll static shared demos" 25PACKAGECONFIG ?= "zlib openssl sf-serialization boost-filesystem boost-asio protobuf json dll static shared demos"
26PACKAGECONFIG[zlib] = "-DLIBRCF_USE_ZLIB=ON,-DLIBRCF_USE_ZLIB=OFF,zlib,zlib" 26PACKAGECONFIG[zlib] = "-DLIBRCF_USE_ZLIB=ON,-DLIBRCF_USE_ZLIB=OFF,zlib,zlib"